Yahoo Messenger can't send/receive files w/NOD32 http checking enabled

Discussion in 'ESET NOD32 Antivirus' started by mchaney, Jan 18, 2010.

Thread Status:
Not open for further replies.
  1. mchaney

    mchaney Registered Member

    Joined:
    Jan 18, 2010
    Posts:
    3
    I found some links on the web but no good solutions. I use Yahoo Messenger and I am unable to send or receive larger (>about 5 MB) files to my friends on Yahoo Messenger. What happens, for example, is that when I send a file, the progress meter jumps to full immediately even though the file is still being received on the other end. Then YM times out and the transfer fails.

    If I open NOD32 and go to "Web Access Protection" and UNcheck "Enable HTTP Checking", the file transfer works fine. Recheck the box, and no go.

    Certainly seems like a bug in NOD32. I don't like unchecking "Enable HTTP Checking" all the time because I certainly want virus protection when using a web browser. Maybe there's a smarter workaround? Or better yet, a bug fix for NOD32?

    Mike
     
  2. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Ensure that you don not have additional file transfer parameters set.
    It may be an issue with Yahoo, check your documentation, I know of others that use IM to exchange extemely large files without issue.
    Note that the above Solution applies to Windows Live Messenger, yet the optional parameters are generally the same.
     
  3. mchaney

    mchaney Registered Member

    Joined:
    Jan 18, 2010
    Posts:
    3
    I've checked everything I can possibly check and there's nothing in Yahoo that could affect it. This problem happens in other file transfer arenas as well (with NOD32) not just Yahoo Messenger. I found the trick to uncheck "Enable HTTP checking" in another thread from users using megaupload:

    ~Untrustworthy link removed.~



    I have the same symptoms (progress bar instantly goes to finished and then times out). Unchecking "enable http checking" in NOD32 fixes it just like in the above thread. Also using Win7 x64.

    Mike
     
    Last edited by a moderator: Jan 20, 2010
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    This behavior shouldn't occur with v. 4.2
     
  5. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Assuming this behaviour would not be enountered with the Beta, it would be up to you to trial run it in an attempt to see if it resolves your IM issues.
     
  6. mchaney

    mchaney Registered Member

    Joined:
    Jan 18, 2010
    Posts:
    3
    It's better! The 4.2 beta corrects the problem when I send files, but when I receive, it still does the same thing: the sender sees an instantaneous completion and my end times out. This time though, unchecking "http checking" does NOT fix it (in the beta)! So that part is actually worse.

    Also, could you make a right click on the task bar icon and "Disable real time protection" really disable real time protection? Obviously some stuff is still running because I have to completely uninstall NOD32 to get this to work. If I could just disable protection (for real), I'd be happy enough.

    Thanks,
    Mike
     
  7. siljaline

    siljaline Former Poster

    Joined:
    Jun 29, 2003
    Posts:
    6,619
    Glad that your situation is better yet not completely solved.
    This still may be due to a time-out issue with your IM and not NOD32_Beta4.2
    It may depend on the size and format of files your are swapping.
    Developer Alert !
     
  8. dyko

    dyko Registered Member

    Joined:
    Feb 19, 2010
    Posts:
    2
    i've got a solution in nod 32 http checking i erase 80, protocol number, i don't know if realy is a better solutin but it works i hope do not make a damage :) from many searching i found that protocol 80 is from filetransfer.msg.yahoo.com
     
    Last edited: Feb 19, 2010
  9. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Effectively this is equal to disabling web protection. Did you try installing EAV 4.2 beta?
     
  10. dyko

    dyko Registered Member

    Joined:
    Feb 19, 2010
    Posts:
    2
    yes and is the same problem ....
     
  11. mlittle1105

    mlittle1105 Registered Member

    Joined:
    May 22, 2008
    Posts:
    29
    Sounds pretty similar to the issue I was having, described here.

    This is something that ESET really needs to examine thoroughly and fix.
     
Thread Status:
Not open for further replies.