ESS 6.0.308.0 - VPN "no network access" & broken ESET GUI issue

Discussion in 'ESET Smart Security' started by Ybsteg, Mar 2, 2013.

Thread Status:
Not open for further replies.
  1. Ybsteg

    Ybsteg Registered Member

    Mar 2, 2013
    Re: Eset SS 6 - egui.exe crashing and hang

    Long story short – today, after uninstallation of ESET Smart Security 6RC and a few repeated uninstallations and installations of ESET Smart Security 6.0.308.0 including manual uninstallation in Safe Mode on Windows 8 64-bit, because of the problem with connected VPN with no network access, now I have broken ESET GUI in forms and in the tree of Advanced Setup – no checkboxes, text only buttons, tooltips have black background… Practically I could not use graphical user interface at all!

    Reading this forum I’ve found same problem here with NOD32 on Windows 8. According to poster Paul Coddington I’ve added ESET installation folder (c:\Program Files\ESET\ESET Smart Security\) to system %PATH% variable and now ESET GUI looks normal.

    But now I’ve started experiencing problems with ESET failing to read firewall configuration very often!? Somehow I believe that these issues are not interconnected?!

    At the end, I have not solved problem with microsoft Window 8 VPN “no network access” erratic not-connectivity (interesting everything is working fine on virtual Widows 7 64-bit on the same physical computer) and I have a new problem with ESET Smart Security 6 that I haven’t before all this trou8les. o_O

    What should I do with ESS?
    Reinstall it? I’ve already tried reinstalling graphic drivers (NVIDIA Optimus) with no change in ESS broken GUI behavior (it is temporarily solved).
    Get back to Win 7 and patiently wait for Win 9? ;)
    I’ll stay on Win 8 :rolleyes: and stick to ESET! :)


    Here is longer story for readers with extra time to spend for nothing:
    A few days ago I’ve started having problems with VPN connection (PPTP) on my Windows 8 Pro 64-bit which was working normally since (clean) installation of Windows 8. VPN connects, but there is no network access! Can’t access server, can’t ping, can’t do nothing remote.
    Trying to solve that red-hot problem I’ve stumbled upon Microsoft Technet forum thread where some people pointed that “third party firewall programs” can be a cause of the issue with VPN connectivity in Windows 8, and ESET was quite often mentioned as a problematic.

    As an old long-term ESET user I disbelieved that, but germ of doubt grew…

    I had ESET Smart Security 6 RC installed back in October 2012 when I moved to Windows 8 (still regretting that move) and everything, including VPN connection, was working normally (besides the fact that I can’t connect to VPN automatically as in Windows 7 – I must click on the “charm” “Connect” on selected VPN connection, even when that connection is started from batch! :ouch: ).

    In order to try every possible solution for problem of connected VPN and no network access I’ve uninstalled ESET Smart Security 6 RC, tried VPN without any firewall – no success. Than I’ve reset Windows (arghhh!) Firewall to default, manually added inbound and outbound rules for VPN – no luck. Of course, I’ve tried almost all “solutions” that seamed even a bit sane (flushing DNS, clearing ARP cache, deleting routes…) but nothing worked!

    After that I have capitulated trying to solve VPN problem which is, in my personal opinion, Microsoft Windows 8 related, and to be safe and firewalled again I’ve installed this time latest ESET Smart Security 6.0.308.0 via live installer. Installation went successful but somehow during installation ESS 6 blocked (maybe read and copied Windows Firewall faulty configuration) access to my VPN servers. Installation was made automatically and firewall started in automatic mode. I had a bunch of rules that I don’t want to have unwantedly created in firewall configuration and I was short-tempered already.

    So I’ve uninstalled ESS 6, downloaded offline 64-bit installation, custom installed (no restart was needed). Connected to my VPN and Smart Security asked me (interactive mode) for all of my domain servers, mail servers and all other computers that I’m connecting to. I allowed communication and… voilà! Suddenly my VPN connection was working normally! :eek: Even through CyberGhost VPN Internet connection as used before escalation of VPN “no network access” trouble.
    But my luck was short timed… It lasted for hour or two and VPN problems came back again.
    Next step was manual uninstallation of ESS in Safe Mode, and new installation. Again VPN has no network access. Luckily on virtual Windows 7 machine VPN is working.
    And now, while I’m writing this pitiful story, and that broken Windows 8 VPN was connected I have realized that there is network access! Paradigital activity, hell yeah!

    Yes, I do believe in digital ghosts! They were working in sales and marketing of big companies, not in development and programming departments for sure!

    Thanks again for reading!
  2. agoretsky

    agoretsky Eset Staff Account

    Apr 4, 2006

    My best guess is that the repeated installations and uninstallations of ESET Smart Security somehow corrupted the software's configuration.

    I would recommend uninstalling the software as normal, performing a manual uninstall using the utility mentioned in this ESET knowledgebase article, and reinstalling the latest version of the software once more.

    If you have a been reloading a backed-up XML configuration file it may be corrupt. Do not use this but instead create a new configuration for the freshly installed copy of ESET Smart Security.

    NOTE: You may need to reinstall or recongfigure your VPN software connection after performing the manual uninstall of ESET.


    Aryeh Goretsky
Thread Status:
Not open for further replies.