XP wireless (AES) weird problems

Discussion in 'ESET Smart Security v3 Beta Forum' started by kC_, Aug 22, 2007.

Thread Status:
Not open for further replies.
  1. kC_

    kC_ Registered Member

    Joined:
    Apr 6, 2007
    Posts:
    452
    i have ess beta1b on my server & laptop... have few minor issues on server but nothing like on laptop..

    my wireless setup is:
    router - thompson st585v6 (6.2 firmware)
    laptop - netgear wg511 pcmcia card
    security - WPA2 (AES encryption) & 54digit security key

    after installing ESS beta1b, (firewall in interactive mode) everything seems to work ok, internet/trusted zone browsing etc..

    but one problem i have is if i try to play a movie (xvid format in .avi container) from my mediacenter (wired to router & no firewall) media player takes about one minute to bring up any picture, then when it does, it just stutters and is unwatchable.. (cpu usage is no problem, ESS using 0% media player using 2% nothing else significantly using anything)

    if i disable ESS realtime antivirus & disable firewall (allow all) the problem is still the same.

    if i set the wireless security to basic & unsecure WEP 128bit, it works perfect with ESS in full protect mode.

    (if i leave router as WPA2/AES & completely uninstall ESS, then all works perfectly)

    so i guess ESS has some problem with WPA2/AES ? or maybe just doesnt like the specific network card/security combination?
    Seems odd that even with ess's antivirus & firewall disabled, the problem persists, only way to fix is either switch to weaker WEP or remove ESS.. currently ive had to do the latter.


    so to quickly sum it up...
    no ess & WPA2/AES = perfect
    ESS & WPA2/AES = stuttering movie playback & long time to read.
    ESS & WEP/128 = perfect


    laptop =
    windows XP Pro sp2 & all current updates
    2.66ghz p4
    1gb ram
    80gb HD
    128mb nvidia
    netgear pcmcia wg511 card with v3.xx drivers

    will give it another go when next beta appears
    Cheers
     
  2. kC_

    kC_ Registered Member

    Joined:
    Apr 6, 2007
    Posts:
    452
    can confirm same bug/problem/incompatibilty with Beta2
     
  3. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Try disabling all IDS rules and enable logging all blocked connections in the IDS setup. Let us know about the outcome.
     
  4. kC_

    kC_ Registered Member

    Joined:
    Apr 6, 2007
    Posts:
    452
    ok first of all i left all IDS on, no reported blocked entries

    unticked all IDS, no reported blocked entries

    either way media player seems to have crashed for 1 minute or so until the show/movie gradually starts to play (unwatchable due to huge stutters)

    i set firewall into ALLOW ALL (disable filtering) mode, but problem still exist, only way to get things working perfectly is to Uninstal ESS.

    i have previously used Outpost firewall, and comodo firewalls using same wireless security setup with no such issues. something somewhere in ess isnt likeing WPA2/AES.

    ive just installed the nod32 antivirus beta for now on the laptop, and enabled windows firewall... things working perfectly. (although i would prefer ESS, as i do plan on purchasing a few licences when its gold)

    ess beta2 running like a dream on my server machine! :)
    may try it on my mediacenter next
     
  5. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Can you provide us with information as to how the files are accessed, e.g. via file sharing, http, etc. ?
     
  6. kC_

    kC_ Registered Member

    Joined:
    Apr 6, 2007
    Posts:
    452
    windows filesharing, files are stored on 3 500gb Samsung spinpoint sata HD's on MCE pc

    windows mce 2005 with gigabit adapter to a gigabit switch, which connects to router (st585v6)

    router then wireless (54g) to laptop (54g wireless card)

    this has worked perfect for years, with variuos firewalls ive tested over time.
    only ESS has the problem.

    (again with ess installed if i change from WPA2/AES to 128but WEP it works) but im not happy using wep when stronger wireless security is availiable and working with other products
     
  7. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    With logging all blocked connections enabled, replicate the problem and then check the firewall log for blocked connections. Are there some connections listed?
     
  8. kC_

    kC_ Registered Member

    Joined:
    Apr 6, 2007
    Posts:
    452
    as stated above... nothing logged
    same with IDS on or off, nothing is reported blocked.

    networking/browsing/internet/fileshare seems to work ok, just excrutiatingly slow when trying stream/read big files with WPA2/AES & ESS

    the mce recods in dvrms format from tv, and i store my dvd collection ripped to xvid format on the MCE hard drive. normally streams fine over wireless, click file, takes about 2 seconds and it plays blissfully.

    with ess, it doesnt block it as such, it sort of works, just that it takes anywhere from 1 minute up to a minute and a half to even start playback of anything... and then when it does eventually start playing, it is totally unwatchable due to terrible stutters.

    the weird thinng is that when ESS firewall is set to "allow all/disable filtering" the problem persists, so it is obviously still filtering something.
    once ESS is completely uninstalled its perfect as usual

    signal strength of the wireless is full, (excelent 54g) and for the past 2-3 years ive been able to watch anything from my mediacenter in my bedroom or even in the garden with no such troubles.
     
  9. kC_

    kC_ Registered Member

    Joined:
    Apr 6, 2007
    Posts:
    452
    any news on this eset?
     
  10. kC_

    kC_ Registered Member

    Joined:
    Apr 6, 2007
    Posts:
    452
    also today just got a 2nd xbox360 for my kids room... i also purchased the microsoft wireless adapter..

    without ESS (just using windows firewall) = all working perfectly..
    - (xbox using 54digit WPA2/TKIP encryption)
    - (laptop using 54digit WPA2/AES encryption

    re-installed ESS on my server, now the wireless xbox360 cannot view the server, so i ran a 30metre cat5e cable to the kids room, (disabled the xbox360 wireless) and it works perfectly

    so ESS definatley does something weird with WPA2, and its obviously now not just a problem with my laptops card.

    so:
    No ESS & Xbox360 [WIRELESS] = Perfect
    ESS & Xbox360 [WIRELESS] = (server cant be found)
    ESS & Xbox360 [WIRED] = Perfect

    and once again, even if i set ESS firewall to "allow all/disable filtering" it doesnt help, only possible way to get it workig is to uninstal ESS & reboot.

    i have also tested now 3 media servers. same results on each
    tversity
    twonkymedia
    mediaplayer11

    i have again tried disabling all IDS rules & checked logs, nothing is being blocked.
     
  11. kC_

    kC_ Registered Member

    Joined:
    Apr 6, 2007
    Posts:
    452
    same with RC1:doubt:
     
Thread Status:
Not open for further replies.