xB-Browser problem

Discussion in 'privacy technology' started by Lorn, Mar 29, 2008.

Thread Status:
Not open for further replies.
  1. Lorn

    Lorn Registered Member

    Joined:
    Mar 29, 2008
    Posts:
    4
    Hello,

    i've just tried out the xB-browser and basicalliy its working fine but i faced some problems:

    1st and most crucial: The Tor-Button (That Onion-Symbol between "Home" and the URL) is just visible from time to time - mostly its missing and its designated room is occupied by a broadened URL-box.

    The other problem: Im using a "normal" Firefox as standardbrowser, and it happened after i tinkered abit with xB and it asked me to restart: (language-thingy) It restarted with the standard-firefox-design and i failed turning it back. Are there any known issues using xB and standardFF parallel ?

    id be glad if anybody could help - otherwise id have to struggle through that tor/privoxy-combination messing around with that DNS-leaking-problem

    thanks
    Lorn
     
  2. SteveTX

    SteveTX Registered Member

    Joined:
    Mar 27, 2007
    Posts:
    1,641
    Location:
    TX
    Hello Lorn,

    I wrote xB Browser. Let me help you.

    What version are you using, that you still see Tor Button? We
    removed it long ago as it is no longer needed, the browser
    now being fully anonymous and capable of running concurrently
    with whatever your normal browser is.

    Steve
     
  3. Lorn

    Lorn Registered Member

    Joined:
    Mar 29, 2008
    Posts:
    4
    Oh, seems as if i've made a lucky strike chosing this forum :D

    I've installed the latest Version (xB-Browser_2.0.0.12b), which i got from the official site. I've also discovered that, sometimes, the process doesnt stop when i exit the browser - i've then to kill xb-browser and Tor with the Taskmanager.
    Im just remembering that when i used Torpark some yeahrs ago it was necessary to close the regulary Firefox to get it started so i thought even though or probably even just because it was possible for me to run both at the same time, this might be the cause for some problems.

    And eehm: If i reinstall the application, is it necessary to manually delete all the files, that were saved in the /Username/Applications/.... folders to get a clean new installation ? Since sth. didnt work alright i obviously dont want it to resume to the old configuration after reinstallation.

    greets
    Lorn

    Edit: I've just read on http://en.wikipedia.org/wiki/Xerobank:
    "The current version is 2.0.0.12b and it does not allow one to run another version of Firefox concurrently for security reasons."
    Seems as if something is wront with my config.
     
  4. SteveTX

    SteveTX Registered Member

    Joined:
    Mar 27, 2007
    Posts:
    1,641
    Location:
    TX
    2.0.0.12b should allow firefox to run concurrently. The wikipedia folks don't have a clue. Let's see, I don't think you should have any files at %USERNAME%/%APPDIR%, unless you installed xb browser there. Uninstallation should uninstall everything.

    We've added some code into the next one that should force the process to die when the window is closed. Sometimes it doesn't, usually because of a firefox conflict. I think we need to add some process id matching. But another issue is firefox respawns itself over and over, strangely.
     
  5. Lorn

    Lorn Registered Member

    Joined:
    Mar 29, 2008
    Posts:
    4
    Thats indeed weird. I installed it into the C:/Programms/XeroBank-directory but during the installation or during the first start .. but the timestamp tends to "installation", a bunch of Data was added to the Applicationfolder. I cant name them cos i've deleted all after deinstallation. I already guessed this might not be intended cos if that happens on a foreign PC it doesnt directly compromise the anynomity but it aleast shows that u are using the xBbrowser. Im using Vista 32bit and oddly with every start xB shows that window with "checking for AddOn compatability with Firefox" or somthing like that, im not sure about the exact wording, appears and my HDD begins to judder..it always taks about 1 min until it has finished its procedure.
    Do you have any workaround for that skin-resetting-issue ? And uh .. if i've understood you right the xB-Browser is now a anonymous-only-browser so its not possible to deactivate TOR-routing ? Is it possible to control the exitnodes, that are used or exclude some suspicious ones from the routing ?
     
  6. SteveTX

    SteveTX Registered Member

    Joined:
    Mar 27, 2007
    Posts:
    1,641
    Location:
    TX
    Oh you just said the magic word: Vista, the operating system where anything can happen. No, it won't compromise anonymity if ran as is. If your host machine is already compromised, it doesn't change your threat model. If you are worried about someone coming along and finding out you were using xb browser, you should probably instead by using xb machine.

    For the skin resetting issue... edit the Tor_user.js file and remove the line about "xb modern" theme.

    Yes, it is now hardwired to by anonymous-only, using either XeroBank or Tor.

    Yes you can control the exit nodes using xb config and write the commands just like it was for the parameters being sent to the command line for starting Tor.
     
Loading...
Thread Status:
Not open for further replies.