WSA prevents Shadow Defender from launching!

Discussion in 'Prevx Releases' started by pvsurfer, Dec 15, 2013.

Thread Status:
Not open for further replies.
  1. pvsurfer

    pvsurfer Registered Member

    Joined:
    Sep 1, 2004
    Posts:
    1,400
    Location:
    California - USA
    I just installed the latest version of WSA. I find that I am unable to launch Shadow Defender, so I generated a scan log which has several Shadow Defender entries listed as which I presume means 'untrusted'. Here is a snip of those entries, each of which pertain to Shadow Defender:


    I am using WSA with its default settings, but I can't find any user-settings (e.g., a 'white-list') that would instruct WSA to trust Shadow Defender. o_O

    Thanks in advance for any suggestions (and I have reported this to Support).
     
    Last edited: Dec 15, 2013
  2. Blues7

    Blues7 Registered Member

    Joined:
    May 11, 2009
    Posts:
    858
    Location:
    Blue Ridge Mountains
    Just as a point of information, I am running Shadow Defender (older .325 version) on my XP SP3 system alongside the current version of WSA AV without issue.
     
  3. pvsurfer

    pvsurfer Registered Member

    Joined:
    Sep 1, 2004
    Posts:
    1,400
    Location:
    California - USA
    Hi Blues,

    That's kind of strange. Are you running the latest version of WSA with its default settings (as I am)? Perhaps the problem is SD version dependent or even Windows version dependent; I'm running the latest version of SD (.457) on Win7 x86 SP1.

    pv
     
    Last edited: Dec 15, 2013
  4. Blues7

    Blues7 Registered Member

    Joined:
    May 11, 2009
    Posts:
    858
    Location:
    Blue Ridge Mountains
    Yes, I'm running the latest WSA AV version with default settings except for disabling "scheduled scans" and the inclusion of apps which I want protected via Identity Shield.


    You just never know how apps are going to interact with one another.

    I've noticed, for example, that WSA will detect the Eicar test file before I give permission to Sandboxie to recover that file to my downloads folder. This is a very good thing.

    However, if I also run Shadow Defender in real-time, WSA doesn't pick up the file until I actually allow Sandboxie to recover it to the folder.
    (Still protected but it's nice to nip it in the bud before it even makes it to the download folder which also happens to be under the supervision of Sandbxie.)

    I can only imagine the number of interactions that we are unaware of which might limit the protection we think we are enjoying via our security apps.

    Primarily for that reason I'm trying to keep my real-time security apps to a minimum and make sure I always have current images in case of emergency.
     
  5. Wendi

    Wendi Registered Member

    Joined:
    Aug 8, 2008
    Posts:
    522
    Location:
    NY, USA
    Hi pv,

    I have a very similar configuration as yours, with no such conflict. I would suggest that you try the following potential remedy:

    1. Close-out any running apps
    2. Rt-click on the WSA tray icon and shut it down
    3. Using Windows Explorer open C:\ProgramData
    4. Copy the sub-folder WRData somewhere else for safekeeping
    5. Now delete the contents of WRData
    6. Restart your PC
    I believe WSA will scan your system and 'rebuild' the WRData folder. Hopefully, Shadow Defender will now open and run with WSA enabled.

    Wendi
     
  6. Triple Helix

    Triple Helix Webroot Product Advisor

    Joined:
    Nov 20, 2004
    Posts:
    12,011
    Location:
    Ontario, Canada
    That's not a good idea and would not suggest to do that! The files are marked Unknown as it's looks to be an update of SD so contact Webroot Support and get the files whitelisted: Webroot Customer Service

    TH
     
  7. PrevxHelp

    PrevxHelp Former Prevx Moderator

    Joined:
    Sep 14, 2008
    Posts:
    8,242
    Location:
    USA/UK
    Indeed, erasing the WRData folder would be a very bad idea - you'll lose all of your licensing information and all local context. Writing into our support inbox will allow our team to whitelist your system and correct the behavior.
     
  8. pvsurfer

    pvsurfer Registered Member

    Joined:
    Sep 1, 2004
    Posts:
    1,400
    Location:
    California - USA
    Well, I've been away visiting family all day and just returned to see that Support already addressed my problem and white-listed the current version of Shadow Defender. Indeed it appears to be working well now. :thumb:

    Considering that the current build of SD (.457) was released 3-months ago it sure seems strange that I was the first to experience and report this issue. :doubt:
     
Thread Status:
Not open for further replies.