winscp causes ekern to hang at 99 percent

Discussion in 'ESET Smart Security' started by daveReed, Jun 23, 2008.

Thread Status:
Not open for further replies.
  1. daveReed

    daveReed Registered Member

    Joined:
    Jun 23, 2008
    Posts:
    5
    I just download winscp to connect to my server. Once the download was close to finishing, firefox just hung there for several minutes while ekern.exe hogged 99% of the cpu. Now when I try to use winscp ekern.exe goes back up to 99% until I kill it (I don't have the patience to wait several minutes to load such a small executable). I seemed to have fixed the problem by adding it to the exclusion list, but it is strange that such a small executable would cause ekern to hang like that. It hasn't done that with any of the other programs I've downloaded that are much bigger. Is there any reason why it would do that?

    P.S. I do have advanced heuristics turned on, and I have checked the sha1sums for winscp, so I know that it isn't corrupted or anything.
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Could you please confirm or deny that the problem occurs with the settings below disabled in the real-time protection module?

    [​IMG]
     
  3. daveReed

    daveReed Registered Member

    Joined:
    Jun 23, 2008
    Posts:
    5
    I took the program off the exclusion list and disabled the advanced heuristics. Runtime packers was already disabled. After doing this, the program loaded up and ran normally. So it appears that the advanced heuristics is the culprit. It's still odd how its only seemed to affected that particular program.
     
  4. simonx

    simonx Registered Member

    Joined:
    Jun 11, 2008
    Posts:
    4
    clicking on, copying etc. winscp causes my ekern (667) to bang the cpu as well.
     
  5. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Using WinSCP 4.0.7, no delays even with AH / RTP enabled on access.
     
  6. daveReed

    daveReed Registered Member

    Joined:
    Jun 23, 2008
    Posts:
    5
    I am using WinSCP 4.0.7.370, but it still hangs if I don't disable AH somehow. It's not really a big deal because I trust it and set it as an exception, but I am just curious if there is a problem with either my settings, or the AH algorithm itself. Is there a way to dump my settings to a file for review?
     
  7. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Please send me your exe file from WinSCP so that I can test it myself with the very same file. I'll drop you a PM with my email address.
     
  8. daveReed

    daveReed Registered Member

    Joined:
    Jun 23, 2008
    Posts:
    5
    I feel really dumb in asking this, but how do you send exe files. I tried to PM you, but didn't see an option for sending attachments and the message board doesn't allow for .exe extensions

    edit: DOH..... didn't see the last part of your post =D
     
    Last edited: Jun 27, 2008
  9. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    I've sent you a PM with my email address, please send the file by email.
     
Thread Status:
Not open for further replies.