Windows Firewall Control (WFC) by BiniSoft.org

Discussion in 'other firewalls' started by alexandrud, May 20, 2013.

  1. focus

    focus Registered Member

    Joined:
    Feb 5, 2007
    Posts:
    387
    Location:
    USA
    sshot-2019-01-12-[07-44-44].jpg
    I installed some new Epson software and am getting continual requests for firewall access in this format, not sure how to deal with this. Any suggestions?
     
  2. alexandrud

    alexandrud Developer

    Joined:
    Apr 14, 2011
    Posts:
    1,638
    Location:
    Estonia
    Windows Firewall displays these notifications when a new software wants to open a port for listening for inbound connections. If you use this Epson device on your home network as a network device, press on "Allow access" to create an allow inbound rule for it. If not, click "Cancel" to create a block inbound rule for it.
     
  3. focus

    focus Registered Member

    Joined:
    Feb 5, 2007
    Posts:
    387
    Location:
    USA
    This worked after about 5 reboots trying different things. I finally realized that Secure Rules & Secure Profile might need to be off so I did this and it created the block rules. All is well now.

    Thanks alexandrud.
     
  4. alexandrud

    alexandrud Developer

    Joined:
    Apr 14, 2011
    Posts:
    1,638
    Location:
    Estonia
    Yes, Secure Rules should be disabled or it should contain the group of the newly added rule in the Authorized groups list. I am glad that you sorted it out.
     
  5. focus

    focus Registered Member

    Joined:
    Feb 5, 2007
    Posts:
    387
    Location:
    USA
    It's interesting that the two Epson In rules were created under the "WFC" group even though they were requested from this exterior pop-up. No problems, just interesting.
     
  6. alexandrud

    alexandrud Developer

    Joined:
    Apr 14, 2011
    Posts:
    1,638
    Location:
    Estonia
    Not possible. But I think you made the following happened:
    1. You disabled Secure Rules.
    2. Windows Firewall displayed that notification.
    3. You allowed it and two inbound rules were created with no group set.
    4. You enabled Secure Rules which displayed 2 confirmations. The ones below:
    upload_2019-1-14_22-7-31.png
    upload_2019-1-14_22-7-7.png
    5. I think you pressed on Yes in the second confirmation and then your rules were added by WFC in "Windows Firewall Control" group.

    I have no other plausible explanation :)
     
  7. focus

    focus Registered Member

    Joined:
    Feb 5, 2007
    Posts:
    387
    Location:
    USA
    You are absolutely right, I just redid the scenario. I remember clicking the first one, that is a usual suspect when enabling Secure Rules, the second one I must have just clicked thinking it was a confirmation dialog. The adding to the WFC group is a new one for me but a most welcome one in these cases. Thank you for clarifying and thank you for this marvelous software.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.