Windows 10 can't see archives

Discussion in 'Paragon Drive Backup Product Line' started by RobertHF, Sep 23, 2015.

  1. RobertHF

    RobertHF Registered Member

    Joined:
    Sep 23, 2015
    Posts:
    6
    Hello,
    I've just purchased Backup and Recovery 15 Home, and I'm trying to archive a volume, i.e. the C: drive on my PC. I'm running Windows 10 Pro 64-bit.

    I've create a usb recovery drive and I'm booting from that and then using the "back up to vhd" option (using all defaults), and specifying that the archive should be stored in an ordinary Windows folder on my second internal hard drive.

    What I'm finding is that the backup completes successfully, but when I go to the archive folder, Windows explorer shows it empty. If I right-click in Windows on the drive letter of the drive containing the backup folder, and select "Properties", the memory usage of the drive has not increased. However, if I go to Volume Explorer in Backup and Recovery 15, and look for the archive in "Hard Disks", it displays the folder contents correctly, but not when I look in "Drives". Also if I select "properties" for the drive in Backup and Recovery 15, it shows that the disk usage has increased by 78GB, which is at odds with Windows Explorer.

    Can anyone suggest why this is is happening? I don't think its anything to do with saving to a second hard drive, since I tried it with an external USB drive, and the same thing happened.

    Am I right in thinking that vhd archives can be saved to ordinary folders?

    Thanks for any advice
     
  2. Robin A.

    Robin A. Registered Member

    Joined:
    Feb 25, 2006
    Posts:
    2,280
    Did you create a VHD image, or a PVHD one? If it was a VHD, possibly Windows 10 considers it a "system file" or something like that, and doesn´t show it in File Explorer by default. Change the options in File Explorer so that it shows all "system files" etc.

    Also, remember that VHD images are not compressed, so they are very large.
     
    Last edited: Sep 23, 2015
  3. RobertHF

    RobertHF Registered Member

    Joined:
    Sep 23, 2015
    Posts:
    6
    It was a pvhd image. As I mentioned in my original post I used all default options.

    I've tried looking for hidden files using a dos prompt, but nothing. It's as if Windows Explorer thinks there's nothing there.

    The hard drive I'm copying to is empty before the backup. After the backup, if I use "properties" on the drive in Windows Explorer, it still says its empty. However "Properties" on the disk in Backup & Recovery says that 78Mb has been used.
     
  4. Robin A.

    Robin A. Registered Member

    Joined:
    Feb 25, 2006
    Posts:
    2,280
    I am unable to replicate your problem.

    Using Hard Disk Manager 15 in a WinPE boot UFD, I imaged the Windows 10 Pro system of a UEFI laptop. I imaged seven partitions (some not related to Windows 10) and created the image in the root of the data partition of the internal disk. The File Explorer shows the folder with the 3 expected files, a .pfi, a .pvhd and a .pbe (only 3 files because I didn´t split the image).
     
  5. RobertHF

    RobertHF Registered Member

    Joined:
    Sep 23, 2015
    Posts:
    6
    Thanks for taking the time, Robin. I think I've found what the problem was. I think it was related to access options for the hard drive I was copying to.

    In Windows Explorer, right-clicking on the drive, selecting "Properties", and then the "Security" tab, showed that under "Permissions for Authenticated Users", the "Full Control" check box was cleared. When I checked this box, and performed the archive again, it worked as expected and I can now see the the saved .pvhd and associated files. I had been quick formatting the drive between archive runs, and it looks like the default is for the "Full Control" checkbox to be cleared after a format.

    So I guess it was primarily my fault, but it was quite confusing, in that it seemed to result in Windows Explorer not being able to see the files, or even report any memory usage.
     
  6. RobertHF

    RobertHF Registered Member

    Joined:
    Sep 23, 2015
    Posts:
    6
    Just a last update on this. Even after I changed the permissions, I found I was still having problems. Sometimes it worked and sometimes it didn't. I get the impression there's also an issue related to directory ownership. To see the directory owner in Windows Explorer use: "Properties - Security - Advanced". My OS is Windows 10 Pro 64-bit.

    I found that if I first created a new directory directly under the hard drive root (mine was "Images"), and then specified that as the archive storage destination it didn't work (well it worked, but as above, I couldn't see the archive in Windows Explorer). But if I saved the archive to the root of the hard disk it did. When I looked at the "Owner" property of the successfully saved archive, it was "SYSTEM". When I checked the owner of the parent "Images" directory, it was "Administrators". When I changed the owner of "Images" to "SYSTEM" and then tried again to save the archive into "Images", it worked. So it looks as if maybe the ownership clash was a factor in my original problem.

    I'm no system administration expert, so I'm not completely sure of all of this. The owner of the hard drive root is also "Administrators", (i.e. the same ownership clash), but that worked, which on the face of it is inconsistent. Anyway, I thought I'd post what I found just in case it might be of use.
     
  7. Robin A.

    Robin A. Registered Member

    Joined:
    Feb 25, 2006
    Posts:
    2,280
Loading...