Win 10 "Desktop Folder" name changed to........ "Downloads" - Weird!

Discussion in 'other software & services' started by kennyboy, Oct 27, 2021.

  1. kennyboy

    kennyboy Registered Member

    Joined:
    Oct 4, 2006
    Posts:
    413
    Win 10 21H1 x64
    As per thread title, for some reason, my Desktop folder still retains its properties as:- C:\Users\ken\desktop, but it is now named "Downloads" everywhere. See attached pic. Probably something simple, but its beyond me, and its annoying. Any help appreciated.

    Wilders 1.png
     
  2. pegas

    pegas Registered Member

    Joined:
    May 22, 2008
    Posts:
    2,438
    I have a similar long lasting issue with folder Documents which has taken the name of the contained folder.
     
  3. Floyd 57

    Floyd 57 Registered Member

    Joined:
    Mar 17, 2017
    Posts:
    1,234
    Location:
    Europe
    Maybe ur desktop folder disappeared from being shown and instead ur download folder is being shown? I will need more pictures
     
  4. stapp

    stapp Global Moderator

    Joined:
    Jan 12, 2006
    Posts:
    17,767
    Location:
    UK
  5. Floyd 57

    Floyd 57 Registered Member

    Joined:
    Mar 17, 2017
    Posts:
    1,234
    Location:
    Europe
  6. stapp

    stapp Global Moderator

    Joined:
    Jan 12, 2006
    Posts:
    17,767
    Location:
    UK
    You don't have to be a genius to work out how to do it with another folder.
     
  7. Floyd 57

    Floyd 57 Registered Member

    Joined:
    Mar 17, 2017
    Posts:
    1,234
    Location:
    Europe
    Yeah i was just messing with you :p

    Though your suggestion isn't too smart as it will reset the settings which is a bummer, since then u have to do it all over again. Which is why i was looking for a better solution but i needed more information

    But hey it's better than nothing ;o
     
  8. kennyboy

    kennyboy Registered Member

    Joined:
    Oct 4, 2006
    Posts:
    413
    No. The folder that is being shown is the actual desktop folder with the desktop contents.
     
  9. kennyboy

    kennyboy Registered Member

    Joined:
    Oct 4, 2006
    Posts:
    413

    Attached Files:

  10. stapp

    stapp Global Moderator

    Joined:
    Jan 12, 2006
    Posts:
    17,767
    Location:
    UK
    Can you see it in C\Users\Default ?
     
  11. kennyboy

    kennyboy Registered Member

    Joined:
    Oct 4, 2006
    Posts:
    413
    Yes. There is a completely empty folder named Desktop there. Is this a help, or does it suggest a remedy. Good thinking by the way.
     
  12. Floyd 57

    Floyd 57 Registered Member

    Joined:
    Mar 17, 2017
    Posts:
    1,234
    Location:
    Europe
    Did u try resetting the folders and the defaults?
     
  13. xxJackxx

    xxJackxx Registered Member

    Joined:
    Oct 23, 2008
    Posts:
    6,774
    Location:
    USA
    I'll ask the stupid question. Why not just rename it back? Am I missing something here?
     
  14. Floyd 57

    Floyd 57 Registered Member

    Joined:
    Mar 17, 2017
    Posts:
    1,234
    Location:
    Europe
    Ye try that before resetting
     
  15. kennyboy

    kennyboy Registered Member

    Joined:
    Oct 4, 2006
    Posts:
    413
    Yes. I followed Stapps link and reset folders and defaults. No good.
     
  16. kennyboy

    kennyboy Registered Member

    Joined:
    Oct 4, 2006
    Posts:
    413
    There is no option to rename the faulty named folder. It is greyed out where it shows, so nothing to rename.
     
  17. Floyd 57

    Floyd 57 Registered Member

    Joined:
    Mar 17, 2017
    Posts:
    1,234
    Location:
    Europe
    You tried to rename the downloads folder that is actually your desktop folder, to Desktop?
     
  18. kennyboy

    kennyboy Registered Member

    Joined:
    Oct 4, 2006
    Posts:
    413
    I think I have solved it. Due to many ideas from here, I looked at the "Downloads" folder which was actually the "Desktop" folder, and thanks to Stapps idea of looking for a Desktop folder in the "Default" Users profile, (which there was), I just copied that folder ie Users\Default\Desktop (which was empty,) and pasted it into my own profile. This did something really strange to the faulty Downloads folder, and still didnt show a Desktop folder, but this then allowed me to rename it to Desktop and it worked! Absolutely no idea why it worked, but very grateful to all who contributed. (Probably a very garbled explanation but I know what I mean anyway.)
     
  19. kennyboy

    kennyboy Registered Member

    Joined:
    Oct 4, 2006
    Posts:
    413
    Yes. See above explanation.
     
  20. xxJackxx

    xxJackxx Registered Member

    Joined:
    Oct 23, 2008
    Posts:
    6,774
    Location:
    USA
    I had also considered suggesting a new user profile but that is more work than most people including myself would want to do.
     
  21. Floyd 57

    Floyd 57 Registered Member

    Joined:
    Mar 17, 2017
    Posts:
    1,234
    Location:
    Europe
    Congrats stapp you solved OP's problem, you should feel proud of yourself, what a smart person!

    Also congrats OP really nice you solved your problem
     
  22. imdb

    imdb Registered Member

    Joined:
    Nov 2, 2011
    Posts:
    3,291
    @kennyboy
    hey,ken. did you by any chance try to modify or delete a desktop.ini file recently?
     
  23. kennyboy

    kennyboy Registered Member

    Joined:
    Oct 4, 2006
    Posts:
    413
    Hi IMDb - No I didnt do that. Interesting thought for next time though.
     
  24. imdb

    imdb Registered Member

    Joined:
    Nov 2, 2011
    Posts:
    3,291
    a corrupt desktop.ini file might be the culprit. a 3rd party system cleaner might have caused it too. just saying. glad you got it sorted out.
     
  25. Floyd 57

    Floyd 57 Registered Member

    Joined:
    Mar 17, 2017
    Posts:
    1,234
    Location:
    Europe
    All those cleaners are snake oil anyway
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.