Why is Suspend to RAM so difficult?

Discussion in 'all things UNIX' started by act8192, Apr 11, 2010.

Thread Status:
Not open for further replies.
  1. act8192

    act8192 Registered Member

    Joined:
    Nov 9, 2006
    Posts:
    1,273
    New Mandriva user here.

    On a laptop suspend to RAM is an essential feature.
    Doesn't work.
    That's a show-stopper for me in an attempt to run Linux, Mandriva, a beautiful OS.

    But as in the title, what is so difficult?
    Windows has no problem - select standby from the TurnOff menu, orange power button flashes, hit it an hour later, it all comes back. Dual boot Mandriva - it fails.

    All I get in Linux is a black screen. Nothing. Have to press the Power button to do a hard boot. WHY? I really would like to understand what the issue is. Once I understand, perhaps I will find a solution amongst those numerous postings from users all over the google search..

    What are the steps that Suspend to RAM, a hardware related function, takes that are being blocked or not functioning? What does it do in terms of networking, screen functioning, login, desktop config, etc.

    I am NOT talking about the dreaded HIBERNATION. Please do not confuse the two, should you chose to answer my query.

    Finally - to Mrkvonic, thank you for your wonderful installation instruction and descriptions of Mandriva.
     
  2. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136
    STR works fine here on Ubuntu Karmic with my VAIO laptop, I have also tried it on Toshiba and it works there as well, having said that STR needs quite a few factors to work well, biggest culprit being BIOS, video drivers, these two don't work well most of the times and issues arise, thankfully Linux OS is now booting under 20 seconds so I hardly ever use STR.
     
  3. Mrkvonic

    Mrkvonic Linux Systems Expert

    Joined:
    May 9, 2005
    Posts:
    8,695
    Suspending to ram requires that you have flawless drivers working with your hardware. If there are issues here and there, some of the hardware may not initialize properly on resume and you get a non-functional machine.

    There's no guarantee, only the best effort. Sometimes it works, sometimes it does not. I have seen cases where it works on windows and linux, cases where it does not.

    I too find the issue troublesome, but it's universal, save when you buy machine+os, like mac, where it's matched and tested.

    Mrk
     
  4. doktornotor

    doktornotor Registered Member

    Joined:
    Jul 19, 2008
    Posts:
    2,047
    I'd add that STR also presumes a non-broken BIOS (which are more an exception than a rule, with vendors "fixing" their BIOS bugs via motherboard drivers on Windows :mad: )
     
  5. GlobalForce

    GlobalForce Regular Poster

    Joined:
    Jun 30, 2004
    Posts:
    3,581
    Location:
    Garden State, USA
    Check the log file as noted by DJenning. With compatible hw, maybe disable speedboot. Rethink your choice of forum too.
     
  6. Try appending this to your boot line:

    Code:
    acpi_sleep=s3_mode
    If that doesn't work, try

    Code:
    acpi_sleep=s3_bios
    Edit: oh a couple more things:

    - What version of Mandriva are you using?

    - Can you post the output of the 'dmesg' command?
     
  7. act8192

    act8192 Registered Member

    Joined:
    Nov 9, 2006
    Posts:
    1,273
    Thank you all for ideas, taking them from the end:

    Gullible Jones,
    Re: Can you post the output of the 'dmesg' command?
    I'm so new to this I would know how. I did Run command little box, typed dmesg and nothing happened. There is in the log files a dmesg file which opens in Kwrite. It's 25K. Should I post it here? The whole thing? Or do some sort of attachment.

    I tried both acpi_sleep=s3_mode and acpi_sleep=s3_bios. No go. Black screen after standby. A b it of harddrive activity, weak fan noise, but nothing of any use to me.

    GlobalForce,
    I saw that thread earlier. I do have the pm-suspend.log, it is 10.3KiB big. But when I open it in Kwrite, there is nothing there. Not even in invisible ink (white or white) which I tried several times. Speedboot setting I tried as well. I have no idea whether it was on or off previously, but adding that line made no difference.

    Mrkvonic and all,
    My laptop is not on the Mandriva compatibility list, was never tested, so yes I can see there might be problems, but I didn't think I'd get a standby issue since Windows handles it so well. According to Toshiba my BIOS is ok. It's A75-S226. I'd hate to give up on this Linux adventure just because of standby.

    I run Mandriva 2010.0, the current distribution + 522 updates when I last installed it few days back and then few more updates came. Dmesg file, first line says:
    Linux version 2.6.31.12-desktop586-3mnb (qateam@titan.mandriva.com) (gcc version 4.4.1 (GCC) ) #1 SMP Thu Mar 25 12:48:26 EDT 2010
     
  8. 1. Open a terminal. (Should be in Applications -> Tools.)

    2. Type 'dmesg' and hit enter. Copy and paste the output.

    Also: It seems that on some machines, the Linux framebuffer interferes with resuming from suspend... And Mandriva uses the framebuffer by default. Try this:

    1. Turn on your laptop.

    2. At the boot prompt (after the BIOS screen), you should see several entries. The selected one will be "Linux". Use the arrow keys to select "Linux-nonfb", and hit enter.

    3. Let the computer boot, then try suspending and resuming.

    Oh and one more thing. (Because I'm an idiot, I should have asked this first.) What model laptop are you using?
     
  9. act8192

    act8192 Registered Member

    Joined:
    Nov 9, 2006
    Posts:
    1,273
    DmesgOutput attached, I hope
    Comp is Toshiba Satellite A75S226
     

    Attached Files:

    Last edited: Apr 13, 2010
  10. act8192

    act8192 Registered Member

    Joined:
    Nov 9, 2006
    Posts:
    1,273
    I don't know how to do that other suggestion.
    Here's what I did:
    I select the "(safe mode") Mandriva boot option, is that what you meant?
    The screen went through a bunch OK events, did some INIT single user mode.
    On the sh-4.0# prompt I typed standby - illegal.
    I closed the lid, that did nothing.
    I typed sleep 5m, nothing happened, but after 5minutes the screen went dark grey, the power light never changed to flashing orange, the drive and the fan continued working, so clearly no suspend.
    Finally I typed "exit", phew - it booted Mandriva desktop but the mouse wasn't working. The touchpad did work.
    Well, back to windows for now. I can't debug something I know nothing about. Thanks for your help.
     
  11. You're welcome, and sorry I couldn't be of more help.
     
Loading...
Thread Status:
Not open for further replies.