Which is best - current v10 or new v11?

Discussion in 'Acronis True Image Product Line' started by mlagrange, Jul 23, 2008.

Thread Status:
Not open for further replies.
  1. mlagrange

    mlagrange Registered Member

    Joined:
    Jul 23, 2008
    Posts:
    3
    Hello - I'm loading up a new laptop, and trying to decide which way to go regarding TrueImage. I'm seeing a lot of "issues", and wondering if it would be better to stick with my version 10 (with the latest update), or upgrade to v11

    Any opinions?

    Thanks

    Mark
     
  2. Xpilot

    Xpilot Registered Member

    Joined:
    May 14, 2005
    Posts:
    2,318
    Check out V10 and if it works go no further. V 10 seems to have a lot more compatablity than V11 and it is not overburdened with the V11 dross.

    Xpilot
     
  3. shieber

    shieber Registered Member

    Joined:
    Oct 27, 2004
    Posts:
    3,710
    ATI10 and ATI11 don't all work with the same ardware setups. ATI10 works on some that ATI11 won't and vice versa.

    ATI11 has lots of bugs that might not matter to you -- you can try it for free. However, if ATI10 is working for you. I'd wait a few more months and see what Acronis comes up with for fixed ATI11 or a new ATI12.ATI11 will be a year old around September and Acronis has been releasing new versions roughly annually.
     
  4. mlagrange

    mlagrange Registered Member

    Joined:
    Jul 23, 2008
    Posts:
    3
    Ok, I'm sticking with v10

    Thanks for your replies

    Mark
     
  5. jmk94903

    jmk94903 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    3,329
    Location:
    San Rafael, CA
    Be sure to boot from the Rescue CD and validate an image you have made while running the Rescue CD. If you can't, then version 10 doesn't support your hardware and you will need a BartPE boot disk, a VistaPE boot disk or possibly version 11.

    Backing up is easy. It's restoring that counts.
     
  6. shieber

    shieber Registered Member

    Joined:
    Oct 27, 2004
    Posts:
    3,710
    Otoh, ati10 works on some setups that ati11 won't so, if you have 11, you might need 10 ;) Bart and Vista PEs are good ways to get around the bootCD problems, imo.

     
Thread Status:
Not open for further replies.