Which HIPS works with Vista

Discussion in 'other anti-malware software' started by polocanada, Aug 26, 2007.

Thread Status:
Not open for further replies.
  1. polocanada

    polocanada Registered Member

    Joined:
    Aug 19, 2007
    Posts:
    60
    Here I tested following apps, all of them claim to work with Vista. For me this was not the case. My machine is clean, just came out of dell.

    • Safe'N'Sec - doesn't work
    • DefenseWall - doesn't work
    • System Safety Monitor - DOES work - but one error message so far
    • ProSecurity - doesn't work, it says it can't connect to kernel and it says I am using a cracked version of ProSecurity... Tha't funny, I just donwloaded it from www.proactive-hips.com...

    I didn't try to install ProcessGuard, since there is no updated version in sight, I don't want to waste my time. Perhaps someone has experience with running ProcessGuard on Vista??

    POST EDIT:
    Seems I found the problem for Safe'n'Sec... at least... The problem is with ESS Eset Smart Security. If both are loaded, Safe'n'sec doesn't load or - the system hangs at some point. Not freezes, but just hangs. When I disable autoloading ESS driver service, Safensec starts fine. I can then start ESS manually and start the driver with "net start ekrn". I'll post this in ESS forum, since this is more appropriate there.

    First impressions last long... it seems I will stay with SSM for a while.

    Apropos the proggy called ProSecurity - I like the idea this little proggy being the future of ProcessGuard. However the idea it need to patch kernel seems like it doesn't have very long future. Microsoft is planning to limit this. There are products that are more advaced and don't need to patch kernel.
    Experts - please correct me if I am wrong on this point.

    Hope this helps anybody...:)
     
    Last edited: Aug 27, 2007
  2. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    ProcessGuard doesnt support Vista.

    As for a Vista-compatible HIPS, have you tried ThreatFire or Prevx2?
     
  3. CJsDad

    CJsDad Registered Member

    Joined:
    Jan 22, 2006
    Posts:
    618
    DefenseWall is another
     
  4. polocanada

    polocanada Registered Member

    Joined:
    Aug 19, 2007
    Posts:
    60
    PrevX -
    resource hog (win XP and win 2000)
    But anyway, perhaps someone can try PrevX and give us opinion?

    Cyberhawk -
    not as userfriendly. It reminds me about Office 2000 interface.
    -----


    CJsDad - DefenseWall was the one I tested. See above.



    .
     
  5. sukarof

    sukarof Registered Member

    Joined:
    Jun 22, 2004
    Posts:
    1,714
    Location:
    Stockholm Sweden
    I beg to differ. Maybe "resource hog" is different on different computers and has a different meaning depending on the user, but Prevx2 played very well on both Winxp and Vista when i used it (had it for a year or so) its been a couple of weeks since I had it installed though. It did not slow down anything. It just sat there and didnt bother me in anyway until it found something that the community or heuristic couldnt solve.
     
  6. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    I read that ThreatFire beta has a new nicer GUI. Maybe give it a second shot?
     
  7. polocanada

    polocanada Registered Member

    Joined:
    Aug 19, 2007
    Posts:
    60
    Great, I might give a try to PrevX again.

    Perhaps it was slow because the systems I used before where older, small memory etc...
     
  8. Tokar

    Tokar Registered Member

    Joined:
    Jul 22, 2005
    Posts:
    81
    How about the HIPS from Spyware Terminator (my company's product)? It supports Vista32bit.
     
  9. Baldrick

    Baldrick Registered Member

    Joined:
    May 11, 2002
    Posts:
    2,299
    Location:
    South Wales, UK
    I believe that your are correct re. the current version 1.30 but not correct re. the current beta 1.40 as this was posted at the ProSecurity forum:

    " ProSecurity v1.40 Public Beta 2 Released!
    Jul 30th, 2007, 9:07am What's new? [July 30, 2007]
    ---------------------
    1. [NEW] Windows Vista x86 is supported except the network protection function.
    2. [FIX] The warning box can't keep top most on Windows 2003.
    3. [FIX] Several BSOD bugs of v1.40 beta1 fixed.
    4. [FIX] Other small bugs fixed.

    Support OS: Windows 2000 SP4/XP SP1 SP2/2003/Vista x86
    Download URL: http://www.proactive-hips.com/download/pssetup_140pb2.exe
    Support Email:support@proactive-hips.com"

    Not sure when the beta version will go currento_O?

    Hope that helps?
     
  10. Edwin024

    Edwin024 Registered Member

    Joined:
    Nov 14, 2004
    Posts:
    1,000
    It would be nice of the topic would be changed to vista 32... I use 64 for instance. And then the world looks even more strange.
     
Loading...
Thread Status:
Not open for further replies.