Weird problem with DiskEditor and external USB drive

Discussion in 'Acronis Disk Director Suite' started by GerryFeed, Nov 29, 2005.

Thread Status:
Not open for further replies.
  1. GerryFeed

    GerryFeed Registered Member

    Nov 29, 2005
    I am having a weird problem with DiskEditor

    XP doesn't see the partition on my external Maxtor 300GB USB drive anymore.
    Originally it had:
    • one NTFS partition
    • no OS installed.

    I ran physical diagnostics on the disk, and everything checks out fine. No bad clusters or any other problems. I still can't see any partitions though, so I guess there is something wrong in the partition table in the MBR.

    I decided to give DiskEditor a shot at it. On startup, DiskEditor sees the disk as 279.5GB unallocated. I click on the disk icon so that I can edit the MBR for the disk.

    In the main window, I view the sectors 'as Hex'

    Absolute sector 0

    The MBR is screwed up. So I load in the 512byte backup of the MBR that I made a few weeks ago when everything was working fine. It looks great. All the changed bytes are displayed in green. Offset 01be has the correct information for the first (and only) partition, the '55 AA' mark is at the end of the sector.

    I move away from sector 0 by clicking on sector 1. A message box pops up and asks:

    'Warning! Sector 0 has been modified! Do you wish to save it?'

    I click yes, and then...

    everything gets shifted down by 16 bytes!

    bytes 0000 to 000F are now in position 0010 to 001F
    The rest of the bytes in the sector are shifted down too.
    The last 16 bytes 'wrap around' to the beginning of the sector,
    moving from 01F0 - 01FF to 0000 - 000F

    That's not the end of it.

    I click back in sector 0. Then I click back in sector 1.
    When I click in sector 1, the first 16 bytes from sector 1 are swapped with the first 16 bytes in sector 0!
    I click back in sector 0, they are swapped back around again.
    I can keep clicking sector 1, sector 0, sector 1, sector 0, and the first 16 bytes of these sectors keep swapping places.

    Are the bytes really being swapped, or is this a bug in how the app is displaying the sectors?

    I've just tried this with another random sector and the sector following it (on the same 300GB Maxtor drive), and the same swapping behaviour is happening there too.

    Ok, this is weird. So I tried to narrow down the problem:

    1. I tried DiskEditor on a 60GB external USB drive I had. This time no problems. No 16 bytes shifting or swapping on that drive. Everything worked fine.
    2. I thought there might be some malware on my machine messing things up, so I installed DiskEditor on a different laptop that had a clean install of XP with SP2, but had the same problems with the Maxtor drive. So something about the Maxtor drive and DiskEditor don't get along.

    Anyone seen anything like this before? And what could be causing it?
  2. Acronis Support

    Acronis Support Acronis Support Staff

    Apr 28, 2004
    Hello GerryFeed,

    Thank you for your interest in Acronis Disk Management Software.

    Could you please download Acronis Report utility available at and run it (with your Maxtor USB drive connected), create a report and send it to us? This would provide us with detailed information on the hard disk partition structure.

    Please collect the information requested above and contact us from our web-site: . Please don't forget to send the link to this thread along with gathered information. This would allow us to investigate the problem and help you with the solution.

    Thank you.
    Vasily Semyonov
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.