WD External Drives not visible in Explorer when pluged into Dynex FireWire Card

Discussion in 'hardware' started by Cutting_Edgetech, May 14, 2010.

Thread Status:
Not open for further replies.
  1. Cutting_Edgetech

    Cutting_Edgetech Registered Member

    Mar 30, 2006
    I have 2 Western Digital 1tb Drives plugged into a Dynex DX-FC103 IEEE 1394 Firewire 3-Port PCI/IO Card and both drives are not visible in Windows Explorer. I've tried uninstalling the Firewire Card under device manager, and also uninstalling the drives themselves with no luck. After reinstalling the drives, and card both external drives are still not visible in explorer. When looking under disk management it says that both external drives have not been initialized, and the space is unallocated. I tried initializing the drives, but windows is unable to do so. Windows also will not allow me to assign a drive letter to the drives. I've tested both drive, and they are both good. I am able to connect them with a usb 2.0 device, and access the drives through the usb 2.0 connection. I also tested the firewire connections on the drives, and they are good. I'm running Windows Ultimate 64 bit OEM. I've spent hours googling this with no luck. It seems like i'm not the only one experiencing this problem. There's lots of post, and none of the solutions posted have not resolved my problem. Anyone got any ideals why the drives are not visible in windows explorer? The device manager shows both drives installed, and working properly. The drivers are also the latest version.

    Attached Files:

    Last edited: May 14, 2010
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.