Watching Amazon Prime Movies with Firefox

Discussion in 'other software & services' started by TheKid7, Dec 22, 2013.

Thread Status:
Not open for further replies.
  1. TheKid7

    TheKid7 Registered Member

    Joined:
    Jul 22, 2006
    Posts:
    3,469
    I recently did a hardware upgrade with an Operating System clean install on one of my PC's.

    OS: Windows 7 Home Premium 64 Bit
    CPU: Intel Core i5
    RAM: 8 GB
    On-Board Graphics: Intel HD Graphics 4600

    The newly upgraded PC seems to be very stable with only one problem being encountered:

    Firefox 26.0: There are periodic brief pauses when watching Amazon Prime Videos. This seems to happen once every few seconds and only lasts for a fraction of a second.

    So far I have done the following with the problem still being unresolved:

    1. Updated to the latest version of the Adobe Flash player for Firefox.
    2. Installed Microsoft SilverLight X64.
    3. Streamed several YouTube HD videos with No Pauses detected.
    4. Watched several Amazon Prime videos in Internet Explorer 11 with No Pauses detected.

    I have made many searches on the web to try to resolve this issue. Does anyone have any tips/suggestions on what to try next to resolve this issue?

    Thanks in Advance.
     
  2. Dermot7

    Dermot7 Registered Member

    Joined:
    Dec 20, 2009
    Posts:
    3,196
    Location:
    Surrey, England.
  3. Raza0007

    Raza0007 Registered Member

    Joined:
    Mar 30, 2009
    Posts:
    1,425
    Location:
    USA
    I watch Amazon Prime regularly on Firefox and I have not experienced the problem you are describing. It maybe that one of your extensions might be interfereing with Amazon Prime. Have you tried disabling all your extensions and add-ons to see if it solves your problem?

    Other thing I can mention is to check and see if you are using Firefox with default setting, I mean you have not modified any settings in the about:config

    By the way, by default, Amazon Prime streams with Silverlight, so updating adobe flash or watching videos on youtube should have no bearing to your problem.
     
  4. JRViejo

    JRViejo Global Moderator

    Joined:
    Jul 9, 2008
    Posts:
    20,968
    Location:
    U.S.A.
    TheKid7, also try disabling Hardware Acceleration to see if it makes a difference.

    Options > Advanced > General Tab> Uncheck Use Hardware Acceleration When Available. Restart browser.
     
  5. TheKid7

    TheKid7 Registered Member

    Joined:
    Jul 22, 2006
    Posts:
    3,469
    Thank you.

    I tried disabling the Hardware Acceleration in Firefox, and the problem was still there and may be a little worse without hardware acceleration.
     
  6. whitedragon551

    whitedragon551 Registered Member

    Joined:
    Sep 30, 2008
    Posts:
    3,189
    Location:
    USA
    Disable all addons and test. If everything works as it should enable addons one at a time until it doesnt work. Disable the last thing you enabled.
     
  7. TheKid7

    TheKid7 Registered Member

    Joined:
    Jul 22, 2006
    Posts:
    3,469
    Thanks.

    The information in the second link seems to have helps some. I added the two website entries to the Adobe Flash Player storage limit and increased the storage limit to 1 MB for each website entry. I again increased the Adobe Flash Player storage limit to 10 MB for each website entry, but I saw not significant improvement in performance over 1 MB. I decided to leave the storage limit at 10 MB for each website entry.
     
Loading...
Thread Status:
Not open for further replies.