Vmware Workstation Bridged Networking - No Connection

Discussion in 'ESET Smart Security' started by andreas73, Jan 26, 2009.

Thread Status:
Not open for further replies.
  1. andreas73

    andreas73 Registered Member

    Joined:
    Jan 26, 2009
    Posts:
    6
    Dear ladies and sirs,
    I need your help:
    I use a VWmare Workstation 5.5 and NOD32 Internet Security (out of the box - i.e. no firewall modifications). However I do not get a network connection with the VMware Host, when Bridged Networking is set. NAT however works - but Bridged Networking is required.

    So, what do I have to do to make it work?
    Thanks.
     
  2. Meriadoc

    Meriadoc Registered Member

    Joined:
    Mar 28, 2006
    Posts:
    2,642
    Location:
    Cymru
    Check any logs you may have. For testing while trying to get bridge to work turn off the firewall, a firewall maybe blocking packets which could prevent the virtual machine from accessing the network. Install vmtools.
     
  3. andreas73

    andreas73 Registered Member

    Joined:
    Jan 26, 2009
    Posts:
    6
    Vmtools are installed. Bridged Networking works both without firewall as well as with other firewalls than NOD32 Internet Security.
     
  4. Rmuffler

    Rmuffler Former Eset Moderator

    Joined:
    Jun 26, 2008
    Posts:
    995
    Location:
    San Diego, CA USA
    Hello andreas73,

    Switch to Interactive mode:

    1. Open the main program window by clicking Start -> All Programs -> ESET -> ESET Smart Security.

    2. Press the F5 key to open the Advanced Setup window.

    3. From the Advanced Setup tree on the left, Click Personal firewall, and then select Interactive mode from the Filtering mode drop-down menu.

    And then set up Protocol filtering:

    1. Open the main program window by clicking the ESET icon next to the system clock or by clicking Start -> All Programs -> ESET -> ESET Smart Security.

    2. Press the F5 key to display the Advanced Setup window.

    3. From the Advanced Setup tree, click Personal Firewall -> Protocol Filtering.

    4. Select the Applications marked as Internet browsers or e-mail clients option.

    5. From the Advanced Setup tree, click Antivirus and antispyware -> Web access protection -> HTTP -> Web browsers and make sure that only the applications you want scanned with the Internet filter are selected. Typically only real web browsers (iexplorer.exe, firefox.exe, etc.) will need to be selected. Repeat this step for email clients (outlook.exe, thunderbird.exe, etc.) by clicking POP3 -> Email Clients.

    6. Click OK to save your changes.

    Thank you,
    Richard
     
  5. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    In the IDS section of the firewall setup, make sure to enable the "Enable communication for bridged connections" option.
     
  6. andreas73

    andreas73 Registered Member

    Joined:
    Jan 26, 2009
    Posts:
    6
    Thanks for all your answers.

    In the end, the "thing" that made it work, was re-installing vmware (when eset internet security was installed).

    After doing so, bridged networking worked out-of-the-box as well.

    It seems that (at least on my machine) the installation order mattered - first eset internet security, and only then vmware.


    Thank you all again.
     
Thread Status:
Not open for further replies.