vBulletin 3.5 Issue

Discussion in 'General Topics' started by Capp, Oct 10, 2005.

Thread Status:
Not open for further replies.
  1. Capp

    Capp Registered Member

    Joined:
    Oct 16, 2004
    Posts:
    2,125
    Location:
    United States
    Ever since the upgrade to 3.5, my experience at Wilders had been kinda weird. No matter how many times I log on from a single machine, it always tells me I have a few hundred unread threads. I even clicked the "Mark Forum read" to mark them all as read. Also, anytime I make a post or reply to a post and then click the "New Posts" link, mine never show up.
    There are only a handfull of forums here that I actually view on a regular basis, so I always have a ton of unread threads. I have always just used the "New Posts" link to refresh my listings, but now it seems to be a little off.

    Anybody else notice any of these?
     
  2. Capp

    Capp Registered Member

    Joined:
    Oct 16, 2004
    Posts:
    2,125
    Location:
    United States
    Also, I just noticed that If I read a thread and then click the "New Posts" link again, the thread I just read dissappears. It didn't use to do that. I liked having it remain there, because it allowed me to see how many people have read certain threads.

    Is there an option I can adjust somewhere to keep these here?

    Thanks
     
  3. beetlejuice69

    beetlejuice69 Registered Member

    Joined:
    Mar 16, 2005
    Posts:
    780
    Yup, same for me...even after "mark forums as read."
     
  4. LowWaterMark

    LowWaterMark Administrator

    Joined:
    Aug 10, 2002
    Posts:
    17,876
    Location:
    New England
    Are they remaining all marked as unread immediately after using "Quick Links" > "Mark Forums Read" within that session, or are you saying that after that, exiting and coming back again (perhaps after a browser restart) they return to unread again?

    Now, I don't want to get your hopes up by asking this question because frankly there is nothing I can adjust on this end to fix the problem for you when it works for the majority of people. At best, it could be a vBulletin bug that only effects some people, which in time they'll find and resolve, or at worst, it's a problem on your end that we can't help you with. But I can't do anything about it because we're talking some pretty core vBulletin code here. The unread thread subsystem is very complex and not something I'm going to be messing around with.

    Although this problem is different, the usual recommendations always apply as a starting point. Clear cache, restart browser, and make sure no web filtering, proxy, cache servers, or software firewall applications are getting in the way of your session here. Make sure session and permanent cookies are fully allowed, as many of these variables are passed via cookies. A little more on this is here.

    "New Posts" is actually just a predefined Search function. vBulletin does not re-execute a search if the searching parameters have not changed since the last time you made that search, and it's within a certain time frame. When you click New Posts, make a quick post somewhere, and then click New Posts again, vBulletin starts back within its cached search results, and simply passes a slightly filtered version of those back to you again. It isn't able to add results, as the collection set is established when you first did the search, but it can drop items out if certain other parameters change. (A search results cache is really just a list of either thread or post IDs, and that list of IDs does not change when the same search is re-executed within an hour, and within the same session. But, the displaying of the results is a processing loop that can drop some items out based upon IF conditions available when those IDs are mapped back to the original posts or threads themselves for displaying the search results page back to you.)
     
  5. Capp

    Capp Registered Member

    Joined:
    Oct 16, 2004
    Posts:
    2,125
    Location:
    United States
    Hey Mike,
    I mark forums read and all the threads are marked. I exit, clear the cache (no proxies), and return and it stays marked as read. It is appearing a little different than it used to. For me, it would show all posts that were made since my last visit regardless of if they were read or not. Now, it just continuously adds to what was there and racks up some massive page numbers. Now, this doesn't always happen and I do view wilders from several different pcs.

    What I was getting at, is..the past year I have been here, I always just clicked the "New Posts" link and it would refresh with the latest posts and show all the other posts I had already looked at. Basically, it kept the current list and just updated with the newest. If I created/edited/or replied to a post, then click the "New Posts" link, it would instantly show up at the top. Now it does not.

    I am not complaining nor trying to start any uprisings ;)

    I just thought I would comment on the noticable difference that I had become accustomed to.
     
Thread Status:
Not open for further replies.