Utorrent

Discussion in 'LnS English Forum' started by Delgado, Feb 17, 2006.

Thread Status:
Not open for further replies.
  1. Delgado

    Delgado Registered Member

    Joined:
    Apr 28, 2004
    Posts:
    131
    Im using the bit torrent programme utorrent. Ive just tried it using the enhanced rule set, and it connected and worked. Do i still need to install the rule set from you called "Bit Torrent", and if so what difference will that make?

    Utorrent uses one port only and im using port 48253.


    Delgado
     
  2. fred22

    fred22 Registered Member

    Joined:
    Dec 6, 2004
    Posts:
    229
    no not really...to make u connectable u must forward the port though..rightclick the blocked TCP incomming conn and create:

    Add Rule TCP: allow Port 48253 Server

    the only diff now is that u r connectable...they say its better for seeding?!

    i get max speeds whitout adding the rule
     
  3. Delgado

    Delgado Registered Member

    Joined:
    Apr 28, 2004
    Posts:
    131
    Thanks fred,

    My prog seems to be working OK without adding the rule, so as you say yours is. I wont bother at the moment, see how it goes.

    If Ive got to add rule later, when I right click on pro nothing happens. Do I have to go to Internet Filter and highlite the rule TCP Block incoming connections, and then click edit?

    Thanks for help

    Delgado
     
  4. chaosblade

    chaosblade Registered Member

    Joined:
    Dec 30, 2005
    Posts:
    18
    Location:
    Israel
    Incoming connections are pretty important for BitTorrent, so i would create that rule. What i did is just create a rule for incoming and outgoing traffic on my uTorrent port for the UTORRENT.EXE program itself (or at least, the rule is triggered by the launching of uTorrent).
     
  5. Delgado

    Delgado Registered Member

    Joined:
    Apr 28, 2004
    Posts:
    131
    Thanks you guys for your help will try what you recommend.

    :) :) :)
     
  6. Delgado

    Delgado Registered Member

    Joined:
    Apr 28, 2004
    Posts:
    131
    Well I have success with this. Ive altered the Bit torrent rie file from the site, to read utorrent, and altered the port numbers to mine, and installed. Seems to be working.

    Can anyone tell me if i have put my security in jeapordy by doing this?

    Thanks in anticipation- Delgado.

    PS- What a friendly forum this is thanks again for help!!!
     
  7. chaosblade

    chaosblade Registered Member

    Joined:
    Dec 30, 2005
    Posts:
    18
    Location:
    Israel
    Opening a port is always somewhat of a risk. But since the only application that should be listening on that port is utorrent, You're probably safe (unless uTorrent has some serious buffer overrun weakpoints - and i doubt that).
     
  8. fred22

    fred22 Registered Member

    Joined:
    Dec 6, 2004
    Posts:
    229
    check log
    rightclick blocked TCP conn
    add TCP rule 45444 Server
    http://img70.imageshack.us/img70/4774/pic261200622160430120062191214.png

    place it below +ACK-URG
    http://img227.imageshack.us/img227/4774/pic261200622160430120062191214.png

    select rule..click edit .. click applications..add UTorrent
    http://img393.imageshack.us/img393/4774/pic261200622160430120062191214.png

    save

    finally UTorrent shows u that Network status = OK
    http://img97.imageshack.us/img97/4774/pic261200622160430120062191214.png

    credits to imageshack for hosting...

    i could be totally wrong here...?! dont shoot me :thumb: :D
     
  9. chaosblade

    chaosblade Registered Member

    Joined:
    Dec 30, 2005
    Posts:
    18
    Location:
    Israel
    Thats pretty much it, Besides the reasoning of putting it below some other rules. Thats more specific to the rules you use i guess.
     
  10. bloodscourge

    bloodscourge Registered Member

    Joined:
    Jul 3, 2004
    Posts:
    372
    Location:
    France
    That's a good way to demonstrate LNS log handling :D. If you need DHT network, you should have to switch from "TCP" to "TCP or UDP" in rule edit.
     
  11. Delgado

    Delgado Registered Member

    Joined:
    Apr 28, 2004
    Posts:
    131
    Thanks Fred. Most helpful. I appreciate your help.

    Will set up as you say. Thanks for your time.
     
  12. Khane

    Khane Registered Member

    Joined:
    Oct 20, 2005
    Posts:
    12
    Hi

    I am a Look 'n' Stop and also a µTorrent newbie and I have some questions about making rules in Look 'n' Stop for µTorrent.
    I have read this thread but I am afraid that because of my limited knowledge about technical stuff related to computers , the explanations were a bit confusing for me.

    Before using µTorent I used the original BitTorrent client and of course I downloaded the rules for BitTorrent from the Look 'n' Stop web site and applied them. After a few days I started to use µTorrent and made it my default BitTorrent client. I was sure it would be OK but when µTorrent is running , DHT is always on DHT (0 Peers (Login)" or sometime on "Waiting to log in". I then try to use Windows XP firewall instead and then peers started to appear in the DHT. It seems that the rules from Look 'n' Stop for BitTorrent do not work wery well for µTorrent.

    I would like to know if I understand exactly the explanation in post # 8 of this thread.
    Here are the step as I understood them :

    1. go to "Log" and then right click on any of the TCP : Block incoming connection
    2. left click on "add rule: TCP Allow Port 32459" that appears
    3. go to "Internet Filtering" and double click on "TCP Allow Port 32459" to edit
    4. in Rule Editing ,under TCP/UDP : port I should see : "Equals" then "32459" and then "0"
    5. click on "Application" and then double click on UTTORENT.1.4.2.BETA BUILT EXE

    I don't know if it is the right thing to do to make a rule that works with µTorrent but that's what I did. Now when I open µTorrent I get a "NAT error"" and DHT keeps being on "Waiting to log in" and download is ridiculously slow.
    As soon as I close Look 'n' Stop and open the Windows' firewall DHT starts showing nodes and the download speed drastically rises , so I bet that I did something wrong while making the rule for µTorrent in Look 'n' Stop :doubt:

    Thanks in advance.
    Khane
     
  13. Meltdown

    Meltdown Registered Member

    Joined:
    Sep 17, 2004
    Posts:
    299
    Location:
    Babylon
    For DHT, you'll need to allow inbound UDP connections to local port 32459.

    edit: and outbound UDP as well, of course, to any remote port.
     
    Last edited: Mar 6, 2006
  14. 2MA

    2MA Registered Member

    Joined:
    Jan 26, 2006
    Posts:
    14
    @ fred22
    What rules set are you using? Phant0m?
     
  15. altea

    altea Registered Member

    Joined:
    Nov 21, 2005
    Posts:
    16
    hello !
    i ve exactly the same problem than Khane but for my part, it seems to have no influence on my speed which is high
    can u explain what's this another rule to be added ??

    thanks !!
     
  16. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
  17. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    I have created just two rules and uTorrent working beautiful and not experienced ANY problems since I’ve begin testing which was well before the creation of this here topic…

    These rules aren’t going to be what most be expecting to see, and may not work depending on persons connection type, operating system and network configurations.
     

    Attached Files:

  18. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    ... .. .. .
     

    Attached Files:

  19. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    ... .. .. . .
     

    Attached Files:

  20. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Probably isn’t best idea to set Application on these two rules, I think there is a slight problem with uTorrent and way that feature works for UDP Protocols...
     
  21. agentsmith

    agentsmith Registered Member

    Joined:
    Aug 14, 2006
    Posts:
    13
    I'm just trying to set up uTorrent myself and I'm total newbie at this, but I noticed this in the Beginners Guide on the uTorrent website:
    But from the pictures you posted above, it seems you're doing exactly that.
     
  22. agentsmith

    agentsmith Registered Member

    Joined:
    Aug 14, 2006
    Posts:
    13
    I'm not sure if this is an issue or not...

    I'm behind a router, so I went through the process of setting up a static IP address and port forwarding on the router (using the instructions here: http://portforward.com).

    I have not set up any rules for uTorrent in "Internet Filtering", but it is still able to connect and seems to be working fine, although my download/upload speeds are rather slow, around 15 kB/s or less (usually less).

    Before I set up the port forwarding on the router, I would get blocked incoming connections showing up in the log, but now there are none. How is it connecting without a rule to allow it? Why aren't the incoming/upload connections being blocked anymore? Will the speed improve if I add a rule as you folks have described here?


    PS: I am using the Enhanced Ruleset with no changes from the default settings/rules.
     
  23. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi,

    Are you sure the network interface is correctly selected in the options ?
    When it is properly selected, on the welcome page:
    - your IP address is displayed
    - the "connected to internet" checkbox is ticked (automatically)
    - the stats are progressing when there are transfers

    In the application filtering you can select the !! attributes for your P2P client so you will see which ports are used exactly (for the outgoing connections only).

    Frederic
     
  24. agentsmith

    agentsmith Registered Member

    Joined:
    Aug 14, 2006
    Posts:
    13
    Yes, this was the problem. I have a laptop with built-in wireless, so I set up a static IP address for both the LAN and wireless connections. In "Options", it had "automatic selection" and the wireless connection checked for some reason. As soon as I switched it to the wired connection, I got LOTS of log entries.

    Does this mean LnS only monitors/guards one connection at a time?
     
  25. agentsmith

    agentsmith Registered Member

    Joined:
    Aug 14, 2006
    Posts:
    13
    I just discovered something...

    When I have the ethernet card selected in the "network interfaces" and "automatic selection" checked, if I unplug the ethernet cable, LnS automatically switches over to the wireless connection... it then shows the IP address of the wireless card on the Welcome page, and has the wireless card selected in the "network interfaces" list.

    However, when I plug the ethernet cable back in, it does NOT automatically switch back, and stays with the wireless card.

    Why can't LnS monitor more than one connection at once? I would like to have everything set up so that I can go back and forth between wired and wireless without having to manually change anything.
     
Thread Status:
Not open for further replies.