USB ports not working after installing HFS+ for Windows 8/8.1

Discussion in 'HFS for Windows' started by Timbito, Jun 25, 2015.

  1. Timbito

    Timbito Registered Member

    Joined:
    Jun 25, 2015
    Posts:
    1
    Hey,

    I have a 500 GB WD external hard drive with two partitions, one NFTS formatted, and one HFS+ formatted. Up until installing the HFS driver on my machine, it would always recognize my NFTS partition just fine.

    I downloaded HFS+ for Windows 8 a few days ago and, after installing the driver and restarting the computer, I noticed that my hard drive wasn't recognized at all by Windows. The USB icon in the taskbar showed the name of the device for a few minutes (without any partition names), and then just three dots. The Device Manager displayed a Code 10 error and said the device could not be started. After trying to run the installer again to repair the driver, reinstalling it, or restating the computer several times, I finally restored it to before installing the HFS+ driver. Once again Windows would only recognize my NFTS partition as before.

    I tried installing the driver once again and this time I noticed that the driver would actually work fine if, after booting, the computer would be put to sleep and then woken up (I couldn't, for the life of me, figure out why). It kept working until yesterday, when I started having the same problem with Windows not being able to start the device. I tried putting the computer to sleep and then waking it up several times, and then restarting it several times. Nothing worked. Then, noticing that the driver actually worked fine on my USB 2.0 ports, I thought that there might be some sort of conflict between the Intel USB 3.0 driver and the HFS+ driver, so I uninstalled the USB 3.0 driver and restarted Windows, so it would install it again. After this, every USB port on my computer stopped working. They still give out power (my usb powered speakers work on all ports and the external HD light comes on), but Windows won't recognize my hard drive, nor my usb flash drive or wireless mouse adapter (the latter two worked fine up until now).

    I don't want to enter a vicious circle where I would just restore my system every few days. Any ideas as to what my be the problem/solution?

    I have an Acer Aspire V3-571G, running Windows 8.1 64-bit.