urlmon.dll problem

Discussion in 'other software & services' started by ndstevens21, Jul 7, 2008.

Thread Status:
Not open for further replies.
  1. ndstevens21

    ndstevens21 Registered Member

    Joined:
    Jul 7, 2008
    Posts:
    2
    I hope someone can help me!!!

    For the last few days, I've been trying to figure out how to replace what I believe is a corrupt urlmon.dll file. A number of programs (including Windows Explorer, System Restore, Palm Desktop, RegCure, Norton Anti-Virus Scan and others ...) begin to load, but then send me to an error message. (For the most part, Firefox and Thunderbird work fine.)

    When I go to eventvwr, I find the following message:

    Windows cannot access the file c:\windows\system32\urlmon.dll for one of the
    following reasons: there is a problem with the network connection, the disk that the file is stored on, or the storage drivers installed on this computer; or the disk is missing. Windows closed the program OLE32 Extensions for Win32 because of this error.


    I've checked all those:

    A. the file does exist in Systerm32

    B: re: network connection - I can access other computers on the network just fine, and they can access me.

    C: re: disk filed is stored on: chkdsk finds no errors

    D: re: disk missing: not an issue.

    Other things I've tried:

    1. Downloaded a replacement urlmon.dll to reinstall it, and I get the same error message when I try to execute it using Windows Explorer.

    2. Tried regsvr32 urlmon.dll, which results in a "successful" message, but the same problem exists after rebooting.

    3. Resorted to using the cmd prompt to do some looking around, but when I try to do System Restore from the Run window, I get the same error message.

    4. I've checked a number of other forums, and most everyone else's problems have to do with Internet Explorer, not other programs, and I've received little or no response from anyone.

    It seems like I'm in a perpetual loop and don't know how to get out of it.

    I really hope you can help as I need my office computer back!

    Thanks.

     
  2. noway

    noway Registered Member

    Joined:
    Apr 24, 2005
    Posts:
    351
    Have you tried installing June's cumulative ie update, WindowsXP-KB950759-x86-ENU.exe??
     
  3. ndstevens21

    ndstevens21 Registered Member

    Joined:
    Jul 7, 2008
    Posts:
    2
    Yes, and it told me that I have the wrong Version of IE installed. Tried installing 7, but that failed.

    I've also tried booting in safe mode - same problem. I ran msconfig in safe mode, disabled all startup programs and all services except those from MS, rebooted - same problem.

    I can't uninstall anything because Windows Explorer & Control Panel won't run.

    I'm really at a loss - am I stuck with reinstalling XP?
     
  4. GlobalForce

    GlobalForce Regular Poster

    Joined:
    Jun 30, 2004
    Posts:
    3,581
    Location:
    Garden State, USA
Loading...
Thread Status:
Not open for further replies.