UPnP in Trusted Zone

Discussion in 'ESET Smart Security' started by TTPoker, Dec 5, 2007.

Thread Status:
Not open for further replies.
  1. TTPoker

    TTPoker Registered Member

    Joined:
    Dec 5, 2007
    Posts:
    2
    I am having a problem setting up TVersity. I am using TVserity to act as a UPnP media server. When ESET's firewall is disabled everything works perfectly, my UPnP media devices connect correctly to TVersity. However when the firewall in enabled it fails.

    I have opened the firewall for all the applications in the folder and I am running in interactive mode but I don't get any pop-up boxes warning me of blocked traffic. Also I have the Allow UPnP in the Trusted Zone allowed. It seems like I've got everything covered, can anyone help?
     
  2. TTPoker

    TTPoker Registered Member

    Joined:
    Dec 5, 2007
    Posts:
    2
    Still looking for a solution. The problem seems to be with UPnP protocol because I can duplicate the problem when using other media server applications such as Nero Media Home or Twonky Media Server. UPnP protocol traffic is blocked. Help!
     
  3. Chuck_IV

    Chuck_IV Registered Member

    Joined:
    Aug 17, 2005
    Posts:
    133
    This problem has been around since early beta and for some reason they either don't know how to or won't fix it. This problem also(I think) encompasses people's XBox media issues, as well as Directv's HR20 Media sharing.

    I had the issue with my Directv HR20 boxes being blocked. After seeing what was being blocked in the log files, I was able to create a somewhat broad rule under System, which allowed access. The problem was, another problem, that they won't address reared it's head in that when you create a rule under "System", it will take, but it will not appear in the Firewall's rules list, so there is no way to remove it or change it, after the fact.

    I ended up removing ESS and moving to something different because the latter issue(rule not showing up, nevermind the media sharing issue) IMO is critical, but continues to go unfixed.
     
  4. psychosmurf

    psychosmurf Registered Member

    Joined:
    Feb 23, 2008
    Posts:
    14
    Well this has helped me out a lot. I can stopping hitting my head on my desk trying to figure out why the XBox won't connect when the firewall is enabled.

    I just set up TVersity this weekend and spent all weekend trying to figure out why I kept getting 'The connection to your computer was lost' on my XBox 360. Finally narrowed it down to ESS which brought me here.

    I disabled all the System uPnP rules and I still can't get my XBox to connect when the firewall is active. Seems Eset has a bit of work to do on their firewall.
     
  5. regis

    regis Registered Member

    Joined:
    May 4, 2008
    Posts:
    1
    In Setup, go under Personal firewall > IDS and advanced options > Allowed services, check Allow UPNP in the Trusted zone.

    It worked for me with my Archos 605.
     
Thread Status:
Not open for further replies.