Uninstalling PEDemo causes havoc

Discussion in 'Port Explorer' started by negora, Sep 21, 2004.

Thread Status:
Not open for further replies.
  1. negora

    negora Guest

    Hi All,

    I was trying out the PE Evaluation version some time ago and today I tried to uninstall it, since the trial was over. However, this caused my computer to stop working properly (could not use the network connection anymore, mysql, apache, instant messaging apps, all dead).

    I'm using WinXP SP1, as for PE, no idea what version that is, the exe is 254,464 bytes (I can't get the version cause it expired).

    To post this message I reinstalled the demo and this seemed to cure my yahoo messenger, gaim, and the rest of the application that use outbound connections, however, my apache server won't work, throwing a warning: [Tue Sep 21 23:54:36 2004] [warn] getsockname

    I can't stress how utterly frustrating this is and I'm hoping some of you can help me out. I really need to fix this, as you may imagine.

    Thanks a lot
     
  2. Bowserman

    Bowserman Infrequent Poster

    Joined:
    Apr 15, 2003
    Posts:
    510
    Location:
    South Australia
    Hi negora :).

    Don't know if this will fix your problem, and you may want to wait for a reply from DCS first (just to be safe), but have a read here if you like about LSP-Fix or the other Winsock repair utilities at the bottom of the page.


    Regards,
    Jade.
     
  3. negora

    negora Guest

    Thanks, I'll give that a try.

    Jason of DCS suggested the same solution, and he also mentioned this might be a known bug in the Apache version I'm using. It's pretty weird nevertheless.
     
  4. Jason_DiamondCS

    Jason_DiamondCS Former DCS Moderator

    Joined:
    Nov 11, 2002
    Posts:
    1,046
    Location:
    Perth, Western Australia
    No, Apache wouldn't cause the uninstall bug (unlikely), I just know Apache v1.3xx has problems with Port Explorer installed, that they fixed in later versions.

    Your uninstall bug is most likely caused by another software package you have installed, LSPFIX will help you identify which one.
     
  5. PeterVO

    PeterVO Registered Member

    Joined:
    Aug 25, 2003
    Posts:
    87
    Location:
    Belgium, Leuven
    Hello,

    when removing V1.8 and installing V2.0 of Port Explorer, NOD32 gave a warning that the network configuration had changed and repaired them.
    So I presume the winsock LSP chain has been changed, preventing network access.

    Kind regards,

    PeterVO
     
  6. Mr.Blaze

    Mr.Blaze The Newbie Welcome Wagon

    Joined:
    Feb 3, 2003
    Posts:
    2,842
    Location:
    on the sofa
    dcs crew im starting to wonder if sp2 is proveing to be to much lol
     
  7. Jooske

    Jooske Registered Member

    Joined:
    Feb 12, 2002
    Posts:
    9,713
    Location:
    Netherlands, EU near the sea
    Uhmmmmmmmm you did close all your scanners when un/installing Port Explorer including their resident protection, i might hope?
     
  8. FanJ

    FanJ Guest

    Yep, I too noticed that twice when I upgraded earlier today.
    First after uninstalling PortExplorer 1.800, second after installing Port Explorer 2.000.
    As far as I can tell at the moment: no problem ;)
     

    Attached Files:

  9. I encountered what seems to be the same problem as negora. After uninstalling the demo I have network problems. I'm using Windows 2000 SP4, PE version 2.0. I reinstalled PE and everything seems fine, I uninstall again and I have network problems. When I reinstalled PE, GoogleDesktop Search complained about PE. Google indicates that PE conflicts with GoogleDesktop: http://desktop.google.com/support/bin/answer.py?answer=10742

    I've tried uninstalling both and still have problems. Currently I have PE installed and everything seems to be working. It would be nice to be able to uninstall PE.
     
  10. hardhead

    hardhead Registered Member

    Joined:
    Mar 4, 2004
    Posts:
    292
    Location:
    Blue Ridge, Va
    I dont think so. :D
    I have installed PE 2 and uninstalled with no problems at all. Running XP Pro SP2!
     
  11. Pilli

    Pilli Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    6,217
    Location:
    Hampshire UK
    Hi Ihavenousername, Did you try LSP fix as mebtioned by Bowserman above ?

    Pilli
     
  12. Yes, I tried LSP fix, here's what's left in the keep column:
    rnr20.dll
    winrnr.dll
    nwprovau.dll
    msadf.dll
    rsvpsp.dll

    When I reinstall PE, dcsws2.dll is also included. I also tried having LSP remove PE with the same result - network problems, I have to reinstall PE.

    Any other ideas?
     
  13. Gavin - DiamondCS

    Gavin - DiamondCS Former DCS Moderator

    Joined:
    Feb 10, 2002
    Posts:
    2,080
    Location:
    Perth, Western Australia
    NOD32 has a very complex LSP program running that you dont notice. A good thing to try would be to uninstall NOD32, reboot, reinstall it, reboot - while OFF the internet of course, just in case.

    And check your system with TDS-3 just in case :) theres nothing better than malware running to cause problems..
     
  14. Thanks Gavin for the suggestions, but I'm still trying to recover from the last DiamondCS program I install. I might try your other programs after I'm able to fully uninstall Port Explorer. As far as malware, I currently have Spybot-SD 1.3 and Symantec AntiVirus 3.5 installed both with current definitions.
    Any manual steps I could try to get PE off my PC?
     
Thread Status:
Not open for further replies.