Uninstall Problem - Now Registry Problem

Discussion in 'ESET Smart Security v4 Beta Forum' started by COSMO26, Mar 5, 2009.

Thread Status:
Not open for further replies.
  1. COSMO26

    COSMO26 Registered Member

    Joined:
    Oct 21, 2003
    Posts:
    404
    XP SP3 --- When I Uninstalled V4 ESS to Re-load V3 ESS I tried Control panel Uninstall instead of the Start/Programs/ESET route that always worked. Blue Screen Windows auto-shutdown, etc led to manual Deletes and Re-Install of V3 ESS. Today attempted Uninstall of V3 ESS to load JUST V4 AV.

    Atempts to Install V4 AV netted "Network Error Attempting to read C:\Windows\Installer\eav_nt32_enu.msi string. I probably Deleted "callmsi.exe/egui" in the Registry Trying to wipe out remnants of egui that STILL showed in a pop-up after "Regular" Explorer and Registry Deletes. Per ESET instructions Copying (e.g., eav_nt32_enu.msi) to the Installer folder and THEN trying to Delete ESET produces (Edited) "Looking for callmsi.exe".

    I can't Un-Install Correctly OR Install anything to do with ESET. Any suggestions?
     
    Last edited: Mar 5, 2009
  2. ASpace

    ASpace Guest

    Last edited by a moderator: Mar 5, 2009
  3. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,802
    Location:
    Texas
  4. COSMO26

    COSMO26 Registered Member

    Joined:
    Oct 21, 2003
    Posts:
    404
    Thanks to you both. I ran the Installer Cleanup Utility and still get the "Network Error Attempting to read C:\Windows\Installer\eav_nt32_enu.msi string....

    Registry "Find" for Eset, ekrn, egui produce nothing now and I can't find any Folders left in Explorer.

    The Only directions I know from ESET say if you get this "Can't Read message are:
    "To resolve the issue, copy the .msi installer file (e.g., eav_nt32_enu.msi) to the C:\Windows\Installer directory and attempt to uninstall/reinstall your ESET security product again."


    That File IS in the Installer Folder now, so that makes no sense if I understand things. Running Uninstall via Start produces "Looking for callmsi.exe"" (that was not quoted correctly in 1st post but I edited it) and that's what I presume I deleted when dealing with the egui pop-up box earlier AFTER I thought I had UN-Installed ESS V3.

    Any other ideas?
     
    Last edited: Mar 5, 2009
  5. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,802
    Location:
    Texas
  6. COSMO26

    COSMO26 Registered Member

    Joined:
    Oct 21, 2003
    Posts:
    404
    Registry "Find" for Eset, ekrn, egui produce nothing now and I can't find any Folders left in Explorer.

    Thanks, Ronjor...Per above I've Manually DELETED Everything I can find prior to posting. I DID find the inf/INFCACHE.1 File still there but Deleting it STILL produces the Can't read string..

    Update: A Search for callmsi.exe produced (2) Results in Windows Install Folders (see jpeg in a later post below): one dated March 2 and the 2nd dated 2/28 and Dbl Clking the Folder shows egui.exe in each Folder. DO I DELETE THOSE? Trying to Re-Install V3 ESS just to see what happens gives "There's a later version of ESET installed now" (something like that)... Is it seeing these egui.exe's from earlier dates??
     
    Last edited: Mar 5, 2009
  7. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,802
    Location:
    Texas
    What a mess. Have you tried a safe mode install?
     
  8. COSMO26

    COSMO26 Registered Member

    Joined:
    Oct 21, 2003
    Posts:
    404
    In Safe Mode I get "Administrator has Policy to Prevent Install" when Clk'ing the App on desktop.

    I have tried to upload (2) jpeg files in this post showing callmsi.exe Search results, Each containing callmsi.exe & egui.exe (Mar 2 and Feb 28...I tried a System Restore to Feb 28 , thought it worked, but No Record shows in System Restore now when I go to it again. I read fast and may have mis-read Success.). DO I NEED TO MANUALLY DELETE EACH OF THESE (2) callmsi.exe & egui.exe pairs in Windows Installer Folder?

    Any comments appreciated!!
     

    Attached Files:

    Last edited: Mar 5, 2009
  9. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,802
    Location:
    Texas
    I suppose you are the admin of the system? The callmsi.exe and egui files look like remnants but I don't see the path to their location.
     
  10. COSMO26

    COSMO26 Registered Member

    Joined:
    Oct 21, 2003
    Posts:
    404
    Desktop stand-alone & I'm Administrator.... By "path to their location" do you mean "other than the Windows Installer Folder shown in the Address Bar of the jpeg picture (just above "callmsi.exe" in pic)??

    Don't forget that when I tried Re-Install of ESS V3 for test only it said a Later Ver of Eset was Installed. It's seeing Something but I don't know what to make it think Something IS INSTALLED. The Registry is as Empty as "Find" can produce for Eset, ekrn, egui and Explorer shows none of the typical Folders ESET Instructions say to Delete.. Maybe it's these two Installer\.msi Files Folders.
     
    Last edited: Mar 5, 2009
  11. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,802
    Location:
    Texas
    :gack: :)
    http://www.betterantivirus.com/nod32-antivirus-faqs/faqs/1118966858.html
     
  12. COSMO26

    COSMO26 Registered Member

    Joined:
    Oct 21, 2003
    Posts:
    404
    Thanks, Ronjor. Windows Temp full of 16kb Perflib_Perfdate files and Doc-Settings\User\Temp full of varied stuff. Were Administrator not logged in I'd see a far different screen.

    Nothing in your last post is out-of-whack unless I'm looking for a specific file/folder - I don't read that's the case - but Thanks.

    If the System restore I thought worked Really Didn't (Sys Restore screen for this date doesn't show the Restore BACK to 2/28 & assuming SR is Not broken) would it screw me up with ESET efforts to try another System Restore to yesterday instead of the Feb 28 I tried earlier?
     
  13. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,802
    Location:
    Texas
    I believe I would download Windows Installer and reinstall it. But, I don't see why trying sys restore would hurt anything at this point.
     
  14. COSMO26

    COSMO26 Registered Member

    Joined:
    Oct 21, 2003
    Posts:
    404
    Ronjor, System Restore to yesterday has V3 ESS RE-Installed and PRESUMABLY ready to screw up again on the next Uninstall Try. Would you do next V3 Uninstall via Start/Programs/ESET/Uninstall again to see what happens?

    To be safe, you DO MEAN Re-Install Windows Installer as in 4.5 rather than Win Install Cleanup Utility?

    If I have an earlier Installer Ver I read it will Install 4.5 over whatever is there, right?

    Thanks again!!
     
  15. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,802
    Location:
    Texas
    I always use the control panel and have never encountered the problem you are facing.

    Right. I would hold off on that for the being.

    Your system is back to normal with Ver3? If that's the case, I would install Ver4 over Ver3 and restart to see if that works.

    http://www.eset.com/threat-center/blog/?p=639&cpage=1#comment-37841
     
  16. COSMO26

    COSMO26 Registered Member

    Joined:
    Oct 21, 2003
    Posts:
    404
    Thanks. V4 ESS gave me so many Time-outs accessing sites that I had to abandon hope of using it now. So trying for V4 AV only won't let me install over V3 ESS - I presume.

    I'll try Control Panel Add-Delete again & hope it works.
     
  17. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,802
    Location:
    Texas
    Correct. Hold off on that for the time being.
     
  18. COSMO26

    COSMO26 Registered Member

    Joined:
    Oct 21, 2003
    Posts:
    404
    Going to Control Panel Add-Delete I SEE TWO (2) ESET Smart Securities-- (1) ESET Smart Security 47.58 MB last used 2/18/09 and (2) ESET Smart Security 31.09 MB last used 3/5/09 -- both are there.

    Progarm Files and Docs & Settings only show One ESET Folder and Registry HKCU and HKLM have One ESET Folder, too.

    Any idea what this may lead to if I try to Delete one at a time....doesn't look good!

    Sorry I missed the Installer clarification earlier right in front of my eyes, read it but it didn't sink in I guess.
     
  19. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,802
    Location:
    Texas
    As long as you have a restore point, you could give it a go. However, I haven't seen this error before.

    You could remove the oldest and try a repair install from the control panel with the newest version listed.
     
  20. COSMO26

    COSMO26 Registered Member

    Joined:
    Oct 21, 2003
    Posts:
    404
    Ronjor - anyone:: V4 AV-Only is Installed but Will Not Update....EDIT: Eureka...Just Updated to Mar 6...

    +++ Finally, Which is better IF I'm a safe surfer (age 60 tells you something) : V3 ESS or V4 AV with Windows FW , or a free FW if I get the nerve to try something like Comodo?

    FYI: Having had (2) ESS's in Control panel, I Deleted the bloated-older (47.58MB vs. std 31MB) ESS and did a Repair Twice on the remaining ESS in Control Panel Add-Delete....Red ESET Eye remained with varied error verbiage...Deleted that ESS and installed V4 AV.

    Ronjor, MANY MANY THANKS for sticking with me on this mess. Really wish V4 ESS worked in my machine but V4 AV hopefully will be good protection!!
     
    Last edited: Mar 6, 2009
  21. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,802
    Location:
    Texas
    Looking at your sig, I would say you are pretty well covered as it is. :D

    Good to hear you got things working.
     
Thread Status:
Not open for further replies.