Uninstall LibreOffice

Discussion in 'other software & services' started by emmjay, Jun 29, 2012.

Thread Status:
Not open for further replies.
  1. emmjay

    emmjay Registered Member

    Joined:
    Jan 26, 2010
    Posts:
    882
    Location:
    Triassic
    I have LibreOffice 3.5.3 installed. In the release notes for 3.5.4 they recommend the previous version be uninstalled before installing the upgrade. I tried to uninstall 3.5.3 using windows but LibreOffice is asking for 3.5.1 which I no longer have installed. I then tried to just install 3.5.4 and it asked for 3.5.1 also. The is no forum to ask anyone what to do.
    How can I force 3.5.3 off my system (W7/32)?
     
  2. stapp

    stapp Global Moderator

    Joined:
    Jan 12, 2006
    Posts:
    7,283
    Location:
    England
  3. vasa1

    vasa1 Registered Member

    Joined:
    May 1, 2010
    Posts:
    4,152
  4. emmjay

    emmjay Registered Member

    Joined:
    Jan 26, 2010
    Posts:
    882
    Location:
    Triassic
    Tnx for the link Stapp. It seems the problem is a matter of not enough privs to uninstall the version that I have. I will try to get it off my system using the command prompt ... the suggested method. It appears that the upgrade requires admin privs also. Seems odd that this info is not included in the release notes!

    If it does not work I will try the links that vasa1 provided. Tnx Vasa1.

    Update: This is what I tried ...
    I tried to uninstall 3.5.3 using Command Prompt (set to run as administrator) msiexec /x LibO_3.5.3 etc .... it did not work as it could not find the package. I retried just typing the C:\ location as it appears in WE, but that did not work either.
    I tried to install 3.5.4 using Command Prompt (set to run as administrator) msiexec /i LibO_3.5.4_Win_x86_install_multi.msi ... it can not find the package (it is on my desktop and I have no idea how to navigate from command prompt to the desktop).
    I am probably doing this wrong.

    I checked out the LibreOffice forum and there are many instances of problems with install and uninstall of different versions including 3.5.3 and 3.5.4. The solution points to using the command prompt, but no-one gives you all the steps. Some people have success and others not. This is a mutl.msi (windows installer) package but windows can not install or uninstall it and neither can I.
    I need more help. The LibreOffice forum is not helpful . Can anyone here tell me what to do?
     
    Last edited: Jul 1, 2012
  5. emmjay

    emmjay Registered Member

    Joined:
    Jan 26, 2010
    Posts:
    882
    Location:
    Triassic
    I got a response on ask.LibO but the answer was for a problem that I did not have. Windows can not uninstall 3.5.3 from my system without the 3.5.1 package which is no longer available. No one seems to know why the uninstall is asking for this package. The installation of 3.5.4 on my system is also asking for the 3.5.1 installation package (even when I use command prompt with admin privs. ). I finally worked out how to use command prompt properly so my original idea that the problem was related to admin privs was incorrect.

    Today I used Geekuninstaller to uninstall LibreOffice 3.5.3 (had to force it). It was removed. I then ran Ccleaner on all the leftovers, restarted W7 and tried to install 3.5.4 It asked for the 3.5.1 package again !!! I sent 3.5.4 to the recyccle bin.
    My solution: Downloaded and installed Apache OO with windows with no problems. I can access all my files that I created under LibO.
    Can not say that I would recommend LibO to anyone after this experience.
     
Loading...
Thread Status:
Not open for further replies.