Unable to install ESS on Vista Ultimate

Discussion in 'ESET Smart Security v3 Beta Forum' started by mmac, Apr 29, 2007.

Thread Status:
Not open for further replies.
  1. mmac

    mmac Registered Member

    Joined:
    Apr 27, 2007
    Posts:
    7
    Ok, so here is my problem. I haven't found any info on here that helped. I was running Nod32. I uninstalled it through progs & features in the control pannel, rebooted the machine and then went to install it. got nearly to the end (installing drivers) and then the ESS rolls back. I don't get any specific error messages the installer just tells me that it encountered an error and the program didnt install. I have tried reinstalling NOD32 and uninstalling NOD32 using its own uninstaller, I've tried disconnecting from the internet, turning off Windows firewall and Defender, I've tried it with UAC on and off. I've tried it with the built in Administrator account and my account with admin. privileges. Any ideas?? Are there any logfiles that ESS dumps?

    My specs are as follows:
    Core Duo 1.6
    1GB ram
    Windows Vista Ultimate 32bit

    Cheers!
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Please run the installation package as follows and send the log created along with a link to this thread to support[at]eset.com:
    ess_nt32_enu.msi /lvx* install.log
     
  3. mmac

    mmac Registered Member

    Joined:
    Apr 27, 2007
    Posts:
    7
    Ok, did that yesterday. Any news on what the problem could be?
     
  4. pcaca

    pcaca Registered Member

    Joined:
    Sep 11, 2005
    Posts:
    62
    I have the same problem on Vista Enterprise 32-bit. When the process comes to "Installing Drivers" it rollbacks. I tried everything, installing with UAC thurned off/on, playing with file permisions, closing every program in tray, disabling windows FW etc.

    Maybe this info could help:
    I disabled Windows Installer Rollaback in Windows Group Policy. ESS didn't rollback during the installation, it said that setup ended with error and system was not modified. But after restart ESS started and I got prompt to add new network to trusted zone, I pressed No and I got error that FW module can't start and it won't work. AV and Anti-Spam modules worked, but I couldn't update. Then I tried to install/reinstall all ESS drivers manualy from "C:\Program Files\Eset\Eset Smart Security\Drivers". All drivers installed without error except "epfwndis" for which I got message "The INF file you selected does not support this method of installation" after pressing Right Click->Install.

    I hope this helps ;)
     
  5. mmac

    mmac Registered Member

    Joined:
    Apr 27, 2007
    Posts:
    7
    Wow, didn't even think of that. I'll give that a try this weekend and see if I can produce similar results.

    As an aside, any idea what epfwndis does?
     
  6. pcaca

    pcaca Registered Member

    Joined:
    Sep 11, 2005
    Posts:
    62
    I wouldn't recommend disabling of Windows Installer Rollback. Acording to MS it can make your system unusable if installation fails.

    Quote from MS:
    epfwndis is miniport driver for ESS Firewall.

    I posted that to help ESET find the reason why ESS Install is failing on some Vista systems. That was NOT recommendation for users.

    Let's wait for ESET's sugestion ;)
     
  7. pcaca

    pcaca Registered Member

    Joined:
    Sep 11, 2005
    Posts:
    62
    I've managed to install epfwndis driver.

    When mmac asked me what is the purpose of epfwndis, it striked me when I saw that it is actually miniport driver, because I knew how miniport drviers should be installed through Network Connections panel. But even with epfwndis installed FW and Updates aren't working :(

    I hope ESET will fix this problem soon.

    EDIT: In the Event Log I found following entry:
    During that period 15:00-15:10 I was trying to install ESS, so maybe this is related with the problem.
     
    Last edited: May 3, 2007
  8. IcePanther

    IcePanther Registered Member

    Joined:
    May 28, 2005
    Posts:
    308
    Location:
    (nearby) Paris, France
    Hi,

    Just to share my experiece : This morning after I updated my graphic card's nVidia driver, ESS wouldn't install at all. I had to rollback the install and ESS installed with no problem. So, it's possible that a driver conflict that should absolutely not exist, in fact happens. So for all of you who have problems installing, double check and tryupdating/downgrading your drivers, it may help...
     
Thread Status:
Not open for further replies.