Ubuntu panel problem

Discussion in 'all things UNIX' started by cet, Apr 3, 2011.

Thread Status:
Not open for further replies.
  1. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    I love to install and use different themes.But whatever theme I install it does not matter I have to use the panel background system theme.If I want to use it transparent or use a solid color I get something like in the picture.Is there a way to solve this problem.
    For example I am using the new equinox evolution light theme,but I hate the light panel and I want to use a different background.This is what I get:
     

    Attached Files:

  2. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    You could try to make the panel transparent if it doesn't support transparency ..

    gedit ~/.themes/CetsTheme/gtk-2.0/gtkrc

    Scroll down to the panel’s style section and look for:
    bg_pixmap[NORMAL] = "panel_bg.png"

    Commented out that line by placing a # at the beginning of it.
    # bg_pixmap[NORMAL] = "panel_bg.png"

    Not sure if this is what you want.
     
  3. Cvette

    Cvette Registered Member

    Joined:
    Apr 16, 2010
    Posts:
    373
    Location:
    South Carolina, USA
    +1 for what Ocky said.

    On a side note, after awhile I became bored with the look of gnome-panel and switched over to AWN (avant-window-navigator), and started making my own themes for that. It's really nice if you're ever looking for a more flexible panel.
     
  4. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
  5. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    It does the same as per my post except the patch will apply to all panel backgrounds.** I am sure it is safe to install the patch.

    ** and not just the panel background that comes with a particular theme.
     
    Last edited: Apr 5, 2011
  6. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    Dark panel
    #=========================================================
    style "panel" = "newwave-default"
    {
    fg[NORMAL] = shade(0.97, @bg_color) #mix(0.70, lighter(@selected_bg_color), @bg_color)
    fg[PRELIGHT] =@text_color # lighter(mix(0.90, lighter(@selected_bg_color), @bg_color))
    #@autho:gp@ Improve consistency between metacity-frame and application active in taskbar.
    fg[ACTIVE] = @base_color # @text_color # lighter(mix(0.50, lighter(@selected_bg_color), @bg_color))

    # @author:dilomo@
    #dark color from v0.1 : "#4C4D4E"
    #dark color from v0.1.1 : "#424242"
    bg[NORMAL] = "#3a3a3a" #This is dark gray
    # @author:gp@ Same color as item selected of taskbar menu.
    bg[PRELIGHT] = shade ( 1.60, @bg_color) #shade(3.0, "#424242")
    #@autho:gp@ Improve consistency between metacity-frame and application active in taskbar.
    bg[ACTIVE] = shade(1.02, "#696969") #bg[ACTIVE] = shade(2.5, "#424242")
    #@autho:gp@ Improve consistency between active-menu-item and menu-background.
    bg[SELECTED] = "#989594" #bg[SELECTED] = shade(3.2, "#424242")

    bg_pixmap[NORMAL] = "Images/Panel/PanelBarLong.png"


    Is this the last line which I am going to put the # sign in front?

    }
     
  7. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    Yes, that looks like it. Comment out and then log out and in again in case it doesn't immediately take.
     
  8. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    I have changed the value but now I get it like this :(
     

    Attached Files:

  9. Cvette

    Cvette Registered Member

    Joined:
    Apr 16, 2010
    Posts:
    373
    Location:
    South Carolina, USA
    1) Press Alt + F2
    2) Type in gksu nautilus
    3) Navigate to File System - Usr - Share - Themes - (theme name) - gtk-2.0 - Apps - panel.rc

    On the line that says:
    bg_pixmap[NORMAL] = "/Panel/panel.png" # Disable for normal panel backgrounds

    Add a # so it will then look like:

    #bg_pixmap[NORMAL] = "/Panel/panel.png" # Disable for normal panel backgrounds.

    Save the file, then open a terminal and type in nautilus -q or logout.
     
    Last edited: Apr 5, 2011
  10. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    Thanks for all the help but I give up.Maybe the reason for this is I am using one theme for the window borders and another theme for the controls.
     
  11. Cvette

    Cvette Registered Member

    Joined:
    Apr 16, 2010
    Posts:
    373
    Location:
    South Carolina, USA
    Oh heck we don't have to give up now. Did you try those instructions that I posted?

    If you don't want to mess around with it anymore, you might want to look into AWN or Avant-Window-Navigator, it's a nice little dock that you can theme (including make transparent) and tweak to your liking.
     
  12. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    Strange, I have tried with New Wave Default, commented out as already said viz:
    #bg_pixmap[NORMAL] = "Images/Panel/PanelBarLong.png"
    The result is a transparent panel. Usually you have to logout. Then r/click on the panel and select solid colour - now you can adjust the degree of tranparency.

    This is New Wave Default panel after #bg_pixmap[NORMAL] = "Images/Panel/PanelBarLong.png"

    Panel.png
     
  13. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    Yay,I did it.The problem was this:I am using the new wave theme but at the same time using the shiki-brave for the controls.So I put the # in front of the line in the shiki-brave panel section.Before I was trying to modify the new wave theme. :) Thank you all.
     

    Attached Files:

Loading...
Thread Status:
Not open for further replies.