µBlock, a lean and fast blocker

Discussion in 'other software & services' started by gorhill, Jun 23, 2014.

  1. accessgranted

    accessgranted Registered Member

    Joined:
    Mar 10, 2010
    Posts:
    205
    Disabled all extensions except for uBO and tried again. Seems to update third-party quite right. I nevertheless noticed that my uBO is blocked at uBlock Origin v1.13.4, despite my regularly updating extensions. What could cause my version to not even notice 1.14.* ? Anything to do with about:config tweaks I might have done in the past and relating to extensions signatures or some? FF 54.0.1 BTW
     
    Last edited: Sep 10, 2017
  2. accessgranted

    accessgranted Registered Member

    Joined:
    Mar 10, 2010
    Posts:
    205
    Mmmmmhh... Looks like uMatrix is interfering with uBO updating and uBO 3rd party updating. My uMatrix version is 1.0.0. What is it supposed to be at?
    EDIT: I just installed uMatrix 1.0.1 rc1. uBlockO updates fine, 3rd party too, but uMatrix' hosts files are not updating.
     
    Last edited: Sep 10, 2017
  3. gorhill

    gorhill Developer

    Joined:
    Nov 12, 2013
    Posts:
    843
    Location:
    Canada
    The first thing to look at for such issue is the logger (both uMatrix/uBO).
     
  4. accessgranted

    accessgranted Registered Member

    Joined:
    Mar 10, 2010
    Posts:
    205
    Hi gorhill,

    uBlockO logger returns a completely blank page when trying and update uMatrix Dashboard.

    The uMatrix logger returns this:
    16:26:46 Network error: Unable to connect to {{url}}
    16:26:46 xhr https://pgl.yoyo.org/adservers/serverlist.php?hostformat=hosts&showintro=1&mimetype=plaintext
    16:26:44 xhr http://winhelp2002.mvps.org/hosts.txt
    16:26:42 Network error: Unable to connect to {{url}}
    16:26:42 xhr https://hosts-file.net/.\ad_servers.txt
    16:26:40 xhr http://someonewhocares.org/hosts/hosts
    16:26:38 Network error: Unable to connect to {{url}}
    16:26:38 xhr https://www.malwaredomainlist.com/hostslist/hosts.txt
     
    Last edited: Sep 10, 2017
  5. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    7,416
    Location:
    Among the gum trees
    So I'm the only one who has seen this?

    In Firefox + Cyberfox I use the default home page. In Edge I use Bing, although
    the default search engine is Google. I just like the picture.

    Every Google search lately has had this pop up.
     
  6. stackz

    stackz Registered Member

    Joined:
    Dec 27, 2007
    Posts:
    635
    Location:
    Sydney Australia
    Use Adguard Annoyances filter - http://filters.adtidy.org/extension/ublock/filters/14.txt
     
    Last edited: Sep 11, 2017
  7. summerheat

    summerheat Registered Member

    Joined:
    May 16, 2015
    Posts:
    1,783
    The question is: Are those XHR requests in red or in black? If they are red you have to click the respective cell in the second column (on the right of the time column). The matrix will open within the logger, and you'll have to allow those XHR requests and save the rules with the padlock.

    EDIT: Btw, you can disable yoyo (Peter Lowe's), MVPS, someonewhocares (Dan Pollock) and Malware Domain List and add one of Steven Black's hosts files instead as all of them (and more) are integrated therein.
     
    Last edited: Sep 11, 2017
  8. topo

    topo Registered Member

    Joined:
    Nov 11, 2013
    Posts:
    133
    after reading some recent posts, i'm confused. i have win764bit and win1064bit, both using ff55.0.3(32bit) with UBO 1.13.8 as only extension(default settings) and have turned off auto update for ubo. do i need to wait until ff57 to turn ubo auto update back on? thanks for your advice.
     
  9. mood

    mood Updates Team

    Joined:
    Oct 27, 2012
    Posts:
    24,072
    Until FF56 :doubt:
     
  10. topo

    topo Registered Member

    Joined:
    Nov 11, 2013
    Posts:
    133
    mood, thanks for your reply will wait for ff56
     
  11. Robin A.

    Robin A. Registered Member

    Joined:
    Feb 25, 2006
    Posts:
    2,546
    I have not been following this thread in detail, but I´m using 1.14.4 with auto-update and default configuration, in FF 53.0.3 64 bits. Haven´t noticed any problem.
     
  12. mrpink

    mrpink Registered Member

    Joined:
    Mar 29, 2010
    Posts:
    379
    Hello! With Youtube's new design i get blanc spaces and white boxes at the top right corner. Is there a solution? I have Chrome60
     
  13. clubhouse1

    clubhouse1 Registered Member

    Joined:
    Sep 26, 2013
    Posts:
    1,124
    Location:
    UK
    I'm back to 1.13.4, the new versions are causing me loading problems such as using google I'm finding the links aren't loading I have to press the browser back button and reload. Or navigating away from a site via bookmarks, same thing not loading back button and reload.
     
  14. Rasheed187

    Rasheed187 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    12,397
    Location:
    The Netherlands
    Anyone? I'm just trying to figure out if they are using some kind of method to bypass ad-blockers. But the ads are non-animated so it's cool with me.
     

    Attached Files:

  15. hawki

    hawki Registered Member

    Joined:
    Dec 17, 2008
    Posts:
    4,494
    Location:
    DC Metro Area
    Nope. Not Me.
     
  16. Nitty Kutchie

    Nitty Kutchie Registered Member

    Joined:
    Apr 10, 2015
    Posts:
    139
    +:thumb:
     
  17. Rasheed187

    Rasheed187 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    12,397
    Location:
    The Netherlands
    Thanks guys, then perhaps there might be something wrong. I sometimes see them, and sometimes I don't.
     
  18. KeyPer4Life

    KeyPer4Life Registered Member

    Joined:
    Dec 18, 2013
    Posts:
    1,184
    UBO.PNG
    What (about:config) setting(s) control UBO GUI? The large icon (enable/disable) isn't showing
    properly. Also the smaller icons above requests blocked & below domains connected are
    not showing properly. When I create a default profile in Pale Moon all GUI icons display
    properly so it must be an about:config preference setting(s) I changed from the default.
     
  19. KeyPer4Life

    KeyPer4Life Registered Member

    Joined:
    Dec 18, 2013
    Posts:
    1,184
    The about:config preference (gfx.downloadable_fonts.enabled) needs to be set to true (default)
    for UBO GUI to display properly. Problem solved.
     
  20. Soujirou

    Soujirou Registered Member

    Joined:
    Mar 25, 2008
    Posts:
    63
    Does anyone use Patreon with UBO? The only method I've found that to pledge some money is to disable UBO. I'm hoping there is a smarter way. Ideally I'd like to use the Paypal option.
     
  21. Sampei Nihira

    Sampei Nihira Registered Member

    Joined:
    Apr 7, 2013
    Posts:
    1,601
    Location:
    Italy
    Hi.
    Is it recommended to add the custom "NoCoin list"?


    Immagine.jpg
     
  22. Brummelchen

    Brummelchen Registered Member

    Joined:
    Jan 3, 2009
    Posts:
    3,120
  23. Overkill

    Overkill Registered Member

    Joined:
    Mar 16, 2012
    Posts:
    2,312
    Location:
    USA
  24. Brummelchen

    Brummelchen Registered Member

    Joined:
    Jan 3, 2009
    Posts:
    3,120
    read Sampei again
     
  25. Sampei Nihira

    Sampei Nihira Registered Member

    Joined:
    Apr 7, 2013
    Posts:
    1,601
    Location:
    Italy
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.