µBlock, a lean and fast blocker

Discussion in 'other software & services' started by gorhill, Jun 23, 2014.

  1. gorhill

    gorhill Developer

    Joined:
    Nov 12, 2013
    Posts:
    836
    Location:
    Canada
    Try to toggle cosmetic filtering when such issues occur, it's often because of some cosmetic filter in some list. Cosmetic filtering switch: https://github.com/gorhill/uBlock/wiki/Per-site-switches#no-cosmetic-filtering

    If you see that toggling off cosmetic filtering fixes your issue, use the logger to identify which cosmetic filter is causing the issue. Clicking on the filter will show you from which filter list it comes from. The logger: https://github.com/gorhill/uBlock/wiki/The-logger
     
  2. Rasheed187

    Rasheed187 Registered Member

    Joined:
    Jul 10, 2004
    Posts:
    11,965
    Location:
    The Netherlands
    Thanks for the info. But actually, it seems that it was caused by one of my own filters, I thought I had already checked this out, but apparently I didn't do it correctly. So my apologies to everyone.
     
  3. clubhouse1

    clubhouse1 Registered Member

    Joined:
    Sep 26, 2013
    Posts:
    1,123
    Location:
    UK
  4. Nanobot

    Nanobot Registered Member

    Joined:
    Jun 23, 2010
    Posts:
    388
    Location:
    Neo Tokyo
    Block concernrain dot com request
     
  5. clubhouse1

    clubhouse1 Registered Member

    Joined:
    Sep 26, 2013
    Posts:
    1,123
    Location:
    UK

    That did the trick, thanks :)
     
  6. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    6,997
    Location:
    Among the gum trees
    Anyone using uBO in Edge? First time I've tried it in months and I've already had it stop working on me once. Well, the counter stopped showing the number blocked anyway.
     
  7. deugniet

    deugniet Registered Member

    Joined:
    Nov 25, 2013
    Posts:
    787
    Using it now and then.

    For issues: https://github.com/nikrolls/uBlock-Edge
     
  8. Krusty

    Krusty Registered Member

    Joined:
    Feb 3, 2012
    Posts:
    6,997
    Location:
    Among the gum trees
    You're right of course but I'm not interested in joining yet another forum.

    I know it is still pre-release but it has stopped working completely on another machine now. Closing Edge and reopening it sometimes gets it working again.

    ABP just works. I'll stick with it in Edge for now.
     
  9. Sampei Nihira

    Sampei Nihira Registered Member

    Joined:
    Apr 7, 2013
    Posts:
    1,528
    Location:
    Italy
    For those who want to make a test.
    You need to view the video:


    http://www.nowvideo.ec/video/fc02e34716301
     
    Last edited: Jan 29, 2017
  10. gorhill

    gorhill Developer

    Joined:
    Nov 12, 2013
    Posts:
    836
    Location:
    Canada
    Code:
    *$websocket,domain=nowvideo.ec
    Why not just report to filter list maintainers?
     
    Last edited: Jan 29, 2017
  11. Sampei Nihira

    Sampei Nihira Registered Member

    Joined:
    Apr 7, 2013
    Posts:
    1,528
    Location:
    Italy
    Long time for the start of the film................
     
  12. Nanobot

    Nanobot Registered Member

    Joined:
    Jun 23, 2010
    Posts:
    388
    Location:
    Neo Tokyo
    I have a similar issue (unblock theguardian.com comment section) as this guy, can anyone help?

    Chrome/ uBlock Origin + uBlock Origin Extra/Win10

    Settings/3rd-party-filters

    https://www.reddit.com/r/uBlockOrigin/comments/5rzhsd/allowing_the_guardians_comments_section/
     
    Last edited: Feb 4, 2017
  13. harsha_mic

    harsha_mic Registered Member

    Joined:
    Mar 11, 2009
    Posts:
    815
    Location:
    India
    Can you post the blocked requests from logger..
     
  14. Nanobot

    Nanobot Registered Member

    Joined:
    Jun 23, 2010
    Posts:
    388
    Location:
    Neo Tokyo


    theguardian.PNG
     
  15. wat0114

    wat0114 Registered Member

    Joined:
    Aug 5, 2012
    Posts:
    2,520
    Location:
    Canada
    With my settings using uBlockO and umatrix, the additional content I needed to allow to render the comments, including the blacklisted j.ophan.co.uk domain.

    Untitled-2.png
     
  16. harsha_mic

    harsha_mic Registered Member

    Joined:
    Mar 11, 2009
    Posts:
    815
    Location:
    India
    As @wat0114 said, unblocking script from j.ophan.co.uk domain should resolve the issue.

    Code:
    @@||j.ophan.co.uk/ophan.ng.js$script,domain=www.theguardian.com
     
    Last edited: Feb 5, 2017
  17. ArchiveX

    ArchiveX Registered Member

    Joined:
    Apr 7, 2014
    Posts:
    1,432
    Location:
    Land of the Light
    This a legitimate News Broadcasting site
    http://webtv.ert.gr/katigories/eidiseis/27ian2017-politistiko-deltio/

    With Adblock Plus, a friend clicked on Open blockable items
    1.jpg
    In the opened Search box, typed manifest and found the file
    http://ep.ert.gr:1935/vodedge/_defi...VILMGR&hdcore=3.10.0&plugin=jwplayer-3.10.0.0
    2.jpg

    which was able to copy
    3.jpg

    -How can I find the same manifest file (http://ep.ert.gr:1935/vodedge/_defi...VILMGR&hdcore=3.10.0&plugin=jwplayer-3.10.0.0) with uBlock Origin?

    OR do I have to use uMatrix?
     
    Last edited: Feb 5, 2017
  18. harsha_mic

    harsha_mic Registered Member

    Joined:
    Mar 11, 2009
    Posts:
    815
    Location:
    India
  19. ArchiveX

    ArchiveX Registered Member

    Joined:
    Apr 7, 2014
    Posts:
    1,432
    Location:
    Land of the Light
    I also couldn't find the respective file in the uBlock Origin Log , too. :thumb:

    However, my friend found it with Adblock Plus :eek:

    Maybe, a uBlock Origin expert, here, can en-light us...
     
  20. harsha_mic

    harsha_mic Registered Member

    Joined:
    Mar 11, 2009
    Posts:
    815
    Location:
    India
    it is best to test both abp and ubO on the same machine. only 1 active at a time though ;)

    Edit: Disabling my medium blocking mode, allowed the request to be fired by the site, and it eventually got blocked with my filter lists present. Bottom line, configure the both the extensions the same way, you will see the same results..
     

    Attached Files:

    Last edited: Feb 5, 2017
  21. wat0114

    wat0114 Registered Member

    Joined:
    Aug 5, 2012
    Posts:
    2,520
    Location:
    Canada
    Not an expert, but there are several files in uBlockO's logs with extension "swf". The individual would have to know they are shockwave flash player files. The other clue is the numerous jwplayer entries.

    Code:
    1 /ping.gif? -- image http://jwpltx.com/v1/jwplayer6/ping.gif?h=-1160034940&tv=2.8.6&n=1875049342032997&aid=%2BjLGdLmfEeK2FxIxOQulpA&e=e&i=1&ifd=1&pv=7.8.7&d=0&c=0&pli=&emi=z3iqnv4bxwko&pid=&pl=497&wd=884&ps=4&pp=flash&ph=0&ed=3&ab=1&vp=1&po=0&dd=1&fv=11.2&pd=0&pad=&sn=seven&ga=0&cb=0&r=0&s=0&hls=&cp=0&st=1641&rf=&sdk=0&vrt=&mt=0&vl=90&id=&vi=0.603&ap=269%2C80&at=0&ccp=0&eb=0&mu=http%3A%2F%2Fep.ert.gr%3A1935%2Fvodedge%2F_definst_%2Fmp4%3Advrorigin%2F2017%2Ftv%2Fpolitistiko-deltio%2F20170127-politistiko-deltio.mp4%2Fmanifest.f4m&pu=http%3A%2F%2Fwebtv.ert.gr%2Fkatigories%2Feidiseis%2F27ian2017-politistiko-deltio%2F&t=&m=1&pt=27%CE%99%CE%B1%CE%BD2017%20%E2%80%93%20%CE%A0%CE%BF%CE%BB%CE%B9%CF%84%CE%B9%CF%83%CF%84%CE%B9%CE%BA%CF%8C%20%CE%94%CE%B5%CE%BB%CF%84%CE%AF%CE%BF%20%7C%20%CE%95%CE%A1%CE%A4%20WebTV
    13:05:17 object http://ssl.p.jwpcdn.com/player/v/7.8.7/vast.swf
    13:05:17 object http://ssl.p.jwpcdn.com/crossdomain.xml
    13:05:16 object http://player.pstatic.gr/jw7/jwplayer.flash.swf
    13:05:16 script http://ssl.p.jwpcdn.com/player/v/7.8.7/polyfills.vttrenderer.js
    13:05:16 script http://ssl.p.jwpcdn.com/player/v/7.8.7/provider.flash.js
    13:05:15 ||entitlements.jwplayer.com^$third-party -- xhr http://entitlements.jwplayer.com/+jLGdLmfEeK2FxIxOQulpA.json
    13:05:15 script http://ssl.p.jwpcdn.com/player/v/7.8.7/related.js
    13:05:15 script http://ssl.p.jwpcdn.com/player/v/7.8.7/jwpsrv.js
    13:05:15 script http://ssl.p.jwpcdn.com/player/v/7.8.7/vast.js
    13:05:15 object http://player.pstatic.gr/jw7/jwplayer.loader.swf
     
  22. Nanobot

    Nanobot Registered Member

    Joined:
    Jun 23, 2010
    Posts:
    388
    Location:
    Neo Tokyo

    Excellent. this solved the issue and the comment section loads normally now, thanks alot @harsha_mic & @wat0114
     
    Last edited: Feb 5, 2017
  23. gorhill

    gorhill Developer

    Joined:
    Nov 12, 2013
    Posts:
    836
    Location:
    Canada
    That file is pulled if using the Flash-based player. Not used if using the HTML5 player.
    a.png
     
  24. gorhill

    gorhill Developer

    Joined:
    Nov 12, 2013
    Posts:
    836
    Location:
    Canada
    I do not have instances of "j.ophan.co.uk" on my side, and no issue with the comments no showing. You should report the issue to EasyPrivacy maintainers (I am assuming this is the list from which the filter comes from).

    Edit: strike that, I can't find that filter in EasyPrivacy or EasyList. Best is that you find first which filter list contains that filter, click on the filter in the logger.
     
    Last edited: Feb 5, 2017
  25. wat0114

    wat0114 Registered Member

    Joined:
    Aug 5, 2012
    Posts:
    2,520
    Location:
    Canada
    Hi gorhill,

    I found it under the hpHost's file, as well as: ophan.guardian.co.uk and ophan.theguardian.com
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.