trying to connect xbox 360 > windows 7 media centre

Discussion in 'ESET Smart Security' started by Zoopy, Nov 20, 2010.

Thread Status:
Not open for further replies.
  1. Zoopy

    Zoopy Registered Member

    Joined:
    Nov 20, 2010
    Posts:
    5
    Hi

    I'm at the stage of pulling my hair out with this problem!

    It does not matter if ESS is set to automatic mode or interactive mode ESS keeps blocking data to or from (or both) so the xbox can not connect

    Ive ticked all the boxes in the IDS and unticked the UPNP in the zones but no popup is coming (in interactive mode) to block or allow the communication.

    the logs are as follows (examples but the log is flooded by these)

    Code:
    20/11/2010 19:39:57	Communication denied by rule	192.168.1.64:55261	239.255.255.250:1900	UDP	Block outgoing SSDP (UPNP) requests
    Code:
    20/11/2010 19:42:52	No usable rule found	192.168.1.254:8000	192.168.1.64:49375	TCP
    Code:
    20/11/2010 19:43:33	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System		
    Code:
    20/11/2010 19:41:26	Packet blocked by active defense (IDS)	192.168.1.64:49351	74.125.4.85:80	TCP	
    I wouldnt be so angry with myself if I had a problem like this is XP but it seemed just to work lol

    Thanks for any help

    **edit**

    Forgot to say if I disable the firewall, connection is made without a hitch
     
    Last edited: Nov 20, 2010
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    1. switch to learning mode
    2. make sure the Xbox IP address is in the Trusted zone
    3. make sure that the "Enable UPnP in the Trusted zone" option is enabled in the IDS setup
     
  3. Zoopy

    Zoopy Registered Member

    Joined:
    Nov 20, 2010
    Posts:
    5
    switched to learning mode, restarted computer

    xbox IP is in the trusted zone

    UPnP is enabled

    Still no joy
     
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    What's logged now in the firewall log?
     
  5. Zoopy

    Zoopy Registered Member

    Joined:
    Nov 20, 2010
    Posts:
    5
    top few (the rest are the same really)

    Code:
    20/11/2010 21:00:40	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    20/11/2010 21:00:40	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    20/11/2010 21:00:39	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    20/11/2010 21:00:39	Packet blocked by active defense (IDS)	192.168.1.64:49518	94.127.74.60:80	TCP			
    20/11/2010 21:00:39	Packet blocked by active defense (IDS)	192.168.1.64:49511	213.120.161.209:80	TCP			
    20/11/2010 21:00:28	No usable rule found	66.220.151.72:80	192.168.1.64:49535	TCP			
    20/11/2010 21:00:03	No usable rule found	192.168.1.254:8000	192.168.1.64:49521	TCP			
    20/11/2010 21:00:03	No usable rule found	192.168.1.254:8000	192.168.1.64:49520	TCP			
    20/11/2010 20:59:18	No usable rule found	192.168.1.254:8000	192.168.1.64:49517	TCP			
    20/11/2010 20:59:17	No usable rule found	192.168.1.254:8000	192.168.1.64:49516	TCP			
    Dont understand the IDS ones though since its allowed *shrugs*
     
  6. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Does creating a rule allowing bi-directional communication via IGMP with the IP address of Xbox as the remote address make a difference? Remember that rules are applied in all modes except automatic mode.
     
  7. Zoopy

    Zoopy Registered Member

    Joined:
    Nov 20, 2010
    Posts:
    5
    That sorted it :)

    Is there any reason why I shoudnt leave this like this?

    **edit** ok maybe not, connected once but now refusing again
     
  8. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    After making each of the changes suggested here, always post the latest records from the firewall log that are related to the problem.
     
  9. Zoopy

    Zoopy Registered Member

    Joined:
    Nov 20, 2010
    Posts:
    5
    I would IF there is a change in the logs, but there is not

    Code:
    21/11/2010 13:00:16	No usable rule found	192.168.1.254:8000	192.168.1.64:53999	TCP			
    21/11/2010 13:00:16	No usable rule found	192.168.1.254:8000	192.168.1.64:53998	TCP			
    21/11/2010 13:00:15	No usable rule found	192.168.1.254:8000	192.168.1.64:53997	TCP			
    21/11/2010 12:59:42	No usable rule found	192.168.1.254:8000	192.168.1.64:53996	TCP			
    21/11/2010 12:59:42	No usable rule found	192.168.1.254:8000	192.168.1.64:53995	TCP			
    21/11/2010 12:59:31	No usable rule found	65.175.38.194:80	192.168.1.64:53993	TCP			
    21/11/2010 12:59:07	No usable rule found	192.168.1.254:8000	192.168.1.64:53990	TCP			
    21/11/2010 12:59:06	No usable rule found	192.168.1.254:8000	192.168.1.64:53989	TCP			
    21/11/2010 12:59:05	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    21/11/2010 12:59:00	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    21/11/2010 12:58:56	No usable rule found	192.168.1.64	224.0.0.22	IGMP		System	
    21/11/2010 12:58:33	No usable rule found	192.168.1.254:8000	192.168.1.64:53987	TCP			
    21/11/2010 12:58:32	No usable rule found	192.168.1.254:8000	192.168.1.64:53985	TCP			
    21/11/2010 12:57:56	No usable rule found	192.168.1.254:8000	192.168.1.64:53984	TCP			
    21/11/2010 12:57:56	No usable rule found	192.168.1.254:8000	192.168.1.64:53983	TCP			
    21/11/2010 12:57:56	Packet blocked by active defense (IDS)	137.254.16.66:80	192.168.1.64:53929	TCP
    Left the computer running overnight on learning mode and in the log its this (xbox was switched off though o_O )
     
Thread Status:
Not open for further replies.