TrueImage Linux Agent Install error on SLES9

Discussion in 'Acronis True Image Product Line' started by MikeMiller, Dec 11, 2006.

Thread Status:
Not open for further replies.
  1. MikeMiller

    MikeMiller Registered Member

    Joined:
    Dec 11, 2006
    Posts:
    1
    We're currently evaluating TrueImage Enterprise for our office. When attempting to install the Linux Agent I receive the following error message:

    Acronis True Image Enterprise Server Setup failed to build kernel moduels. Consult /var/log/trueimage-setup.log and /var/lib/dkms/snapapi26/0.7.9/build/make.log for error messages.

    Below is a cut+paste from the make.log. I elected to attach the setup.log as I assume it's not as useful and it's pretty long :)

    > cat /var/lib/dkms/snapapi26/0.7.9/build/make.log
    DKMS make.log for snapapi26-0.7.9 for kernel 2.6.5-7.97-default (i586)
    Mon Dec 11 13:56:01 EST 2006
    make: Entering directory `/usr/src/linux-2.6.5-7.97-obj/i386/default'
    make -C /usr/src/linux-2.6.5-7.97 O=/usr/src/linux-2.6.5-7.97-obj/i386/default modules

    WARNING: Symbol version dump /usr/src/linux-2.6.5-7.97-obj/i386/default/Module.symvers is missing, modules will have CONFIG_MODVERSIONS disabled.

    find: /linux: No such file or directory
    CC [M] /var/lib/dkms/snapapi26/0.7.9/build/snapapi26.o
    /var/lib/dkms/snapapi26/0.7.9/build/snapapi26.c: In function `do_init_session':
    /var/lib/dkms/snapapi26/0.7.9/build/snapapi26.c:1970: error: structure has no member named `max_hw_sectors'
    make[3]: *** [/var/lib/dkms/snapapi26/0.7.9/build/snapapi26.o] Error 1
    make[2]: *** [_module_/var/lib/dkms/snapapi26/0.7.9/build] Error 2
    make[1]: *** [modules] Error 2
    make: *** [modules] Error 2
    make: Leaving directory `/usr/src/linux-2.6.5-7.97-obj/i386/default'
     

    Attached Files:

  2. ehall

    ehall Registered Member

    Joined:
    Nov 1, 2006
    Posts:
    8
    SUSE 9.x doesn't have symbols defined by default, so you need to create them first. Easiest way is to do the following:

    cd /usr/src/linux/
    make cloneconfig
    make prepare-all

    The first "make" will copy all of your current kernel settings, and the second one will generate the symbols needed to build a new kernel (but won't actually build it).

    You'll run into this a lot with SUSE 9.x and third-party tools.
     
  3. skolaut

    skolaut Registered Member

    Joined:
    Mar 16, 2007
    Posts:
    1
    If have performed the statements above, but the error still occurs. What libraries and packages do I need?

    Kind regards
    Helmut
     
  4. barfly4711

    barfly4711 Registered Member

    Joined:
    Jun 1, 2007
    Posts:
    1
    We're also testing the Linuxagent on SuSE 9.2 (64 bit Kernel). We've got exactly the same problems and exactly the same error message.

    I tried:

    cd /usr/src/linux/
    make cloneconfig
    make prepare-all

    .....no success

    On SusE 10 (32bit), ist works fine.

    Any ideas?
     
Thread Status:
Not open for further replies.