Truecrypt Container 0kb after chkdsk

Discussion in 'encryption problems' started by eggbreaker, Jun 15, 2016.

  1. eggbreaker

    eggbreaker Registered Member

    Jun 15, 2016
    Hello guys,

    I've been dual-booting Linux and Windows for 2 years or so. I recently resized a partition (NTFS) on Linux. That partition had a TrueCrypt-Container file. Everything worked fine on Linux and the Container still worked ... until I booted to Windows and chkdsk ran. The ~280GB container became 0KB.

    The only thing I want to know is: Could chkdsk have corrupted or deleted the header? I have looked at the current 0kb-file in WinHex and it seems to be in a very different location based on the surrounding data (since it is readable data and not random).

    If the header is still okay I should be able to find the header (hopefully) since I know the password and left every setting at default.

    If I exclude all sector-ranges of normal files (recognized by windows) on the partition and also sector-ranges from deleted files determined with recovery software, then I should be able to narrow it down a little bit.

    Thanks for your help.