The 2.06 Beta 1 version is available.

Discussion in 'LnS English Forum' started by Frederic, Feb 16, 2007.

Thread Status:
Not open for further replies.
  1. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi ^Ale,

    Send me A Private Message with your email or your order ID and I will give you the serial based on your email address.

    Frederic
     
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi General Noel,

    Some problem may still happen with the service mode.

    If this second user logs on directly and alone, does Look 'n' Stop starts ?
    If it does not, this has to be fixed first.

    Frederic
     
  3. General Noel

    General Noel Registered Member

    Joined:
    May 3, 2005
    Posts:
    68
    Well, the 1st User logs into a windows session and start LnS in the task bar, then with the FSU feature, I log into another windows session (leaving the 1st session opened as expected for the FSU feature).

    Now in this case the second windows session doesn't get the LnS icone in the task bar, although it looks like LnS is still running as it prevent unauthorized application to be launched in the second windows user session.

    If I then swapp back to the 1st windows session (leaving the 2nd windows session active), I can then see a popup warning that an unauthorized application is trying to get access to the internet.

    To summarize, the FSU feature with LnS 2.06b1, it looks like LnS works properly as a service however one cannot manages LnS on a second windows session with LnS.

    Now this is not really a big deal if this isn't addressed in the future as I believe that only few people will ever use the windows FSU feature, however I wanted to "push the test" further with this new beta release.
     
  4. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,721
    Location:
    Canada
    In Look 'n' Stop Service Properties, visit 'Log On', activate 'Allow service to interact with desktop' and run your test :)
     
  5. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi General Noel,

    What I wanted to know, is if you start the first session with the other user the same problem appears.
    In other words: if you have two users A and B.

    First Test:
    1-A logs First => Look 'n' Stop OK
    2-FUS on B => Look 'n' Stop not displayed
    3-FUS on A => Ok Look 'n' Stop still enabled

    Second test:
    reboot
    1-B logs First => Does it work ?
    2-FUS on A => what happens ?
    3-FUS on B = ?

    Also the console windows gives some information about the session change, it would be interesting to open it and see what is displayed after step 3-.

    Yes, since the service mode is not working under Vista as it is right now, not sure I will spend too much time on the interaction between FUS & Service mode, as it would need to be implemented in a different way :doubt:

    Frederic
     
  6. General Noel

    General Noel Registered Member

    Joined:
    May 3, 2005
    Posts:
    68
    Hi Frederic,

    Thank you for spending time on this matter.

    I tried Phant0m's tip - which is to set Look n Stop Service with the box activate 'Allow service to interact with desktop' ticked- with no better result. (Thank you Phant0m for your help ;) )


    Now I tried the second test and the results are the following :

    1-B logs First => Look 'n' Stop Icon appears in the task bar
    2-FUS on A => Look 'n' Stop Icon do NOT appear on the task bar (however in the Task manager I can still see looknstop.exe and LnSSvc.exe process executed by the SYSTEM)
    3-FUS on B => Look 'n' Stop Icon appears again in the task bar

    If I try to lauch on Step 2 the LnS program (through the Windows Start > Programs menu ), I can finally get the LnS interface and the LnS in the windows task bar, however this open another looknstop.exe program ran by the FUS A user login of the 2nd test (not the SYSTEM).

    Another remark is that I ran LnS Console on Step 1 and looked if it was logged any information once getting back to Step 3 of the test, but there was no indication of any information in the log at all of Step 2 FUS.


    To summarize, all the tests, the First Test and the Second Test give the same result.
    LnS works in the background as a Service with looknstop.exe and LnSSvc.exe process owned by the SYSTEM. But it is not possible to "see" LnS Icon in the windows taskbar with FUS when swiching to a second Windows User (Step 2 of the 1st and 2nd test).

    Note: This doesn't mean that LnS is not active as User A and B use the same LAN. The only way to "see" LnS is to launch LnS again.

    If anybody has any other idea on this matter I am ready to take it. But for now I don't think this is worth investigating any longer as FUS is not a windows feature widely used, and I believe that there are probably more important issue to consider with LnS 2.06b1 :eek:

    PS: I still like very much LnS and appreciate your involvement Frederic and your advice on LnS :thumb:
     
  7. Thomas M

    Thomas M Registered Member

    Joined:
    Jan 12, 2003
    Posts:
    355
    Until LnS 2.06 it was not possible for me to
    1.) log on user 1
    2.) log off user 1
    3.) log on user 2

    without loosing the LnS icon in the system tray.

    By using LnS 2.06 the procedure above (so far) produced always the LNS icon in the tray! That means now I can at least log off, log on without loosing the protection from LNS.

    For me this is very important, since I am always logging on first as Admin to update several security programs before I log off and re-login as a limited user for dayly work. In this regard the new LnS 2.06 is doing it's job just perfect :)

    Thomas :)

    (WinXP-SP2 and LnS 2.06beta1)
     
  8. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi Thomas,

    Yes, there is a specific change regarding this problem:

    When Look 'n' Stop is started in service mode, if the user log off, Look 'n' Stop is no longer stopped (and restarted).

    (from the change log).

    The previous design was actually linked to an MFC issue described here:
    http://support.microsoft.com/kb/164166/en-us


    Frederic
     
  9. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi General Noel,

    Thanks for the test and your report.

    I just would like to know if the problem is reproduced with and without starting Look 'n' Stop in service mode ? (and nothing in the console when you come back to the initial user).

    With the 2.05p3, the handling of FUS was disabled when Look 'n' Stop is started in service mode.
    But now with the 2.06b1 and because of the change just above, this restriction was removed and handling of FUS is normally there, and you should have at least some messages in the Console Windows.

    Frederic
     
  10. General Noel

    General Noel Registered Member

    Joined:
    May 3, 2005
    Posts:
    68
    Hi Frederic,

    I only ran the test with Look 'n' Stop in Service mode only. I see all the other startup option as "not really interresting" as I want LnS to be running before login into any Windows session.
    I can eventually try again and see if the LnS Console window log anything once using FUS with another windows session and swapping back to the first windows session opened.

    Now I have a more general question to whoever read this post : Has anybody else tested LnS 2.06b1 with FUS ?

    Kind Regards

    Gen. Noel
     
  11. General Noel

    General Noel Registered Member

    Joined:
    May 3, 2005
    Posts:
    68
    All right, I tried again the FUS feature with the LnS console mode activated.

    The Look n Stop Service is running with the box activate 'Allow service to interact with desktop' selected.

    Here is what I can see from the LnS Console log when opening windows session 1, then with FUS opening a 2nd windows session, and finally switch back to session 1 :


    Look 'n' Stop Version 2.06 Beta 01

    Driver versions: 5.01 & 4.01
    API Driver versions: 6.01 & 5.01
    Service Mode.
    [23:31:11] Firewall Internet Actif
    [23:31:11] Firewall Appli Actif
    [23:31:15] Ordinateur non connecté à Internet.
    [23:31:15] Watch Failed
    [23:31:19] Security Center registration Ok.
    [23:31:49] Adapter modified
    [23:31:49] Ordinateur connecté à Internet sur: 192.168.0.102.
    [23:32:13] 1 message Downlink
    [23:32:44] 1 message Downlink
    [23:33:58] Adapter modified <<< ---- FUS from window Session 1 to Session 2
    [23:33:58] Ordinateur connecté à Internet sur: 192.168.0.102.
    [23:33:59] 1 message Downlink
    [23:33:59] 1 message Uplink
    [23:33:59] 3 messages Uplink
    [23:34:10] 1 message Uplink
    [23:34:10] 3 messages Uplink
    [23:34:13] 1 message Downlink
    [23:34:15] 1 message Uplink
    [23:34:15] 1 message Uplink
    [23:34:18] 1 message Uplink
    [23:34:19] 1 message Uplink
    [23:34:19] 3 messages Uplink
     
  12. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi General Noel,

    I tested again also, and I had the same result :(

    Actually when Look 'n' Stop is started as a service, it is not attached to the session of the first user (even if the display goes to the desktop of this user). And thus the session change events of that user are not received.

    The good thing is anyway the protection is still there and the service instance is doing properly its job.
    The bad thing is new popup alerts are not seen for the second user that was logged through FUS.

    I don't know if there is a way to have the GUI of one application following the desktop of the current user. I've searched for that some time ago, but it was not fruitful.

    Frederic
     
  13. General Noel

    General Noel Registered Member

    Joined:
    May 3, 2005
    Posts:
    68
    Hi Frederic,

    I am not focused on the FUS windows feature as it is more a confort option than a mandatory one. If I come accross some suggestion to address this limitation I'll tell you ASAP.

    Now as you said :
    Thank you for your ongoing endeavour to make LnS a good product (which is actually the case :) ) and for your real availability to answer questions on this forum which is very much appreciate by everyone. :thumb::thumb::thumb:
     
  14. PolyWon

    PolyWon Registered Member

    Joined:
    Mar 3, 2007
    Posts:
    3
    Where to download or how to get the newest English.lng? Thanks.
     
  15. uc-icq

    uc-icq Registered Member

    Joined:
    Oct 28, 2006
    Posts:
    129
    Hi Frederic,

    Is there a mirror site where I can download 2.06 beta 1 English for Vista? I've got problems connecting to the link you provided. Thanks.

    Kind regards
     
  16. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi,

    Here is another link, but I'm afraid you will get the same error:
    http://www.looknstop.fr/Beta/2.06b1/

    What is the error you get exactly ?

    Frederic
     
  17. General Noel

    General Noel Registered Member

    Joined:
    May 3, 2005
    Posts:
    68
  18. PolyWon

    PolyWon Registered Member

    Joined:
    Mar 3, 2007
    Posts:
    3
    Sorry, but what i say is the newest language file, because i want to translate it.
     
  19. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi,

    I've put the template file with new 2.06b1 strings to be translated here:
    http://looknstop.soft4ever.com/Beta/2.06b1/english_to_X.lng

    Note that you don't need to translate all strings again, you can use the .lng file you had for the 2.05 and just add at the end the new entries.

    Also the new entries are put at the end of english_to_X.lng.

    To know what are the missing entries, you can look at the translation_missing.log file which is created in Look 'n' Stop folder with the IDs of the strings that are missing (under Vista, to get this file, you need to run Look 'n' Stop as Admin).

    Regards,

    Frederic
     
  20. PolyWon

    PolyWon Registered Member

    Joined:
    Mar 3, 2007
    Posts:
    3
    Thanks, Frederic:p
     
  21. uc-icq

    uc-icq Registered Member

    Joined:
    Oct 28, 2006
    Posts:
    129
    Above link worked a treat. Dunno how, with the intial link IDM always suggested timed out. Thanks a bunch.

    A question: When I install on my 32bit Vista HP, it seemed to freeze up in the middle of installing the needed driver...It stayed up there for many a minute and the process couldn't even be terminated via task manager so I had to manually reset...What gives?
     
  22. uc-icq

    uc-icq Registered Member

    Joined:
    Oct 28, 2006
    Posts:
    129
    For your info I had UAC on and Areo Glass, and I didn't turn off the built-in firewall...Which could have been the reason, I wonder?
     
  23. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Sometimes it takes a very long time, it depends on the computer speed also.

    Did you get UAC alert when installing the driver ?
    (not talking about the initial UAC alert when running the setup program, I'm talking about another alert when the driver is installed).

    If you aborted the installation, I'm afraid some information will be now incorrect in the registry.
    If you open the Device Manager, in the network adapter devices, is Look 'n' Stop Driver attached to your ethernet/internet adapters ?

    Frederic
     
  24. BlueMick

    BlueMick Registered Member

    Joined:
    May 1, 2006
    Posts:
    4
    I upgraded about a week ago, and it all went very smoothly, installed over the top of 2.05, rebooted and had no problems at all.

    But today, I twice had Look n Stop telling me that it's own application signature had changed, and did I want to allow it to connect. None of my other security software (I run System Safety Monitor, Nod32, Prevx1 and Ewido/AVG) has reported any issues. I let it go and everything seems okay, but it just seems a little odd.
     
  25. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi,

    Yes, this is very strange.

    You said it happened twice: was it for the same session of Look 'n' Stop, or did you quit & restart Look 'n' Stop between these two occurences ?

    Next time it happens, open the console, ask for driver logs, and send us the result at lnssupport@soft4ever.com.

    Just afer upgrading from the 2.05 to 2.06b1, do you remember if you had a signature change for Look 'n' Stop ?

    Thanks,

    Frederic
     
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.