"Terminal Services" process keeps enabling itself

Discussion in 'other software & services' started by Birdman, Oct 27, 2008.

Thread Status:
Not open for further replies.
  1. Birdman

    Birdman Registered Member

    Joined:
    Nov 24, 2003
    Posts:
    571
    I have set this service to DISABLE, yet every time I reboot my system.....it's set "manual" and it's automatically started.

    Is there a way to permanently disable this service?

    p.s. I'm using Norton Internet Security 2009....could this beenabling terminal services because it needs it?
     
  2. Kerodo

    Kerodo Registered Member

    Joined:
    Oct 5, 2004
    Posts:
    7,787
    Are you sure you're setting it to Disabled? And not Manual? If you set a service to Manual, then it won't run, but sometimes it will be started if needed. As far as I know, setting to Disabled should stay that way.
     
  3. Birdman

    Birdman Registered Member

    Joined:
    Nov 24, 2003
    Posts:
    571
    Yes I'm 100% positive I'm setting it on DISABLED. As soon as I reboot, it's running with it set to manual.

    I'm not sure what is causing terminal services to re-start itself. Some 3rd part application is probably dependent on it running all the time and is re-enabling it. My only guess is NIS 2009 from the google searches that I've done and read.

    I'm hoping that someone here might know more.
     
  4. Seer

    Seer Registered Member

    Joined:
    Feb 12, 2007
    Posts:
    1,596
    Location:
    Singidunum
    Hello Birdman
    and Kerodo.

    Birdman, first thing to do is to state your OS, XP or Vista. Followed by an inspection of service and its dependencies (Vista's Terminal Services differ here from XP's). You will be looking for any 3rd party service that is dependant on Terminal Services.
    Then, stop Terminal Services, set it to "disabled", go to Event Logs, clear them and reboot. After the reboot check Event Logs (now with fresh new entries) on any entry regarding Terminal Services. We are interested here in how it's being started, normally or with an error.

    Then repost back as you're giving us almost no info at all.
     
  5. Birdman

    Birdman Registered Member

    Joined:
    Nov 24, 2003
    Posts:
    571
    Hi. I'm using XP (sp3). Terminal Services does not have an option to stop or start the service. Both tabs are grayed out. You can only select/change the start-up type.
     
  6. Seer

    Seer Registered Member

    Joined:
    Feb 12, 2007
    Posts:
    1,596
    Location:
    Singidunum
    Oh yes, this service can be started or stopped only on reboot. OK, so change its startup to "disabled", clear the logs and reboot. Look at the logs again after the reboot and check dependencies...
     
  7. ThunderZ

    ThunderZ Registered Member

    Joined:
    May 1, 2006
    Posts:
    2,459
    Location:
    North central Ohio, U.S.A.
    Terminal services disabled here, XP Sp3. And it stays that way through every reboot. :rolleyes: As Seer said, check the dependencies.
     
  8. Birdman

    Birdman Registered Member

    Joined:
    Nov 24, 2003
    Posts:
    571
    No errors in the event logs. I finally figured out what was enabling the service on reboot. I also had to DISABLE the service in > terminal Services properties > log on tab > "hardware profile" section > highlight profile and click "disable."

    Upon reboot, the service remained disabled.

    Thanks for your help in this matter. :thumb:
     
Loading...
Thread Status:
Not open for further replies.