System Suite 9.0 Professional Problem

Discussion in 'other software & services' started by DCM, Oct 24, 2008.

Thread Status:
Not open for further replies.
  1. DCM

    DCM Registered Member

    Joined:
    May 25, 2004
    Posts:
    234
    I bought this program a couple of days ago and installed it as soon as it was downloaded.

    Immediately, it caused problems by giving script errors while browsing and every time I shut down Microsoft Office 2003, it gave some kind of Microsoft error. I sent those to Microsoft by using the button for that purpose and then realized that these things were not happening until I installed this program.

    Last night, I uninstalled it and the problems went away.

    Uninstallation seemingly took forever. Slow would not adequately describe the amount of time needed to do what should be a simple task.

    Anyone else had these problems yet?

    By the way, I cannot see any meaningful differences between this version and my previous Version 7 except that the startup was slow and it caused my computer to take much much longer to shut down at the end of the day.

    Makes me wonder if I am a part of their annual annuity program.
     
  2. Baldrick

    Baldrick Registered Member

    Joined:
    May 11, 2002
    Posts:
    2,301
    Location:
    South Wales, UK
    Hi there

    I know it is not much help but I used to use this software but stopped at version 7. I could not see what improvements where being made.

    I switch to System Mechanic which seems to have a more postive impact on my system's health relative to what the utilities element of System Suite seem to be able to do.

    I will not go into the relative merits of each compared to the other; this is just my opinion about how the two behaved on my rig.;)
     
  3. DCM

    DCM Registered Member

    Joined:
    May 25, 2004
    Posts:
    234
    Thanks for the reply. I bought Version 8 and returned it for a refund because I could see no difference between it and Version 7.

    This time, an email arrived offering Version 9 for $19. I figured that after all these years, there must be some improvement. I was wrong and wish I had saved the wasted money.

    I will look into a refund for this too because it did not do anything new except cause problems that I do not want to waste time fixing.

    Thanks again.
     
  4. Baldrick

    Baldrick Registered Member

    Joined:
    May 11, 2002
    Posts:
    2,301
    Location:
    South Wales, UK
    If I might suggest you could take a look at System Mechanic Professional 8 (the equivalent to System Suite). System Mechanic has had a lot of bad press in the past...which was warranted in terms of v6 of the product but the latest incarnation is IMHO excellent.

    I have used a succession of such software; from First Aid, Norton System Works, etc., and System Mechanic is the culmination of these, again IMHO.

    I believe that they offer a competitive upgrade price for those switching from an equivalent application...so if you are tempted you may be able to get a good price. I would certainly take it for a test drive...I did and have not regretted it.:D
     
  5. smokinjoe

    smokinjoe Registered Member

    Joined:
    Feb 6, 2009
    Posts:
    1
    I purchased ss9 and installed it on 3 computers
    Laptop with a Vista home OS - Installed fine but I also get the script errors while browsing the web.

    XP Home OS Desktop I recieve the script errors and all of my video has a slight hesitation .5 sec evry 2 seconds DVD, Mpeg, AVI ... it must have changed some settings somewhere but as of yet I have not Found any changes.

    XP Home OS Laptop - Script Errors, Missing wmp.dll which rendered WMP unusable so I updated to V10 ( Had not used the laptop in a while)
    Now WMP Works but all of m video is choppy as with desk top

    My Vista Laptop Video runs fine.
    I can not be positive but all 3 systems did not print web colors corectly so I went to IE - Tools - internet options - advanced - Scrolled down to Printing and checked off the box (print background colors and images)Did SS9 make this change? What else did it Change
    Who needs this agrivasion!! If you have any commnets or sugestions please reply. After this I just may use a different utility.
     
Loading...
Thread Status:
Not open for further replies.