Start-up files scanning

Discussion in 'ESET Smart Security' started by pegas, Jun 25, 2008.

Thread Status:
Not open for further replies.
  1. pegas

    pegas Registered Member

    Joined:
    May 22, 2008
    Posts:
    2,016
    I have noted the start-up files scanning shall be performed at the successful definition update but only once within 24 hours.

    Having v667. In v657 the scan was executed daily or maximally every other day but under the current build v667 the scan has not been done within 6 days. Hence I run it manually and everything seems OK.

    BUT, does it mean the ESET did in their new build some changes related to this scan or the scan is also dependent on other parameters? All other scheduled tasks run as they should.

    regards,
    pegas
     
  2. Jenee

    Jenee Registered Member

    Joined:
    Dec 27, 2007
    Posts:
    185
    Mine hasn't scanned at startup since I installed the latest version either. It may just be that the date isn't updating. Perhaps someone can advise.
     
  3. pegas

    pegas Registered Member

    Joined:
    May 22, 2008
    Posts:
    2,016
    Glad to hear that someone else encountered it also. I feared I am alone thus something might be wrong with my ESS.

    I call attention of Marcos or Lukas, ESET's members to clarify.
     
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    How do you know? Have you put eicar to the run key to test it?
     
  5. COSMO26

    COSMO26 Registered Member

    Joined:
    Oct 21, 2003
    Posts:
    404
    Marcos, they're saying the Last Date Scanned data needs to be accurate regardless of whether it's Scanning but showing it Did Not - I, too, show a Last Scan After Virus Update of 6/18 (.667 setup correctly & .567 Updated Both Dates OK) BUT my Scan After Logon correctly shows Today a.m. when I logged-on-

    Your eicar suggestion is short on details for my expertise but it would be nice if Pegas or Jenee can prove the Scan Is Occuring After Virus Updates (or Logon) But the Date is just Not changing. I think there is an Issue that needs fixing, particularly if the Scan is Not Occurring.
     
  6. Jenee

    Jenee Registered Member

    Joined:
    Dec 27, 2007
    Posts:
    185
    My last update shows as 27th June but the startup scan date still shows as 20th June for the scan that is done after an update. The scan that is done after logon is correct showing 27th June. I don't know how to tell if the startup scan after update has been running and I don't know what putting eicar to the run key to test it means or how to do it.
     
  7. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    If no threat is found during a startup scan, the results are not logged. Otherwise a bubble with an alert will appear and you'll also see the threat listed in the "Detected threats" log.

    The picture below explains it:
     

    Attached Files:

  8. pegas

    pegas Registered Member

    Joined:
    May 22, 2008
    Posts:
    2,016
    I confirm the exactly same behaviour. Probably only two options, either the scan after startup is not executed at all or the scan is done but the date is stuck old. While doing the startup scan manually (via right click on the task) it shows the correct date. This must be a hitch of v667 as in v657 all dates were showing correctly.
     
  9. COSMO26

    COSMO26 Registered Member

    Joined:
    Oct 21, 2003
    Posts:
    404
    Marcos, the Date data referred to is in the Scheduler module, not Log Files/Detected Threats -
     

    Attached Files:

  10. pegas

    pegas Registered Member

    Joined:
    May 22, 2008
    Posts:
    2,016
    ESET folks, where are you to drop your comments?, we are keen to get know what you are doing with the said shortcoming?

    You should talk to your consumers if you want to retain them!
     
  11. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    A newer version with a fix for this quirk will be released soon.
     
  12. Leschy

    Leschy Registered Member

    Joined:
    Sep 23, 2007
    Posts:
    55
    Location:
    Munich
  13. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
  14. Bubba

    Bubba Updates Team

    Joined:
    Apr 15, 2002
    Posts:
    11,271
    @ member Leschy,

    I have merged your posts concerning EAV scheduling issues and respopnses into the ongoing support thread you started. Let's attempt to keep EAV issues separated from ESS issues Please.

    your ongoing thread---> Start up Scan - never done or just not logged
     
  15. Leschy

    Leschy Registered Member

    Joined:
    Sep 23, 2007
    Posts:
    55
    Location:
    Munich
    OK, sorry, will use the original thread.

    leschy
     
Thread Status:
Not open for further replies.