SS4 - Dont understand Rules and Zones

Discussion in 'ESET Smart Security' started by northridge, Aug 3, 2010.

Thread Status:
Not open for further replies.
  1. northridge

    northridge Registered Member

    Joined:
    Jun 10, 2010
    Posts:
    14
    Using SS4.
    For some reason one of my programs is not asking my "Interective" setup for permission to connect to the net and it definately needs to.
    Thing is, I dont understand the Rules and Zones part - I dont see how to add a program or executable to the list: I get a box asking me to create a new Rule.

    Please explain in simple language how I can simply add a program and allow it bothway communication.

    Thanks
    Nicholas
     
  2. AJStevens

    AJStevens Registered Member

    Joined:
    Aug 27, 2008
    Posts:
    97
    Location:
    Surrey, UK
    Hi Nicholas,

    In Interactive mode you should get a prompt, but from firsthand experience I've had to create some rules manually before as well.

    Firstly, make sure you don't have any other firewalls installed or on, and check Windows Firewall isn't blocking it. Also, worth getting the latest version of ESS as well.

    Ok, I take it you are in the Setup dialog (F5), and looking under Personal firewall and Rules and Zones.

    Zones are networks, bit like network detection in Windows, a choice of Home/Work (Private, allow sharing) and Public (don't allow sharing).

    Rules are where you define what's allowed in or out and you can specify if it applies to the trusted zone or internet (includes trusted).

    Click New to create a new rule through the ESET firewall.

    Name: Give it a name, this doesn't have to be the program name as that's alreay listed, instead create a description, e.g.
    Allow communication for myprogram.exe

    Direction: Unless you have a specific reason, "Both" will do.

    Action: You'll want to change this to "Allow" from the default "Deny" for obvious reasons.

    They've added a recent "Profiles" option, but just ignore that for now and leave as "For every".

    If you wish you can log it, and notify user when it happens, useful for diagnosis or recording certain events, but usually leave them off.

    Move onto the "Local/Remote" Tabs. These are how this rule is matched to a program or communication that you wish to allow.

    Seeing as this is a program on your computer you want to allow, I would recommend choosing the "Application" option on the local Tab, click browse and find the program .exe in your system, typically C:\Program Files\program\program.exe

    You can now click "OK".

    The other options in Local and Remote allow you to open "Ports" instead of specifying an application, if allowing by program doesn't work, find out what Ports it uses and enter them in instead of the application location.

    The settings in Local and Remote are logical ANDs, meaning the more you set in them, the more specific the rule, however unless you wish to filter the remote address coming from or going to, or the local ports that can be used, a normal user is unlikely to want to specify too many settings in here, for more advanced firewall users.

    Click ok all the way back to the main ESET GUI and try your program again.

    There is also the "Learning Mode" option instead of the others, this basically allows anything through the firewall and records rules in the rule list, it's not recommended to run this for a extended period of time, but in situations where you can't get a rule/program to work, it can help create a rule for you. Although, you would have expected Interactive mode to have picked it up if it could, so it's unlikely to help in this situation.

    Don't forget there is a helpfile just a push of F1 away, and guides you can download at www.eset.com/download
     
  3. northridge

    northridge Registered Member

    Joined:
    Jun 10, 2010
    Posts:
    14
    Thank you for the quick and easy to understand reply.
    Problem resolved.
     
Thread Status:
Not open for further replies.