SS 4.2.40 cuts all connections and partially hangs

Discussion in 'ESET Smart Security' started by parkher, Apr 24, 2010.

Thread Status:
Not open for further replies.
  1. parkher

    parkher Registered Member

    Joined:
    Apr 9, 2010
    Posts:
    10
    Until today it worked fine.
    But suddenly today I had massive "connection closed by peer" with uTorrent - through different ISPs and with different trackers.
    Only rebooting helped, but only temporarily. Then again.
    The next time, after a longer time away from my computer, I see the same, but also my browser is no longer able to connect to anything.


    I looked at Smart Security - it became damaged:
    1. Watch activity - does not show anything
    2. Network connections - does not show anything
    3. Update - shows 0%
    4. when opening advanced setup, I get message "could not read firewall configuration".
    5. when attempting to make changes to firewall settings - could not write configuration.

    I tried to reset Smart Security to default - did not help. The same.

    After rebooting - again ok (for a while?)
    After I already started rebooting, I noticed that also PeerBlock was not responding, still, even if PeerBlock somehow hang, Smart Security should not have suffered from that. Not sure which one initiated the problem.

    Perhaps Smart Security is under attack?

    Anyway, I don't know what to do, if it repeats yet again.
    Perhaps to switch off firewall altogether and switch on Windows firewall and see what happens.

    Is it true that with the same license I bought, I can remove Smart Security and install just Nod32 instead?
    It may become necessary.

    One more thought. Maybe, just maybe, the problem was caused by a problematic eSATA controller card.
    I had issues with it several times before - when writing to a disk on that card, occasionally system hangs, even the mouse won't move.
    But before the complete hanging, I noticed once or twice both uTorrent and PeerBlock not responding - the only case when I saw PeerBlock not responding before today.
    Still, I was not writing to the problematic disk this time. And this time there was no complete hanging, just SS blocking everything and not working properly.
     
    Last edited: Apr 24, 2010
  2. Cudni

    Cudni Global Moderator

    Joined:
    May 24, 2009
    Posts:
    6,956
    Location:
    Somethingshire
    check windows event viewer logs for errors or warnings
     
  3. parkher

    parkher Registered Member

    Joined:
    Apr 9, 2010
    Posts:
    10
    No errors or warnings.
    There was a Dhcp 1003 warning during the 1st occurrence, but not during the 2nd one, perhaps no attempt was made to access DHCP server during the 2nd one.
    I found a lot of info messages and 4 error messages too (in system and application), but then I realized they were generated by my rebooting afterwards, not by the problem before. I'll have to investigate and eliminate the errors.

    Anyway, so far this problem did not occur again after more than 12 hours.
    And never occurred before since I installed SS 4.2.40 the next day after it was released.
    Never occurred with SS 4.2.35 which I first installed (bought the license) literally a few hours before 4.2.40 was released.
    There were two back-to-back occurrences earlier today.
    I noticed the 2nd one after 5 hours after the 1st one, but the 2nd one may have occurred sooner.
    I noticed the Smart Security malfunctioning during the 2nd one, did not check the 1st time.
    BTW, during those occurrences, SS firewall was in automatic mode. So far I only used automatic, and, what it's called, automatic with exceptions? - only when I was running an ftp server, because automatic blocked it.
     
    Last edited: Apr 24, 2010
  4. parkher

    parkher Registered Member

    Joined:
    Apr 9, 2010
    Posts:
    10
    UPDATE:

    On Saturday-Sunday I had several times the following problem:

    I see that both PeerBlock and uTorrent are not responding and Eset Smart Security is impaired - it does not show network connections and when attempting to enter advanced settings, cannot open firewall configuration.

    It gets worse: the hanging PeerBlock and uTorrent processes (or process trees) cannot be killed.
    When attempting to reboot, Windows does not finish shutting down,
    it is necessary to press the button, unfortunately.

    Because until Friday there were no such problems, I thought back what changes I made.
    The only change: I started using one more disk for files downloaded/seeded by uTorrent.
    That is an external disk in a box containing two disks, connected via USB.
    One USB connection - two disks visible.
    I have quite a few such boxes connected simultaneously, a couple to eSATA, others to various USB ports.
    This one is different in one thing: both disks in it have no drive letters assigned to them (I ran out of them), but rather paths.
    I had used the other disk in that box with uTorrent some time ago, perhaps months ago - no problems.
    Anyway, I stopped all the torrents with files located on that disk, I moved the files of some torrents that I was still downloading or wanted to continue seeding to other disks. Not using that particular disk with uTorrent anymore.
    No more problems until now.

    Possible things to try:
    1. to use a different USB port or eSATA for that box - and try with uTorrent.
    2. to use drive letters instead of paths - and try with uTorrent.
    If still problems, then
    3. to put the disk into a different box.
    4. to try the disk separately, without a double disk box.
    5. to reduce the number of simultaneously connected external drives and try then: currently I have 8 drives inside the computer connected to SATA, 4 external connected to two eSATA ports (on a separate board, integrated 6+2 all used for internal drives), and 14 hard drives connected to 8 USB ports: two separately, the rest in double-drive boxes. This number varies sometimes, and particular drives or boxes are replaced by different ones, but pretty much this is the picture for some time now - I am making empty promises to myself and New Year resolutions to switch the majority off.
    All my drives are 1 TB or 1.5 TB, except a couple of 0.5 TB drives inside the computer in the mirror configuration with the OS on them and the most valuable stuff. Also 4 other drives inside the computer are in RAID 5.
    6.?

    Anyway, I have no time to play with it at this time.
    No problems reading/writing files from/to that disk as it is.
    Only something happens with uTorrent.

    Still a question - even if the problem is elsewhere, should Smart Security be affected in such a way that it cannot read firewall configuration?
     
    Last edited: Apr 27, 2010
Thread Status:
Not open for further replies.