SQL server port 1433

Discussion in 'NOD32 version 2 Forum' started by fingers, Jul 17, 2003.

Thread Status:
Not open for further replies.
  1. fingers

    fingers Guest

    I installed version 2 on SQL server 2000 and NOD binds to port 1433 which makes SQL fail any suggestions or methods to change the binding order etc for NOD32
     
  2. DolfTraanberg

    DolfTraanberg Registered Member

    Joined:
    Nov 20, 2002
    Posts:
    676
    Location:
    Amsterdam
  3. fingers

    fingers Guest

    Thank you i wil take a look
     
  4. fingers

    fingers Guest

    Noi that is only port stats and usage i wish to know if there is a problem with SQL and NOD32 on same system and if there is a way to make them co-exist
     
  5. DolfTraanberg

    DolfTraanberg Registered Member

    Joined:
    Nov 20, 2002
    Posts:
    676
    Location:
    Amsterdam
    Maybe I don't understand your question, but there is no way to let two applications listen to te same port. I wonder though why NOD should be listening to ANY port.
    Dolf
     
  6. fingers

    fingers Guest

    That is exactly my question. The uninstallation of NOD32 removed the Conflict and SQL started without errors. So the inability to bind by SQL to port 1433 was removed with the uninstall of NOD32 with it installed the reboot had SQL fail to start with the error fail to bind to port1433 which is required to start.

    I dont know why NOD32 would need port 1433 if that is what it is doing or maybe it is a sympton rather that the actual cause. And what i am after is information as to a possible solution if not then NOD32 stays away from my SQL insatllations until it is proved too work in unison
    fingers
     
  7. fryr

    fryr Registered Member

    Joined:
    Jul 15, 2003
    Posts:
    51
    Running "netstat -a" will show you what ports are being listened on. I have NOD32 running and there is no listing for Port 1433.
     
  8. Dan Perez

    Dan Perez Retired Moderator

    Joined:
    May 18, 2003
    Posts:
    1,495
    Location:
    Sunny San Diego
    What was it that was leading you to believe there was a port conflict? (Aside from the apparent incompatibility of the two active processes)

    I also, show no ports open from NOD32. I have the "standard" edition of SQL7 installed though the service is usually stopped. and when I first tried to launch it it did not, however subsequent launches worked fine. Can it be that the on access scanning by AMON interferes (sometimes) with the launch of SQL. You can set an exclusion of that directory tree to see if this resolves the issue for you.

    HTH,

    Dan
     
  9. fryr

    fryr Registered Member

    Joined:
    Jul 15, 2003
    Posts:
    51
    As far as I am aware there is an issue with the exclusion part of NOD32 v2 - it does not work at the moment even though the facility is available via the application entries in the exclusion list are not excluded.

    See http://www.wilderssecurity.com/showthread.php?t=10222
     
  10. Dan Perez

    Dan Perez Retired Moderator

    Joined:
    May 18, 2003
    Posts:
    1,495
    Location:
    Sunny San Diego
    Ahh, yes, you are right! Thanks for the correction, I had been using KAV's on access component rather than NODs so I wasn't aware
     
  11. fingers

    fingers Guest

    The Same thing has now shown to have occured on another system with SQL2k on a windowsXP system. I have tried now to turn off AMON but on reboot the same error occurs, but as you pointed out if you persist in starting the sevice it finally installs, also tried the exclusion of the Database dir and also the Executable dir, and tem dir etc,

    I was thinking is there any way to have Nod32v2 dependent upon the SQL service starting first?
    and also if maybe I turn off memory scan on startup?

    As you have pointed out the Nod32v2 doesn't show binding to port 1433 etc, but if it isnt installed SQL binds normally.

    microsoft in its knowledgebase article http://support.microsoft.com/default.aspx?scid=kb;en-us;293107 states.....
    (Although port 1433 is reserved for use by SQL Server, Winsock applications use random ports above 1024 and therefore may bind to port 1433.)
    a possible indication?
    dave
     
  12. Dan Perez

    Dan Perez Retired Moderator

    Joined:
    May 18, 2003
    Posts:
    1,495
    Location:
    Sunny San Diego
    Hi Dave,

    I don't think it is an ephemeral ports issue as only NOD seems to conflict with SQL and not any of our other, more Internet oriented, apps like our browsers, mail clients, etc all of which use ephemeral ports.

    Your setting a service dependency might work but if it is a compatibility issue, it may be incompatible both ways. However, if you want to try it (and I caution you that this is something that Eset has not given any blessing on one way or the other, and should in any case only be don in a test environment first)

    Open up regedt32 (you can't use regedit for this). I would assume that everything is case-sensitive.

    Go to HKLM\SYSTEM\CurrentControlSet\Services\NOD32krn

    Go to "Edit" -> "Add Value"

    For DataType select "REG_MULTI_SZ"

    For Value Name type "DependOnService" (without quotes ;) )

    When it prompts for the string type "MSSQLServer"

    Then its just a matter of a reboot with crossed fingers :)

    HTH,

    Dan
     
  13. fingers

    fingers Guest

    Thanx Dan,
    Ill give a try with crossed fingers and report back.
    dave
     
  14. fingers

    fingers Guest

    Hi
    just a quickie add i created a reg file for anyone else wishing to
    test this depend on SQL service starting
    the contents are....
    Code:
    REGEDIT4
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NOD32krn]
    "DependOnService"=hex(7):4d,53,53,51,4c,53,65,72,76,65,72,00,00
    just thought that independent test might be helpfull if anyone else has
    SQL2k installed.
    dave
     
  15. Dan Perez

    Dan Perez Retired Moderator

    Joined:
    May 18, 2003
    Posts:
    1,495
    Location:
    Sunny San Diego
    Hey ;)

    I ran the reg file just to be sure it would add the value as a REG_MULTI_SZ and it added okay. Unfortunately though I can't test the efficacy of the dependency as I have AMON disabled by default.

    Dan
     
  16. fingers

    fingers Guest

    no worries!
    i'll build a test Server to see if this results in a :"Solution":, this, if it works will be a workaround, but, is something that ESET might need to resolve or place an exclusion notice on Installation until it is rectified dy default.

    i consider it a fairly serious problem- even though it is only apparent on SQL2k boxes.

    dave
     
  17. fingers

    fingers Registered Member

    Joined:
    Sep 3, 2003
    Posts:
    7
    Location:
    Australia
    just to update with all the activity lately i have been unable to progress very far with this.

    I even managed to be hacked by having a copy of pafildb3.1 installed and forgotten about on my home server....lol

    well im still busy but wouldd like to find a solution to this SQL problem in the near future
     
  18. fingers

    fingers Registered Member

    Joined:
    Sep 3, 2003
    Posts:
    7
    Location:
    Australia
    I have heard that other installs are having the same problem, but not everone, disabling AMON is the only solution I have come up with, but maybe someone will come up with a solution in the near future.
    Will have to wait, aside it is good to see the exclusions prob has come up with a manual hack fix
    I also have heard that developers are working on a fix and would apreciate any information people have pertaining to the install of nodv2 and MSSQL2K
    dave
     
Thread Status:
Not open for further replies.