Spywareguard problem/cannot uninstall/error messages

Discussion in 'SpywareBlaster & Other Forum' started by smiler, Sep 8, 2005.

Thread Status:
Not open for further replies.
  1. smiler

    smiler Registered Member

    Joined:
    Oct 1, 2004
    Posts:
    30
    Hi i have 3 error messages when i boot up and i have finally traced it down to spyware guard after along time!,i went to msconfig and unticked every box 1 at a time until i found the program that was bringing up the error mesages,i unticked the box spyware guard and the error messages never returned on bootup.
    So i decided to uninstall spywareguard and there i had the problem it will not uninstall from add/remove or from program folder- my computer/D Drive/program files/spywareguard or anywhere,i could only remove it from a program called reglite which removed all entries,i then being over zealous i used regscrub and removed 750 invalid entries and ended up messing up my whole pc,luckily i manged to go into safe mode and used retore to restore all my previous settings back to a few days ago-ect,thank god!.
    I downloaded again spywareguard from javacool site full version as i thought it might have got corrupted somehow,i went through the setup but it locked up at the end of it,could not press cancel and task manager could not even close setup it down,i tried to shut down the pc usual way start/shutdown that di not work so i had to press the reset button on the pc to finally shut down.
    On bootup Spyware guard loads up ok and so does the previous error 3 messages,i can get rid of the error messages by clicking the X box 8 times but if i click on the shortcut for SG i get the error messages again,SG is not listed even in the add/remove but is in the start/programs listing?.
    I tried to delete th efolder SG in MyComputer/Ddrive/program files/SG when i click on the folder delete i get this error box appear:-

    X Error deleting file or folder
    Cannot delete dlprotected.dll.Access is denied make sure the disc is not full or write protected and that the file is not currently in use.

    Whats happening i never had problems with SG before,please help tried all i know?.

    smiler
    __________________
    A Small Minded Man Weighs What Can Hinder Him,And Fearful Dares Not Set Off To Work!
     
  2. snowbound

    snowbound Retired Moderator

    Joined:
    Feb 18, 2003
    Posts:
    8,723
    Location:
    The Big Smoke
    I,m not sure what is causing this but can u open Task Manager now?

    If so, go in and kill these 2 processes,

    SGMAIN.EXE

    SGBHP.EXE

    Then exit the program, try to uninstall and reinstall and see if this clears the errors.


    snowbound
     
  3. smiler

    smiler Registered Member

    Joined:
    Oct 1, 2004
    Posts:
    30
    Thanks done that thats sorted the error messages out SpywareGuard was the culprit why i do not know never had a problem in years,i still cannot remove the program folder of SpywareGuard from compure/D DRIVE/Program Files i get this error message box if i try to delete the folder:_

    X Error deleting file or folder
    Cannot delete dlprotect.dll.Access is denied.Make sure the disc is not full or write protected and that the file is not currently in use.

    Cannot work this problem out any idea appreciated,also when i click on Spyware Balster i get the smae 3 error messages come up,seems the 2 javacool programs have become corrupt do you think?,i have uninstalled Spyware Blaster no problem and removed the program folder no proble and am going to download new copy and re-install.

    smiler
     
  4. snowbound

    snowbound Retired Moderator

    Joined:
    Feb 18, 2003
    Posts:
    8,723
    Location:
    The Big Smoke
    Did u uncheck the protection in SWG before u exited and uninstalled?

    If so, did u reboot your computer before trying to install again?

    Looks to me like the Download Protection might be still active....


    snowbound
     
  5. smiler

    smiler Registered Member

    Joined:
    Oct 1, 2004
    Posts:
    30
    Hi snowbound,NO i did not uncheck the protection in swg before i exited and uninstalled maybe thats the problem,also i did not re-boot either but have re-booted many times after that as i needed ro isolate the problem program in msconfig which i did-i have no swg in add/remove but cannot get rid of the program folder,what do i have to do now?

    regards
    smiler
     
  6. snowbound

    snowbound Retired Moderator

    Joined:
    Feb 18, 2003
    Posts:
    8,723
    Location:
    The Big Smoke
    Try reinstalling again(hopefully it will show up in Add and Remove Programs) then uninstall.

    Make sure u uncheck all protection first, then exit the program, uninstall and finally reboot your comp. Also make sure those 2 running processes i posted above are not running in Task Manager before uninstalling.



    snowbound
     
Thread Status:
Not open for further replies.