Something in GSS is blocking logoff scripts

Discussion in 'Ghost Security Suite (GSS)' started by meargh, Dec 3, 2005.

Thread Status:
Not open for further replies.
  1. meargh

    meargh Guest

    I have a CMD script I run at each logoff. This is done by going into Group Policy and double clicking the Logoff entry under User Configuration | Windows Settings | Scripts (Logon/Logoff).

    The actual script I run is C:\WINDOWS\system32\GroupPolicy\User\Scripts\Logoff\logoff.cmd.

    This setup has worked fine for me for months. However, since installing GSS the other day, I see the following error in Event Viewer whenever I reboot:

    I assume that something in GSS, probably AppDefend, is blocking whatever process kicks off the CMD script. The problem is that, without a log being saved to disk, I have no idea what's really going on.

    Before I spend hours figuring out exactly what, can someone point me in the right direction?
     
    Last edited by a moderator: Dec 3, 2005
  2. meargh

    meargh Guest

    Ignore this for now... I'm going to try figuring it out.

    Would be nice if the Wilders admins would re-enable my real account so that I could edit posts and so on.
     
  3. meargh

    meargh Guest

    I think I've got it solved. I added C:\WINDOWS\system32\userinit.exe and gave it permission to Start Applications. I've rebooted once, and no error appeared in Event Viewer.

    I wish this had been a default setting.
     
  4. meargh

    meargh Guest

    Yes, sometimes I post first, and think afterward. Sorry. And it only took a minute to figure out. Well at least there's a reference here for anyone else who needs it...

    But I still wish they'd re-enable my forum account.
     
  5. meargh

    meargh Guest

    BTW, Jason, if you would like a reference (to justify giving userinit.exe permission to launch applications by default), here is where I got my info:

    http://www.microsoft.com/technet/pr...Ref/0c714f15-0405-42d8-ae24-7280211635eb.mspx

    Which of course means that userinit.exe needs to be able to launch cmd.exe.
     
  6. Jason_R0

    Jason_R0 Developer

    Joined:
    Feb 16, 2005
    Posts:
    1,038
    Location:
    Australia
    Thanks meargh,

    I will update the default ruleset to reflect this. :)
     
  7. meargh

    meargh Guest

Thread Status:
Not open for further replies.