Snap Deploy and GRUB

Discussion in 'Other Acronis Products' started by koziel, Oct 17, 2006.

Thread Status:
Not open for further replies.
  1. koziel

    koziel Registered Member

    Joined:
    Oct 16, 2006
    Posts:
    3
    Hello,
    we have installed Snap Deploy 2.0 and created an image which contains two
    operating systems: XP and debian etch with the GRUB loader. The restore to the client works fine, but when we boot the client, we don't get the GRUB menue to select either XP or debian. We get the GRUB shell prompt. We enter
    the kernel path and the initrd path, but booting failed. If we restore the same image with TRUE IMAGE and boot the client the usual GRUB
    OS-Selection menu appears and it works fine. Maybe Snap Deploy overwrites the MBR. Any ideas?

    Best regards and many thanks in advance
    Horst Kozielski
     
    Last edited: Oct 18, 2006
  2. koziel

    koziel Registered Member

    Joined:
    Oct 16, 2006
    Posts:
    3
    hello,
    after booting the client, we don't get the Grub menu, we get only the Grub shell prompt. The reason for this behavior is the following: Grub can't find it's configuration file /boot/grub/menu.lst, and the reason for this is: Snap Deploy alters the bootloader. Normaly we found in /boot/grub/stage2 an entry for the config file like 0.95./boot/grub/menu.lst. But in the deployment this entry is modified to 0.95./boot/grub/grub.conf. After creating a symbolic link
    with ln -s /boot/grub/menu.lst /boot/grub/grub.conf the menu appears.

    I hope this is the correct explanation.
    I would be glad if someone could translate this reply to a better english text.

    Best regards
    Horst Kozielski
     
Thread Status:
Not open for further replies.