Smart Security 3.0.672 causing VMPlayer issues over bridged network

Discussion in 'ESET Smart Security' started by GeneNZ, Oct 15, 2008.

Thread Status:
Not open for further replies.
  1. GeneNZ

    GeneNZ Registered Member

    Joined:
    Oct 15, 2008
    Posts:
    6
    Hi there,

    We currently have recently deployed Eset Smart Security 3.0.627 throughout our organization, and have recently discovered an issue with it and VMPlayer (version 2 and above).

    The issue we are experiencing is we get some general network problems when the WinXP Virtual Machine running is configured in Bridged Ethernet Mode. These general network issues include things like:

    - Not being able to get an IP address from DHCP when the IP address has been released. The moment Eset Firewall is turned off, the VM is this able to get an IP address.
    - Not being able to authenticate against any servers running Samba (the password dialog appears). When the firewall is turned off, the VM is able to access the Samba share with no issues.
    - On the other hand, when the VM has an IP address, it is able to do some network things, like ping servers.

    I have tried various solutions, including adding rules and policies to the firewall, ensuring the networks are in trusted zones, turning off eset firewall features one at a time to determine what the cause is. Again to no avail.

    For the time being we are able to use the VM's in NAT/host-only configuration mode with none of the above issues. But this is not ideal, since we should have access to all options as we need them.

    If anyone has any solutions, it would be greatly appreciated.

    Regards,

    Gene Tang
     
  2. shansmi

    shansmi Registered Member

    Joined:
    Feb 19, 2008
    Posts:
    130
    have you tried putting the firewall in Interactive Mode and letting it learn all these services?
     
  3. GeneNZ

    GeneNZ Registered Member

    Joined:
    Oct 15, 2008
    Posts:
    6
    I have indeed. I have a solution from ESET Support:

    Basically creating rules in the Personal Firewall fixed the problem. By allowing access to each of the VMPlayer executables fixes the problem. However, I'm lazy, and simply gave full access in and out to our private subnet.
     
Thread Status:
Not open for further replies.