Slow Shutdown with Outpost v3.0

Discussion in 'other firewalls' started by kalpik, Oct 9, 2005.

Thread Status:
Not open for further replies.
  1. kalpik

    kalpik Registered Member

    Joined:
    May 26, 2005
    Posts:
    369
    Location:
    Delhi, India
    The screen stays at Windows is shutting down screen for about 25-30 seconds! Does not happen if i exit outpost from the tray icon and then shutdown/restart. Logs are clean.

    Freshly installed Windows XP Professional SP2 with NOD32 AV.

    Thanks
     
  2. kalpik

    kalpik Registered Member

    Joined:
    May 26, 2005
    Posts:
    369
    Location:
    Delhi, India
    Never mind! Fixed when i disabled logging!
     
  3. kalpik

    kalpik Registered Member

    Joined:
    May 26, 2005
    Posts:
    369
    Location:
    Delhi, India
    Nope.. Its still there! Any suggestions?
     
  4. FirePost

    FirePost Registered Member

    Joined:
    Jul 29, 2005
    Posts:
    212
    Hello Kalpik,
    I have a few suggestions. Slow shut downs can occur from windows not releasing user profiles properly. The first thing to try is to add the UPHC service. This is made to help shut down problems by closing these user registry hives that got left behind. You can read about it and get it from Microsoft here.
    http://www.microsoft.com/downloads/details.aspx?FamilyID=1b286e6d-8912-4e18-b570-42470e2f3582&displaylang=en
    That may fix your problem. If not, it also should not hurt anything.

    Outpost 3.0 includes an auto-feedback function that records OS data and keeps a packed version of logs. In the event of an error you can opt to send an error report that contains the data. This packing of the logs etc. may also cause some slowing. You can try excluding op_data.mdb and op_data.ldb and the /log folder from Amon in Nod.

    The third alternative is to use your favorite startup/registry editor preferrably reversible, so you can re-enable if you need to send error reports, and remove the auto run entry for HKLM\..\[Outpost Feedback] <installedpath> feedback.exe /dump: os_startup
     
    Last edited: Oct 9, 2005
  5. Kerodo

    Kerodo Registered Member

    Joined:
    Oct 5, 2004
    Posts:
    7,780
    Interesting! This was a problem for me as well in 2.6 and 2.7, so I avoided using it then. Had to use the User Hive Profile Cleanup thing from MS mentioned above. That will stop Windows from hanging for a long time at the "saving your settings" window or at shutdown in general, but you will still get an error message in your event viewer logs.

    For me, this problem disappeared in the 3.0 release, so it's very weird that it's happening on your machine. But there you have it, so there it is.. ;)

    I found that it did not happen before I entered my registration serial/key. But as soon as I entered it, then it started happening. There is obviously something amiss at shutdown, and you will most likely just have to live with it. If you use the User Hive Profile util above, it will speed up the shutdown hanging though, so you'll just get error messages in event viewer. No big deal really..

    P.S. I am on Win2k, so perhaps it's still a problem with XP and not 2k... don't know..
     
  6. kalpik

    kalpik Registered Member

    Joined:
    May 26, 2005
    Posts:
    369
    Location:
    Delhi, India
    Nope... Didnt help! Thanks for trying anyway! I have now un-installed Outpost. Im on Windows Firewall right now!
     
  7. nick s

    nick s Registered Member

    Joined:
    Nov 20, 2002
    Posts:
    1,430
    Hi kalpik,

    I have seen the same shutdown delay (about 15 seconds more than usual) on three different systems. Might be a side-effect of fixing the issue that was causing the "unexpected service termination" event log error that was common with 2.7 when shutting down the system.

    Nick
     
  8. TairikuOkami

    TairikuOkami Registered Member

    Joined:
    Oct 10, 2005
    Posts:
    2,509
    Location:
    Slovakia
    I have NOD32 and OP 3.0 and no problem. Logging, Feedback and Antispyware plugin disabled.
    By the way, it is better to have slow shutdown, then to use that thing, that is named Firewall.
     
  9. kalpik

    kalpik Registered Member

    Joined:
    May 26, 2005
    Posts:
    369
    Location:
    Delhi, India
    Hmm could not find a better alternative to Outpost, but this slow shutdown thing is really bugging! Please help people!
     
  10. Kerodo

    Kerodo Registered Member

    Joined:
    Oct 5, 2004
    Posts:
    7,780
    There's probably nothing you can do about it other than report it to the Outpost people, who will then probably send you a link and ask you to download their debug plugin, reproduce the problem, and then send them the resulting logs. Good luck.. :)
     
  11. FirePost

    FirePost Registered Member

    Joined:
    Jul 29, 2005
    Posts:
    212
    kalpik,
    Besides what I mentioned before, I tried an experiment and turned off boot sector scan at shutdown in the AV and disabled realtime antispyware in the firewall and shut downs occur in 6-8 seconds total. Maybe if you try the same you will achieve something less maddening for your system.
     
Loading...
Similar Threads
  1. jhr76
    Replies:
    20
    Views:
    1,488
Thread Status:
Not open for further replies.