serveur ftp et lns

Discussion in 'LnS French Forum' started by bprudhon, Aug 11, 2005.

Thread Status:
Not open for further replies.
  1. bprudhon

    bprudhon Registered Member

    Joined:
    Feb 8, 2005
    Posts:
    3
    Bonjour

    J'ai crée un serveur ftp mais lorsque lns est activé ce serveur n'est pas accessible. POurtant j'ai importé les règles adéquates.

    Je suis obligé d'inactiver lns (2.05p2) pour permettre aux personnes habilitées d'accéder à mon serveur.

    Comment faire pour rendre le serveur accessible avec lns activé ??

    Merci pour votre aide
    ram
     
  2. Climenole

    Climenole Look 'n' Stop Expert

    Joined:
    Jun 3, 2005
    Posts:
    1,640
    Bonjour :)

    La position des règles est importante...

    D'une façon générale les règles concernant les serveurs (Http, Ftp ou autres)
    doivent être placées avant la règle de blocage des paquets TCP avec le flag SYN + l'option "bloquer les connections venant du réseau" ...

    La façon de voir où ça coince est d'examiner les entrées du journal.
    Si votre règle de serveur FTP est incorrectement positionnées dans la liste
    vous aurez un blocage par une autre règle qui vous y sera signalé...

    Les règles sont lues en séquence à partir de celle du haut;
    si la règle ne s'applique pas
    alors la règle suivante est examinée
    et ainsi de suite jusqu'à ce qu'une règle corresponde:
    Si la règle correspond
    alors celle-ci est appliquée et les autres règles ne sont pas examinées.
    (Ce comportement peut être modifié : voir la documentation concernant l'option de la 4 ième colonne dans le filtrage internet...)

    Autrement dit il s'agit d'une séquence de "propositions" reliées par
    l'opérateur logique XOR (ou exclusif).
    S'il n'y avait que 2 règles cela serait:
    ou bien la règle 1 ou bien la règle 2.

    Pour une suite de règles c'est :
    Pour toutes les règles il existe une et une seule règle qui s'applique...

    D'où l'importance d'une règle finale de "verrouillage" :
    "Bloquer tous les autres paquets"...

    Tenez-nous au courant.

    :)
     
  3. bprudhon

    bprudhon Registered Member

    Joined:
    Feb 8, 2005
    Posts:
    3
    Merci pour ces infos.

    La règle serveur ftp que j'ai importé (qui autorise les ports 20,21) est placée en tête , en tout cas avant la règle de blocage des paquets TCP avec le flag SYN + l'option "bloquer les connections venant du réseau".

    Donc je ne vois pas trop où est le problème !!??
     
  4. Climenole

    Climenole Look 'n' Stop Expert

    Joined:
    Jun 3, 2005
    Posts:
    1,640
    Alors c'est la règle qui est pas correcte...
    Vérifie dans le journal pour voir où ça coince...

    ;-)
     
  5. Pierre4012

    Pierre4012 Registered Member

    Joined:
    Jan 18, 2005
    Posts:
    58
    Sinon, il faut que tu sache qu'un serveur FTP utilise bien plus que deux ports (par défaut 20 et 21) pour le mode passif, donc il faut que tu règle ces ports dans le serveur, et que tu fasse la règle adéquoite dans lns.
    Tout les serveurs FTP ne le permettent pas, donc si je peut t'en conseiller un c'est celui de filezilla qui est open source, donc gratuit et qui marche super bien.

    Si tu n'y arrive toujours pas, contacte moi.
     
Thread Status:
Not open for further replies.