Securing Messaging Won't Switch Off

Discussion in 'ProcessGuard' started by Syncman9, Feb 12, 2005.

Thread Status:
Not open for further replies.
  1. Syncman9

    Syncman9 Registered Member

    Joined:
    Jul 28, 2004
    Posts:
    113
    Location:
    UK
    Hi,

    I added secure message flag to my firewall. However I've since worked out that I only need it on the service job not the gui.

    However despite removing the flag, the message still pops up. Any ideas?
     
  2. Pilli

    Pilli Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    6,217
    Location:
    Hampshire UK
    Hi syncman99, What firewall are you using and what are your protection settings in ProcessGuard?
    You do not need to add Secure Message Handling to programs or services that do not have a GUI.

    HTH Pilli
     
  3. Syncman9

    Syncman9 Registered Member

    Joined:
    Jul 28, 2004
    Posts:
    113
    Location:
    UK
    Hi I'm using the latest version of Kerio. I may have solved it, since the last time is answered a message, I select OK to ALL and I've had no further ones since.

    The main problem is that Kerio is split into two parts (sorry if you already know), a service and GUI. The GUI can self re-start if an error occurs but has the power to shut down the service.

    I want to prevent the service from being stopped by anything other than me or the machine shutting down.

    If it has to be linked to the GUI, can I setup anything to stop it poping up, every time I answer a message from the GUI. I only want it pop up when I select the shutdown firewall option.

    Hope this makes sense.

    Aaron
     
  4. Pilli

    Pilli Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    6,217
    Location:
    Hampshire UK
    Hi Aaron, You can teach ProcessGuard how to react to different closure methods:

    From the help file.

    Usually ProcessGuard will only ask for human verification when you click on the X button of one of your programs. However if you tried to exit an application by going to the File Menu then clicking on Exit or by clicking on a custom button which exit's the application, you may find ProcessGuard didn't request your verification before closing down. Or you may find that even if you cancel the verifications that ProcessGuard does display, that the application still closes down.

    You can fix this issue by holding down the INSERT key on your keyboard, whilst you click your mouse on a menu item, or button. Now the next time you click on that button or on that menu item, ProcessGuard will request your verification. By holding down the INSERT key you are allowing ProcessGuard to learn that there is other ways that this application can use windows messages to close itself. ProcessGuard will then protect the application from any malicious application which may use these custom messages.

    You can theoretically allow ProcessGuard to learn any menu item or button you want, it doesn't necessarily need to be a button or menu item which closes the application. There could be a menu item which disables your firewall's protection for instance, by holding down INSERT and clicking on it, you are making sure that only you can disable your firewall, not a malicious program.

    If you want to remove any custom messages you made ProcessGuard learn, simply remove Secure Message Handling from the application. This clears ProcessGuard's knowledge of the custom messages for the application. You can then enable it again immediately if you want the feature back on, but the custom messages you defined will be gone for that application.

    This custom message verification is enabled for any application which has Secure Message Handling enabled for it, all you need to do is hold down the INSERT key and click on a button or menu item to activate this feature


    Note: Disabling SMH and restarting the program that it was applied to will reset the SMH settings to none, you can then teach PG the new settings you require.

    HTH Pilli
     
Thread Status:
Not open for further replies.