secure deletion, don't delete folders ?

Discussion in 'Other Ghost Security Software' started by gkweb, Jan 7, 2004.

Thread Status:
Not open for further replies.
  1. gkweb

    gkweb Expert Firewall Tester

    Joined:
    Aug 29, 2003
    Posts:
    1,932
    Location:
    FRANCE, Rouen (76)
    I have added to encrypted archive some stuff, and then when i wanted to secure delete folders, i have noticed that folders aren't deleted, and that few are even renamed with random characters.

    Just do the following test, create :

    C:\Temp\A
    C:\Temp\B

    in each create folders :

    tempa
    tempb

    in each "teampa/tempb" copy a "toto.txt" file

    then secure delete A and B folders.

    For me, all txt files were deleted, tempa and tempb weren't, A folder name stayed A, but B was renammed to D.

    that secure delete doesn't delete folders why not, but don't rename folders with strange name so :)

    (my original deletion has renamed me a folder like "somestuff" into "abdecbabcder")
     
  2. Jason_R0

    Jason_R0 Developer

    Joined:
    Feb 16, 2005
    Posts:
    1,038
    Location:
    Australia
    I noticed something similar with a few folders here too. I will have to check into this and make sure it removes the folder! :) .

    The reason the directory name changes is because CryptoSuite renames the directory/filenames a 100 times before removing them.

    -Jason-
     
  3. ipje

    ipje Registered Member

    Joined:
    Mar 18, 2002
    Posts:
    50
    Location:
    the netherlands
    I'm now having a same problem on my external harddisk, secure delete is doing his job but when I try to delete the folder with "delete" I get the message that the folder is used by another program, only in "safe mode" it's possible to remove the folder :rolleyes:
     
Thread Status:
Not open for further replies.