Seamonkey blocks its own site - what to do?

Discussion in 'other software & services' started by act8192, May 2, 2016.

  1. act8192

    act8192 Registered Member

    Joined:
    Nov 9, 2006
    Posts:
    1,347
    On Windows 10, using SeaMonkey 2.39 I'm trying to download 2.40 and it says certificate is worthless. I use the same link that I always do in Windows 7.
    240-BadCertificate.png
     
  2. amarildojr

    amarildojr Registered Member

    Joined:
    Aug 8, 2013
    Posts:
    2,052
    Location:
    Brasil
    Have you checked the expiration date of the certificate?

    This may sound like a silly question, but does the time on your computer match the actual time of your location?
     
  3. act8192

    act8192 Registered Member

    Joined:
    Nov 9, 2006
    Posts:
    1,347
    Please see "Technical details" in the screenshot above. It's not a time or expiration thing. Though I'm not well versed in this certificate thing, so likely am not looking in correct places.
    It has always worked for me, for years.
    Bad news here - it appears they aren't fixing it
    https://bugzilla.mozilla.org/show_bug.cgi?id=1258123

    Now I can't download from Windows 10 and 7. Has anyone been able to download it?
     
  4. phalanaxus

    phalanaxus Registered Member

    Joined:
    Jan 19, 2011
    Posts:
    499
    I know it doesn't really solve the issue but why don't you download from a site that has other mirrors for the setup, like softpedia ?
     
  5. JRViejo

    JRViejo Global Moderator

    Joined:
    Jul 9, 2008
    Posts:
    23,146
    Location:
    U.S.A.
    The answer lies here: https://bugzilla.mozilla.org/show_bug.cgi?id=1258123#c4

    Change the URL address to the below, and you will download the new version:
    https://download-installer.cdn.mozilla.net/pub/seamonkey/releases/2.40/win32/en-US/SeaMonkey Setup 2.40.exe
     
  6. act8192

    act8192 Registered Member

    Joined:
    Nov 9, 2006
    Posts:
    1,347
    That worked. Thank you, JR.
    I obviously missed the "-installer" part in that bug report :(
    Wonder why their official link is still wrong.
     
  7. JRViejo

    JRViejo Global Moderator

    Joined:
    Jul 9, 2008
    Posts:
    23,146
    Location:
    U.S.A.
    Yes, one would figure that their download links would be checked prior to posting them online, but then... ;)

    act8192, you're welcome! Take care.
     
  8. act8192

    act8192 Registered Member

    Joined:
    Nov 9, 2006
    Posts:
    1,347
    Seven months later their link is still wrong. Amazing.
    Anyway, JR, I just took the link you wrote in post#5, changed to 2.46 in two places and it downloaded just fine. So thanks again :)
     
  9. JRViejo

    JRViejo Global Moderator

    Joined:
    Jul 9, 2008
    Posts:
    23,146
    Location:
    U.S.A.
    Glad it worked once more. Take care.
     
  10. act8192

    act8192 Registered Member

    Joined:
    Nov 9, 2006
    Posts:
    1,347
    There's an annoying bug in 2.46 - search engine preference doesn't hold. The new default is DuckDuckGo, and no matter what's set in preferences or about:config, it's always DDG.
    See known bugs:
    http://www.seamonkey-project.org/releases/seamonkey2.46/
    and a workaround in Comment 6 which seems to work:
    https://bugzilla.mozilla.org/show_bug.cgi?id=1265881
    There's a Search button in the left bottom corner of the sidebar. Set the engine there then use that Search button for searching rather than the usual url place on top. Bit of a pain IMO. I hope they synchronise their setting places.

    Ronjor's thread about SeaMonkey releases doesn't show 2.46 yet.

    Edit: corrected version#
     
    Last edited: Jan 3, 2017
  11. cruelsister

    cruelsister Registered Member

    Joined:
    Nov 6, 2007
    Posts:
    1,135
    Location:
    Paris
    To change the Search Engine you have to actually get rid of DuckDuckGo:

    1). Edit>Preferences>Internet Search
    2). Change your Default Search Engine in the drop down box, then
    3). Go into Manage Search Engines, highlight Ducky and click Remove, then OK out.

    SeaMonkey Quacks no more.
     
  12. act8192

    act8192 Registered Member

    Joined:
    Nov 9, 2006
    Posts:
    1,347
    I thought of that, but decided that it's sometimes useful.
    Quacks no more here either.
    After working on/from the sidebar, AND restarting SeaMonkey, non-Duck search engine (google) is back on the url bar.
     
Loading...