Screen Reader Problem

Discussion in 'General Topics' started by rrrh1, May 26, 2015.

  1. rrrh1

    rrrh1 Registered Member

    Joined:
    Sep 10, 2007
    Posts:
    202
    Some recent change a Wilders is causing me problems reading your site with a screen reader.

    If I highlight a section to read when I let the mouse button up it automatically thinks I want to reply and crashes both the browser and the screen reader.

    If I disable the screen reader the browser does not crash but I am physically unable to read the screen.

    This touch screen compatibility for mobile is hurting those who have handicaps.

    Thanks
     
  2. LowWaterMark

    LowWaterMark Administrator

    Joined:
    Aug 10, 2002
    Posts:
    17,875
    Location:
    New England
    Well, we're only using built-in XenForo functionality. Nothing custom. Can you provide more details?

    First, how long has this been happening. It'd be nice to tie the change as close to the date it started to see just what upgrade of option change might be associated with it.

    My best guess since you mentioned it's related to replying is: The XenForo version 1.4 "highlight to reply" feature. Text that you highlight from a post is captured by Javascript and it presents a click point saying "Reply". If you press that, the highlighted text is automatically inserted into the quick reply box.

    I can see how that unexpected Javascript might be the issue. A test for this is trying to highlight and have the text read while you are logged out of the forum. That Javascript only runs for logged in members. When logged out, there is no capture for auto-reply. If the browser does not crash when logged out, it then points directly to that feature.
     
  3. rrrh1

    rrrh1 Registered Member

    Joined:
    Sep 10, 2007
    Posts:
    202
    If I log out it will work without crashing.

    Apparently it is the feature you mentioned "The XenForo version 1.4 "highlight to reply" feature".

    I guess the short term solution is to stay logged out except when posting.

    Use the screen magnifier (very slow and hard) it does not highlight just magnifies, when writing and reading while logged in.

    Thanks
     
  4. LowWaterMark

    LowWaterMark Administrator

    Joined:
    Aug 10, 2002
    Posts:
    17,875
    Location:
    New England
    I think I have a fix for this. Please try it again.
     
Loading...