Scheduler and daylight savings

Discussion in 'NOD32 version 2 Forum' started by Unknown01, May 5, 2004.

Thread Status:
Not open for further replies.
  1. Unknown01

    Unknown01 Registered Member

    Joined:
    May 5, 2004
    Posts:
    10
    Hello everyone,
    I'm in a part of the world that uses the daylight saving system. When I schedule a custom task it runs an hour earlier than when I schedule it for. Was wondering if anyone had come across this and/or if there was a way around it. . .
     
  2. Bandicoot

    Bandicoot Eset Staff

    Joined:
    Mar 23, 2004
    Posts:
    297
    Location:
    California
    Hello the Unknown01,

    Surely if you configure the Date & Time in the Control Panel on your PC to whatever part of the world you live in, there shouldn't be a problem should there? In Europe the clocks go forward an hour in Spring and back an hour in Autumn and my PC automatically adjusts itself.

    Regards,
    Bandicoot.
     
  3. Unknown01

    Unknown01 Registered Member

    Joined:
    May 5, 2004
    Posts:
    10
    Hi Bandicoot,
    Daylight savings functionality have been enabled on both the computers I've tested and both run scheduled tasks an hour earlier then the time they are scheduled for. When I disable the daylight savings checkbox in Windows, the scheduler runs tasks an hour after they were scheduled for. . .
    Was just wondering if anyone else in a daylight savings zone had encountered this as I would of thought NOD32 would of used the system time to schedule jobs.
    Yes bandicoot my computers auto-adjust time back/forth in regards to daylight savings too, which is fine.
     
  4. Bandicoot

    Bandicoot Eset Staff

    Joined:
    Mar 23, 2004
    Posts:
    297
    Location:
    California
    Hi Unknown01,

    Apparently, lots of people in Australia and New Zealand have been experiencing this problem.... scheduled tasks run an hour earlier than they should.

    There seems to be a slight problem with the time zone thing and the Eset Techno boys will get a fix for it sorted as soon as possible.

    I found that if you uncheck "Automatic daylight savings" in your computer's Control Panel, the scheduled tasks run at the right time. You say they run an hour later than scheduled. I checked, checked and triple checked that my computer thought he/she was living in Auckland, New Zealand and ran scheduled tasks 3 times to make sure they ran at the right time. I think it might be because in the Australian and New Zealand areas, the clocks go forward when they go back in Europe and vice versa......... maybe.

    Anyway, hopefully a proper fix will be sent out soon.

    Bandicoot.
     
Thread Status:
Not open for further replies.