Samsung 850 Evo mSATA SSD

Discussion in 'hardware' started by luciddream, Sep 13, 2015.

  1. luciddream

    luciddream Registered Member

    Mar 22, 2007
    There's an option in the BIOS to set a password for it, under the "Security" heading, "Mini Card SSD Password". I set it. After doing so I noticed it asked me for that password right after prompting me for the BIOS PW, which I what I wanted... a PW that would travel with the drive no matter where it went. But now it no longer prompts me for it, and I don't know why. I never removed it. In fact, when I look in the BIOS it shows that the Mini Card SSD Password is still enabled and set. Yet it doesn't prompt me to enter it when I turn my computer on.

    I tried formatting the drive... to no avail. In fact I can't even do it, as it gives a some error message about a cable being unplugged or something (which isn't true). I also tried to use the Samsung Magician tool and a feature called Secure Erase, but that gave me a message saying it was frozen, locked, or something like that, and unable to help me. It's basically tying my hands here.

    So does anyone have any tips here on how to remedy this situation? How to clear the old PW/key from this thing so I can enter a new one? Recover it? Secure Erase doesn't seem up to the task.
  2. sdmod

    sdmod Shadow Defender Expert

    Oct 28, 2010
    Maybe bootitng or bootit bare metal by Terabyte Unlimited, sometimes will delete and format all when others don't work. If you do try don't have to install it to a drive, just make and run it from the boot disk and choose not to install.

    Low Level Format Tool
    which I understand is free for home use
    Last edited by a moderator: Sep 15, 2015